summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-12-24 13:23:06 +0000
committerMike Frysinger <vapier@gentoo.org>2009-12-24 13:23:06 +0000
commit8d1da71ac77bb0846d2a721dfef34dd30d5cb95b (patch)
tree92b037f266b977dccab7ec296bee09b6ca443dd6 /dev-util/mingw64-runtime
parentold (diff)
downloadgentoo-2-8d1da71ac77bb0846d2a721dfef34dd30d5cb95b.tar.gz
gentoo-2-8d1da71ac77bb0846d2a721dfef34dd30d5cb95b.tar.bz2
gentoo-2-8d1da71ac77bb0846d2a721dfef34dd30d5cb95b.zip
Add fix from upstream for 32bit toolchains #298087 by Alon Bar-Lev.
(Portage version: 2.2_rc60/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/mingw64-runtime')
-rw-r--r--dev-util/mingw64-runtime/ChangeLog7
-rw-r--r--dev-util/mingw64-runtime/files/mingw64-runtime-20091222-mm_shuffle_ps-x86.patch13
-rw-r--r--dev-util/mingw64-runtime/mingw64-runtime-20091222.ebuild11
3 files changed, 27 insertions, 4 deletions
diff --git a/dev-util/mingw64-runtime/ChangeLog b/dev-util/mingw64-runtime/ChangeLog
index ec642cfeaa1d..84baf574e9a2 100644
--- a/dev-util/mingw64-runtime/ChangeLog
+++ b/dev-util/mingw64-runtime/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/mingw64-runtime
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw64-runtime/ChangeLog,v 1.2 2009/12/22 13:49:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw64-runtime/ChangeLog,v 1.3 2009/12/24 13:23:06 vapier Exp $
+
+ 24 Dec 2009; Mike Frysinger <vapier@gentoo.org>
+ mingw64-runtime-20091222.ebuild,
+ +files/mingw64-runtime-20091222-mm_shuffle_ps-x86.patch:
+ Add fix from upstream for 32bit toolchains #298087 by Alon Bar-Lev.
*mingw64-runtime-20091222 (22 Dec 2009)
diff --git a/dev-util/mingw64-runtime/files/mingw64-runtime-20091222-mm_shuffle_ps-x86.patch b/dev-util/mingw64-runtime/files/mingw64-runtime-20091222-mm_shuffle_ps-x86.patch
new file mode 100644
index 000000000000..cedbcac92394
--- /dev/null
+++ b/dev-util/mingw64-runtime/files/mingw64-runtime-20091222-mm_shuffle_ps-x86.patch
@@ -0,0 +1,13 @@
+fix from upstream
+
+--- trunk/mingw-w64-headers/crt/intrin.h 2009/11/10 15:45:03 1517
++++ trunk/mingw-w64-headers/crt/intrin.h 2009/12/23 12:31:10 1672
+@@ -582,7 +582,7 @@
+ __MACHINEX86X_NOWIN64(__m64 _mm_cvtt_ps2pi(__m128))
+ __MACHINEX86X_NOIA64(__m128 _mm_cvt_si2ss(__m128,int))
+ __MACHINEX86X_NOWIN64(__m128 _mm_cvt_pi2ps(__m128,__m64))
+- __MACHINEX86X_NOIA64(__m128 _mm_shuffle_ps(__m128,__m128,unsigned int))
++ __MACHINEX86X_NOIA64(__m128 _mm_shuffle_ps(__m128,__m128,int const))
+ __MACHINEX86X_NOIA64(__m128 _mm_unpackhi_ps(__m128,__m128))
+ __MACHINEX86X_NOIA64(__m128 _mm_unpacklo_ps(__m128,__m128))
+ __MACHINEX86X_NOIA64(__m128 _mm_loadh_pi(__m128,__m64 const*))
diff --git a/dev-util/mingw64-runtime/mingw64-runtime-20091222.ebuild b/dev-util/mingw64-runtime/mingw64-runtime-20091222.ebuild
index b1402df495d7..b732af028ef5 100644
--- a/dev-util/mingw64-runtime/mingw64-runtime-20091222.ebuild
+++ b/dev-util/mingw64-runtime/mingw64-runtime-20091222.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw64-runtime/mingw64-runtime-20091222.ebuild,v 1.1 2009/12/22 13:49:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw64-runtime/mingw64-runtime-20091222.ebuild,v 1.2 2009/12/24 13:23:06 vapier Exp $
export CBUILD=${CBUILD:-${CHOST}}
export CTARGET=${CTARGET:-${CHOST}}
@@ -10,7 +10,7 @@ if [[ ${CTARGET} == ${CHOST} ]] ; then
fi
fi
-inherit flag-o-matic
+inherit flag-o-matic eutils
DESCRIPTION="Free Win64 runtime and import library definitions"
HOMEPAGE="http://mingw-w64.sourceforge.net/"
@@ -37,6 +37,12 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-mm_shuffle_ps-x86.patch #298087
+}
+
src_compile() {
# install the local headers as the crt step wants latest
pushd ../mingw-w64-headers >/dev/null
@@ -64,5 +70,4 @@ src_install() {
emake install DESTDIR="${D}" || die
env -uRESTRICT CHOST=${CTARGET} prepallstrip
rm -rf "${D}"/usr/doc
- dodoc ChangeLog
}