summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2013-02-06 14:55:19 +0000
committerMichael Palimaka <kensington@gentoo.org>2013-02-06 14:55:19 +0000
commit5d62d8c5de95fc557f960fc440f15650ecc8f686 (patch)
tree0b08fd91b98c2ffc97841294f3d11a4ede8929bf /dev-util/monkeystudio
parentFix building on bsd wrt bug#454796. (diff)
downloadgentoo-2-5d62d8c5de95fc557f960fc440f15650ecc8f686.tar.gz
gentoo-2-5d62d8c5de95fc557f960fc440f15650ecc8f686.tar.bz2
gentoo-2-5d62d8c5de95fc557f960fc440f15650ecc8f686.zip
Version bump wrt bug #454524.
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'dev-util/monkeystudio')
-rw-r--r--dev-util/monkeystudio/ChangeLog10
-rw-r--r--dev-util/monkeystudio/files/monkeystudio-1.9.0.4-install.patch26
-rw-r--r--dev-util/monkeystudio/monkeystudio-1.9.0.4.ebuild78
3 files changed, 112 insertions, 2 deletions
diff --git a/dev-util/monkeystudio/ChangeLog b/dev-util/monkeystudio/ChangeLog
index dc84114b0a73..55e98bb926b1 100644
--- a/dev-util/monkeystudio/ChangeLog
+++ b/dev-util/monkeystudio/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/monkeystudio
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monkeystudio/ChangeLog,v 1.1 2012/07/03 17:20:33 kensington Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monkeystudio/ChangeLog,v 1.2 2013/02/06 14:55:19 kensington Exp $
+
+*monkeystudio-1.9.0.4 (06 Feb 2013)
+
+ 06 Feb 2013; Michael Palimaka <kensington@gentoo.org>
+ +files/monkeystudio-1.9.0.4-install.patch, +monkeystudio-1.9.0.4.ebuild:
+ Version bump wrt bug #454524.
*monkeystudio-1.9.0.2 (03 Jul 2012)
diff --git a/dev-util/monkeystudio/files/monkeystudio-1.9.0.4-install.patch b/dev-util/monkeystudio/files/monkeystudio-1.9.0.4-install.patch
new file mode 100644
index 000000000000..0a657d48f208
--- /dev/null
+++ b/dev-util/monkeystudio/files/monkeystudio-1.9.0.4-install.patch
@@ -0,0 +1,26 @@
+* Don't install unneeded docs
+* Don't install all translations
+
+--- installs.pri
++++ installs.pri
+@@ -31,19 +31,9 @@
+ !exists( $${toolsFolder} ):toolsFolder = tools
+ toolsDataFolder = $${toolsFolder}/data/$${dataFolder}
+
+- # licenses, readme, changelog
+- monkey_docs.path = $${PACKAGE_DOCS}
+- monkey_docs.files = GPL-2 \
+- GPL-3 \
+- LGPL-3 \
+- dev-readme \
+- readme.txt \
+- ChangeLog
+- install_folders *= $${monkey_docs.path}
+-
+ # datas
+ monkey_datas.path = $${PACKAGE_DATAS}
+- monkey_datas.files = datas/*
++ monkey_datas.files = datas/apis datas/scripts datas/templates
+ monkey_datas.CONFIG *= no_check_exist
+ install_folders *= $${monkey_datas.path}
+
diff --git a/dev-util/monkeystudio/monkeystudio-1.9.0.4.ebuild b/dev-util/monkeystudio/monkeystudio-1.9.0.4.ebuild
new file mode 100644
index 000000000000..ddb4bb2e7072
--- /dev/null
+++ b/dev-util/monkeystudio/monkeystudio-1.9.0.4.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monkeystudio/monkeystudio-1.9.0.4.ebuild,v 1.1 2013/02/06 14:55:19 kensington Exp $
+
+EAPI=5
+LANGS="be es fr ru"
+
+inherit qt4-r2
+
+MY_P="mks_${PV}-src"
+
+DESCRIPTION="A cross platform Qt 4 IDE"
+HOMEPAGE="http://www.monkeystudio.org"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc plugins"
+
+RDEPEND="plugins? ( >=x11-libs/qt-webkit-4.7.0:4 )
+ >=x11-libs/qt-assistant-4.7.0:4
+ >=x11-libs/qt-core-4.7.0:4
+ >=x11-libs/qt-gui-4.7.0:4
+ >=x11-libs/qt-sql-4.7.0:4
+ x11-libs/qscintilla:="
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.5.8 )"
+
+PATCHES=( "${FILESDIR}/${P}-install.patch" )
+DOCS=( ChangeLog readme.txt )
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # Revert upstream change designed to permit shadow building
+ # which is causing build failure
+ sed -e '/PACKAGE_BUILD_PATH = $$(PWD)\/build/d' \
+ -e 's/#PACKAGE_BUILD_PATH/PACKAGE_BUILD_PATH/' \
+ -i config.pri || die
+
+ rm -r qscintilla/QScintilla-gpl-snapshot \
+ || die "failed removing bundled qscintilla"
+
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ eqmake4 prefix=/usr system_qscintilla=1
+
+ if use plugins ; then
+ eqmake4 plugins/plugins.pro
+ fi
+}
+
+src_install() {
+ qt4-r2_src_install
+
+ if use plugins ; then
+ insinto /usr/lib64/monkeystudio
+ doins -r bin/plugins/*
+ fi
+
+ insinto /usr/share/${PN}/translations
+ local lang
+ for lang in ${LANGS} ; do
+ if use linguas_${lang} ; then
+ doins datas/translations/monkeystudio_${lang}.qm
+ fi
+ done
+
+ fperms 755 /usr/bin/${PN}
+
+ if use doc ; then
+ doxygen || die "doxygen failed"
+ dohtml -r doc/html/*
+ fi
+}