summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-01-06 00:19:34 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-01-06 00:19:34 +0000
commitc840166d5ddfc13f89bab3181e9ba2e426877d07 (patch)
tree97a3dadb0a9fb35bdba803a8180ca8e87f7e41ba /dev-util/ninja-ide
parentrevbump: migrate to distutils-r1 (diff)
downloadgentoo-2-c840166d5ddfc13f89bab3181e9ba2e426877d07.tar.gz
gentoo-2-c840166d5ddfc13f89bab3181e9ba2e426877d07.tar.bz2
gentoo-2-c840166d5ddfc13f89bab3181e9ba2e426877d07.zip
revbump: migrate to distutils-r1
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'dev-util/ninja-ide')
-rw-r--r--dev-util/ninja-ide/ChangeLog9
-rw-r--r--dev-util/ninja-ide/ninja-ide-2.1.1-r2.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/dev-util/ninja-ide/ChangeLog b/dev-util/ninja-ide/ChangeLog
index 3e8b13c4d887..1a0b1a525468 100644
--- a/dev-util/ninja-ide/ChangeLog
+++ b/dev-util/ninja-ide/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/ninja-ide
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ninja-ide/ChangeLog,v 1.4 2012/10/29 16:36:35 mgorny Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ninja-ide/ChangeLog,v 1.5 2013/01/06 00:19:34 hasufell Exp $
+
+*ninja-ide-2.1.1-r2 (06 Jan 2013)
+
+ 06 Jan 2013; Julian Ospald <hasufell@gentoo.org> +ninja-ide-2.1.1-r2.ebuild:
+ revbump: migrate to distutils-r1
29 Oct 2012; Michał Górny <mgorny@gentoo.org> ninja-ide-2.1.1-r1.ebuild:
Use virtual for argparse.
diff --git a/dev-util/ninja-ide/ninja-ide-2.1.1-r2.ebuild b/dev-util/ninja-ide/ninja-ide-2.1.1-r2.ebuild
new file mode 100644
index 000000000000..afa78b3c10a4
--- /dev/null
+++ b/dev-util/ninja-ide/ninja-ide-2.1.1-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ninja-ide/ninja-ide-2.1.1-r2.ebuild,v 1.1 2013/01/06 00:19:34 hasufell Exp $
+
+# XXX: tests
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_6 python2_7 )
+
+inherit gnome2-utils distutils-r1 vcs-snapshot
+
+DESCRIPTION="Ninja-IDE Is Not Just Another IDE"
+HOMEPAGE="http://www.ninja-ide.org"
+SRC_URI="https://github.com/ninja-ide/ninja-ide/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/PyQt4[webkit]
+ dev-python/argparse
+ dev-python/simplejson
+ dev-python/pyinotify
+ virtual/python-argparse"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-lang.patch )
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newicon -s 256 icon.png ${PN}.png
+ make_desktop_entry ${PN} "NINJA-IDE"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}