summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-19 14:08:27 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-19 14:08:27 +0000
commit6526346f8d57d411288d8ae82407c70f3ecef3ae (patch)
tree966b12fbdddea916d222368664b5cb568004afc1 /dev-util/omake
parentFix dependency on sys-apps/dtc due to internal copy of fdt_env.h in QEMU sour... (diff)
downloadgentoo-2-6526346f8d57d411288d8ae82407c70f3ecef3ae.tar.gz
gentoo-2-6526346f8d57d411288d8ae82407c70f3ecef3ae.tar.bz2
gentoo-2-6526346f8d57d411288d8ae82407c70f3ecef3ae.zip
eapi5 and add := dep on ocaml
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-util/omake')
-rw-r--r--dev-util/omake/ChangeLog5
-rw-r--r--dev-util/omake/omake-0.9.8.6.0_rc1.ebuild14
2 files changed, 12 insertions, 7 deletions
diff --git a/dev-util/omake/ChangeLog b/dev-util/omake/ChangeLog
index b4f6a90c7d9c..af7756e608ed 100644
--- a/dev-util/omake/ChangeLog
+++ b/dev-util/omake/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/omake
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/omake/ChangeLog,v 1.25 2013/08/19 14:03:51 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/omake/ChangeLog,v 1.26 2013/08/19 14:08:27 aballier Exp $
+
+ 19 Aug 2013; Alexis Ballier <aballier@gentoo.org> omake-0.9.8.6.0_rc1.ebuild:
+ eapi5 and add := dep on ocaml
19 Aug 2013; Alexis Ballier <aballier@gentoo.org> -omake-0.9.8.5.ebuild,
-files/omake-0.9.8.5-caml_sync.patch, -files/omake-0.9.8.5-lm_printf.patch:
diff --git a/dev-util/omake/omake-0.9.8.6.0_rc1.ebuild b/dev-util/omake/omake-0.9.8.6.0_rc1.ebuild
index 4b2f24696da2..0a5ae3e2d1b6 100644
--- a/dev-util/omake/omake-0.9.8.6.0_rc1.ebuild
+++ b/dev-util/omake/omake-0.9.8.6.0_rc1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/omake/omake-0.9.8.6.0_rc1.ebuild,v 1.3 2012/08/22 23:49:11 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/omake/omake-0.9.8.6.0_rc1.ebuild,v 1.4 2013/08/19 14:08:27 aballier Exp $
+
+EAPI=5
-EAPI=2
inherit toolchain-funcs multilib versionator eutils
MY_PV=$(replace_version_separator 5 '.' "$(replace_version_separator 4 '-' )")
@@ -15,10 +16,11 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ppc x86"
IUSE="doc fam ncurses +ocamlopt readline"
-DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
+DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
ncurses? ( >=sys-libs/ncurses-5.3 )
fam? ( virtual/fam )
readline? ( >=sys-libs/readline-4.3 )"
+RDEPEND="${DEPEND}"
S=${WORKDIR}/${PN}-${MY_PV%-*}
@@ -64,11 +66,11 @@ src_configure() {
}
src_compile() {
- emake all || die "compilation failed"
+ emake all
}
src_install() {
- emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ emake INSTALL_ROOT="${D}" install
dodoc CHANGELOG.txt
if use doc; then
dodoc doc/ps/omake-doc.{pdf,ps} doc/txt/omake-doc.txt