summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-26 01:38:33 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-26 01:38:33 +0000
commit936bf8f1abac4c22d5a4b43c2667cc3bc53698a4 (patch)
treefdfe76ee2541b196ad78f74456ef017f6214a0ab /dev-util/perforce-proxy
parentAdd die following econf for bug 48950 (Manifest recommit) (diff)
downloadgentoo-2-936bf8f1abac4c22d5a4b43c2667cc3bc53698a4.tar.gz
gentoo-2-936bf8f1abac4c22d5a4b43c2667cc3bc53698a4.tar.bz2
gentoo-2-936bf8f1abac4c22d5a4b43c2667cc3bc53698a4.zip
add inherit eutils
Diffstat (limited to 'dev-util/perforce-proxy')
-rw-r--r--dev-util/perforce-proxy/perforce-proxy-2003.1.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/dev-util/perforce-proxy/perforce-proxy-2003.1.ebuild b/dev-util/perforce-proxy/perforce-proxy-2003.1.ebuild
index 2e6f19b88830..858c343e870d 100644
--- a/dev-util/perforce-proxy/perforce-proxy-2003.1.ebuild
+++ b/dev-util/perforce-proxy/perforce-proxy-2003.1.ebuild
@@ -1,34 +1,34 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/perforce-proxy/perforce-proxy-2003.1.ebuild,v 1.3 2004/04/26 01:34:26 vapier Exp $
+
+inherit eutils
DESCRIPTION="Proxy daemon for a commercial version control system"
HOMEPAGE="http://www.perforce.com/"
-URI_BASE="ftp://ftp.perforce.com/perforce/r03.1/"
-BIN_BASE="$URI_BASE/bin.linux24x86"
-DOC_BASE="$URI_BASE/doc"
-SRC_URI="${BIN_BASE}/p4p"
+SRC_URI="ftp://ftp.perforce.com/perforce/r03.1/bin.linux24x86/p4p"
+
LICENSE="perforce.pdf"
SLOT="0"
KEYWORDS="x86"
IUSE=""
+RESTRICT="nomirror nostrip"
+
DEPEND="virtual/glibc"
-#RDEPEND=""
+
S=${WORKDIR}
-RESTRICT="nomirror nostrip"
-MY_FILES=$FILESDIR/perforce-proxy-2003.1/
-src_unpack ()
-{
+MY_FILES=${FILESDIR}/perforce-proxy-2003.1/
+
+src_unpack() {
# we have to copy all of the files from $DISTDIR, otherwise we get
# sandbox violations when trying to install
-
for x in p4p ; do
cp ${DISTDIR}/$x .
done
}
-src_install()
-{
+src_install() {
enewuser perforce
enewgroup perforce