summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-01-04 02:05:50 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-01-04 02:05:50 +0000
commitc255f7da79c9e80baa72ed558ac470cfcbbf7a60 (patch)
treef8b87c3c0ea07fe1286d179770fb7e396de0f95c /dev-util/pkgconfig
parentGen-1 punt. (diff)
downloadgentoo-2-c255f7da79c9e80baa72ed558ac470cfcbbf7a60.tar.gz
gentoo-2-c255f7da79c9e80baa72ed558ac470cfcbbf7a60.tar.bz2
gentoo-2-c255f7da79c9e80baa72ed558ac470cfcbbf7a60.zip
Fix tests to match new CFLAGS behavior; bug #146551
(Portage version: 2.1.2_rc4-r5)
Diffstat (limited to 'dev-util/pkgconfig')
-rw-r--r--dev-util/pkgconfig/ChangeLog8
-rw-r--r--dev-util/pkgconfig/files/pkg-config-0.21-fix-tests.patch22
-rw-r--r--dev-util/pkgconfig/pkgconfig-0.21-r1.ebuild9
3 files changed, 34 insertions, 5 deletions
diff --git a/dev-util/pkgconfig/ChangeLog b/dev-util/pkgconfig/ChangeLog
index d9b1698c1f1e..1ffb83c1b341 100644
--- a/dev-util/pkgconfig/ChangeLog
+++ b/dev-util/pkgconfig/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/pkgconfig
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/ChangeLog,v 1.52 2006/11/06 22:38:14 flameeyes Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/ChangeLog,v 1.53 2007/01/04 02:05:50 dang Exp $
+
+ 04 Jan 2007; Daniel Gryniewicz <dang@gentoo.org>
+ +files/pkg-config-0.21-fix-tests.patch, pkgconfig-0.21-r1.ebuild:
+ Fix tests to match new CFLAGS behavior; bug #146551
*pkgconfig-0.21-r1 (06 Nov 2006)
diff --git a/dev-util/pkgconfig/files/pkg-config-0.21-fix-tests.patch b/dev-util/pkgconfig/files/pkg-config-0.21-fix-tests.patch
new file mode 100644
index 000000000000..8c981667ce4c
--- /dev/null
+++ b/dev-util/pkgconfig/files/pkg-config-0.21-fix-tests.patch
@@ -0,0 +1,22 @@
+diff --exclude-from=/home/dang/.diffrc -up -ruN pkg-config-0.21.orig/check/check-requires-private pkg-config-0.21/check/check-requires-private
+--- pkg-config-0.21.orig/check/check-requires-private 2006-08-16 13:05:30.000000000 -0400
++++ pkg-config-0.21/check/check-requires-private 2007-01-03 20:49:56.000000000 -0500
+@@ -9,14 +9,14 @@ set -e
+
+ . ${srcdir}/common
+
+-# expect cflags from requires-test and public-dep
++# expect cflags from requires-test, public-dep, and private-dep
+ ARGS="--cflags requires-test"
+-RESULT="-I/requires-test/include -I/public-dep/include"
++RESULT="-I/requires-test/include -I/private-dep/include -I/public-dep/include"
+ run_test
+
+-# still expect those cflags for static linking case
++# still expect cflags from requires-test, public-dep, and private-dep
+ ARGS="--static --cflags requires-test"
+-RESULT="-I/requires-test/include -I/public-dep/include"
++RESULT="-I/requires-test/include -I/private-dep/include -I/public-dep/include"
+ run_test
+
+ # expect libs for just requires-test and public-dep
diff --git a/dev-util/pkgconfig/pkgconfig-0.21-r1.ebuild b/dev-util/pkgconfig/pkgconfig-0.21-r1.ebuild
index a84f09c756c9..3b4964d77617 100644
--- a/dev-util/pkgconfig/pkgconfig-0.21-r1.ebuild
+++ b/dev-util/pkgconfig/pkgconfig-0.21-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/pkgconfig-0.21-r1.ebuild,v 1.1 2006/11/06 22:38:14 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/pkgconfig-0.21-r1.ebuild,v 1.2 2007/01/04 02:05:50 dang Exp $
-inherit flag-o-matic
+inherit flag-o-matic eutils
MY_P="pkg-config"-${PV}
DESCRIPTION="Package config system that manages compile/link flags"
@@ -22,6 +22,9 @@ S=${WORKDIR}/${MY_P}
src_unpack() {
unpack "${A}"
+ cd "${S}"
+
+ epatch ${FILESDIR}/${MY_P}-fix-tests.patch
use ppc64 && use hardened && replace-flags -O[2-3] -O1
}