summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-17 04:25:08 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-17 04:25:08 +0000
commit0db6f990b2acf47c2929a68e1602e68244cd7d9a (patch)
tree8b76fd5018505e9048799d8039ef875dff9f011d /dev-util/pstack/pstack-1.1-r1.ebuild
parentRespect LDFLAGS (bug #335093), CC, CFLAGS. (diff)
downloadgentoo-2-0db6f990b2acf47c2929a68e1602e68244cd7d9a.tar.gz
gentoo-2-0db6f990b2acf47c2929a68e1602e68244cd7d9a.tar.bz2
gentoo-2-0db6f990b2acf47c2929a68e1602e68244cd7d9a.zip
Respect LDFLAGS (bug #335300), CFLAGS, and do not hard-wire CC.
(Portage version: 2.2_rc82/cvs/Linux i686)
Diffstat (limited to 'dev-util/pstack/pstack-1.1-r1.ebuild')
-rw-r--r--dev-util/pstack/pstack-1.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/pstack/pstack-1.1-r1.ebuild b/dev-util/pstack/pstack-1.1-r1.ebuild
new file mode 100644
index 000000000000..825c71136f53
--- /dev/null
+++ b/dev-util/pstack/pstack-1.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pstack/pstack-1.1-r1.ebuild,v 1.1 2010/09/17 04:25:08 jer Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Display stack trace of a running process."
+SRC_URI="mirror://gentoo/${PN}.tgz"
+HOMEPAGE="http://www.linuxcommand.org/man_pages/pstack1.html"
+# Old upstream HOMEPAGE: www.whatsis.com/pastack is dead, using
+# the man page at the moment.
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 -ppc -sparc -alpha"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ # respect CC variable see bug #244036
+ sed -i Makefile \
+ -e 's:gcc:$(CC) $(CFLAGS) $(LDFLAGS):' \
+ || die "sed Makefile"
+ tc-export CC
+}
+
+src_install() {
+ dosbin pstack || die "dosbin failed"
+ doman man1/pstack.1
+}