summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-01-06 05:26:09 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-01-06 05:26:09 +0000
commitbbc37e5d2d09e21de37925d61f3dba6784022a6b (patch)
treeac37002f25e738584740580073a1955ae2f412d1 /dev-util/shc
parentversion update. Seems to fix a few glitches in previous version. (diff)
downloadgentoo-2-bbc37e5d2d09e21de37925d61f3dba6784022a6b.tar.gz
gentoo-2-bbc37e5d2d09e21de37925d61f3dba6784022a6b.tar.bz2
gentoo-2-bbc37e5d2d09e21de37925d61f3dba6784022a6b.zip
new package - A (shell-) script compiler/scrambler.
Diffstat (limited to 'dev-util/shc')
-rw-r--r--dev-util/shc/ChangeLog13
-rw-r--r--dev-util/shc/files/digest-shc-3.41
-rw-r--r--dev-util/shc/shc-3.4.ebuild33
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/shc/ChangeLog b/dev-util/shc/ChangeLog
new file mode 100644
index 000000000000..ec3619bf73e6
--- /dev/null
+++ b/dev-util/shc/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for dev-util/shc
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-util/shc/ChangeLog,v 1.1 2003/01/06 05:26:09 george Exp $
+
+*shc-3.4.ebuild (05 Jan 2003)
+
+ 05 Jan 2003; George Shapovalov <george@gentoo.org> ChangeLog, shc-3.4.ebuild, files/digest-shc-3.4 :
+ initial release (#12633)
+ ebuild submitted by Tom <Eckert.Thomas@gmx.net>.
+ shc is a compiler/scrambler for interpreter-languages. As long as the
+ interpreter can read it's script from the command-line you can use shc
+ to hide your code -- well this is not very open-source like, but
+ sometimes this may be wanted. The main-target was shell-code.
diff --git a/dev-util/shc/files/digest-shc-3.4 b/dev-util/shc/files/digest-shc-3.4
new file mode 100644
index 000000000000..3d378f06d332
--- /dev/null
+++ b/dev-util/shc/files/digest-shc-3.4
@@ -0,0 +1 @@
+MD5 cd25623484d9f06af823de0199f94f30 shc-3.4.tgz 16645
diff --git a/dev-util/shc/shc-3.4.ebuild b/dev-util/shc/shc-3.4.ebuild
new file mode 100644
index 000000000000..2fe685d8eb5d
--- /dev/null
+++ b/dev-util/shc/shc-3.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-util/shc/shc-3.4.ebuild,v 1.1 2003/01/06 05:26:09 george Exp $
+
+IUSE=""
+
+DESCRIPTION="A (shell-) script compiler/scrambler."
+SRC_URI="http://www.datsi.fi.upm.es/~frosal/sources/${P}.tgz"
+HOMEPAGE="http://www.datsi.fi.upm.es/~frosal"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc ~sparc ~sparc64 ~alpha"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${P}.tgz
+ cd ${S}
+}
+
+src_compile() {
+ ## the "test"-target leads to an access-violation -> so we skip it
+ ## as it's only for demonstration purposes anyway.
+ make shc || die
+}
+
+src_install () {
+ exeinto /usr/bin
+ doexe shc
+ doman shc.1
+ dodoc shc.README CHANGES
+}