summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-12-12 05:17:42 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-12-12 05:17:42 +0000
commitabcd18451a5fc6254e03754194a804328f4f1f95 (patch)
tree6b8510636929d085c48067322810745f688fdda3 /dev-util/wiggle/wiggle-0.6-r2.ebuild
parentAdd modular X dependencies. (diff)
downloadgentoo-2-abcd18451a5fc6254e03754194a804328f4f1f95.tar.gz
gentoo-2-abcd18451a5fc6254e03754194a804328f4f1f95.tar.bz2
gentoo-2-abcd18451a5fc6254e03754194a804328f4f1f95.zip
Version bump.
(Portage version: 2.0.53)
Diffstat (limited to 'dev-util/wiggle/wiggle-0.6-r2.ebuild')
-rw-r--r--dev-util/wiggle/wiggle-0.6-r2.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-util/wiggle/wiggle-0.6-r2.ebuild b/dev-util/wiggle/wiggle-0.6-r2.ebuild
new file mode 100644
index 000000000000..da8ddeda1239
--- /dev/null
+++ b/dev-util/wiggle/wiggle-0.6-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/wiggle/wiggle-0.6-r2.ebuild,v 1.1 2005/12/12 05:14:14 robbat2 Exp $
+
+inherit eutils
+
+PATCHDATE=20051211
+PATCHBALL=${P}-patches-${PATCHDATE}
+DESCRIPTION="program for applying patches that patch cannot apply because of conflicting changes"
+HOMEPAGE="http://cgi.cse.unsw.edu.au/~neilb/source/wiggle/"
+SRC_URI="http://cgi.cse.unsw.edu.au/~neilb/source/wiggle/${P}.tar.gz
+ mirror://gentoo/${PATCHBALL}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+# The 'p' tool does support bitkeeper, but I'm against just dumping it in here
+# due to it's size. I've explictly listed every other dependancy here due to
+# the nature of the shell program 'p'
+RDEPEND="dev-util/diffstat
+ dev-util/patchutils
+ sys-apps/diffutils
+ sys-apps/findutils
+ sys-apps/gawk
+ sys-apps/grep
+ sys-apps/less
+ sys-apps/sed
+ sys-apps/coreutils
+ sys-devel/patch"
+DEPEND="${RDEPEND}
+ sys-apps/groff
+ sys-process/time"
+
+PATCHLIST="001NoQuietTime 002SpecFile 003Recommit 004ExtractFix 005Pchanges
+007Stuff"
+# excluded: 006NoDebug 008NewMerge2
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ for i in ${PATCHLIST}; do
+ epatch ${WORKDIR}/${PATCHBALL}/${i}
+ done;
+}
+
+src_compile() {
+ emake OptDbg="${CFLAGS}" || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dobin p
+ dodoc ANNOUNCE INSTALL TODO DOC/diff.ps p.help notes
+}