summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-06-05 20:04:08 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-06-05 20:04:08 +0000
commit5c6f2710325563fc39883e7e16c3d2b65475983e (patch)
treea5bc495c61ddd67034229c6749ec67457414f572 /dev-util
parentRemoving games-fps/americas-army. (diff)
downloadgentoo-2-5c6f2710325563fc39883e7e16c3d2b65475983e.tar.gz
gentoo-2-5c6f2710325563fc39883e7e16c3d2b65475983e.tar.bz2
gentoo-2-5c6f2710325563fc39883e7e16c3d2b65475983e.zip
Fixed ICU compilation bug
(Portage version: 2.1.5.4)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/boost-build/ChangeLog9
-rw-r--r--dev-util/boost-build/boost-build-1.35.0-r1.ebuild (renamed from dev-util/boost-build/boost-build-1.35.0.ebuild)5
-rw-r--r--dev-util/boost-build/files/1.35.0-fix_broken_icu_build.patch33
3 files changed, 45 insertions, 2 deletions
diff --git a/dev-util/boost-build/ChangeLog b/dev-util/boost-build/ChangeLog
index cb7396e646f3..dde2f6df431f 100644
--- a/dev-util/boost-build/ChangeLog
+++ b/dev-util/boost-build/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/boost-build
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/ChangeLog,v 1.24 2008/05/05 17:47:46 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/ChangeLog,v 1.25 2008/06/05 20:04:07 dev-zero Exp $
+
+*boost-build-1.35.0-r1 (05 Jun 2008)
+
+ 05 Jun 2008; Tiziano Müller <dev-zero@gentoo.org>
+ +files/1.35.0-fix_broken_icu_build.patch, -boost-build-1.35.0.ebuild,
+ +boost-build-1.35.0-r1.ebuild:
+ Fixed ICU compilation bug
05 May 2008; Jeroen Roovers <jer@gentoo.org> boost-build-1.34.1.ebuild,
boost-build-1.35.0.ebuild:
diff --git a/dev-util/boost-build/boost-build-1.35.0.ebuild b/dev-util/boost-build/boost-build-1.35.0-r1.ebuild
index 11cdd32658b8..cca933adb395 100644
--- a/dev-util/boost-build/boost-build-1.35.0.ebuild
+++ b/dev-util/boost-build/boost-build-1.35.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.35.0.ebuild,v 1.2 2008/05/05 17:47:46 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.35.0-r1.ebuild,v 1.1 2008/06/05 20:04:07 dev-zero Exp $
inherit flag-o-matic toolchain-funcs versionator
@@ -22,6 +22,9 @@ S=${WORKDIR}/boost_${MY_PV}/tools
src_unpack() {
unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PV}-fix_broken_icu_build.patch"
# Remove stripping option
cd "${S}/jam/src"
diff --git a/dev-util/boost-build/files/1.35.0-fix_broken_icu_build.patch b/dev-util/boost-build/files/1.35.0-fix_broken_icu_build.patch
new file mode 100644
index 000000000000..b4611054c9b0
--- /dev/null
+++ b/dev-util/boost-build/files/1.35.0-fix_broken_icu_build.patch
@@ -0,0 +1,33 @@
+--- trunk/tools/build/v2/build/targets.jam (revision 45072)
++++ trunk/tools/build/v2/build/targets.jam (revision 45245)
+@@ -1170,5 +1170,5 @@
+ ECHO [ targets.indent ] "Building target '$(fn)'" ;
+ targets.increase-indent ;
+- ECHO [ targets.indent ] "Build request: " [ $(property-set).raw ] ;
++ ECHO [ targets.indent ] "Build request: " $(property-set) [ $(property-set).raw ] ;
+ local cf = [ build-system.command-line-free-features ] ;
+ ECHO [ targets.indent ] "Command line free features: " [ $(cf).raw ] ;
+@@ -1275,5 +1275,14 @@
+ # case we don't want any diagnostic. In the former case, we need
+ # diagnostics. FIXME
+- self.generated.$(property-set) = $(rproperties) ;
++
++ # If this target fails to build, add <build>no to properties
++ # to cause any parent target to fail to build. Except that it
++ # - does not work now, since we check for <build>no only in
++ # common properties, but not in properties that came from
++ # dependencies
++ # - it's not clear if that's a good idea anyway. The alias
++ # target, for example, should not fail to build if a dependency
++ # fails.
++ self.generated.$(property-set) = [ property-set.create <build>no ] ;
+ }
+ }
+@@ -1283,4 +1292,7 @@
+ {
+ ECHO [ targets.indent ] "Already built" ;
++ local ur = $(self.generated.$(property-set)) ;
++ ur = $(ur[0]) ;
++ ECHO [ targets.indent ] " Usage requirements " [ $(ur).raw ] ;
+ }
+ }