summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2004-06-02 06:22:03 +0000
committerRyan Phillips <rphillips@gentoo.org>2004-06-02 06:22:03 +0000
commit5c98d0426ac225b5e6cc5c4eea0497c72f054bc9 (patch)
treef203c6d79096121193ec30399a04f826b48da529 /dev-util
parentWork around upgrade problem where people have Option "XkbRules" "xfree86" in ... (diff)
downloadgentoo-2-5c98d0426ac225b5e6cc5c4eea0497c72f054bc9.tar.gz
gentoo-2-5c98d0426ac225b5e6cc5c4eea0497c72f054bc9.tar.bz2
gentoo-2-5c98d0426ac225b5e6cc5c4eea0497c72f054bc9.zip
fixes bug #51586 and security flaw in libneon
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/tla/ChangeLog9
-rw-r--r--dev-util/tla/Manifest5
-rw-r--r--dev-util/tla/files/digest-tla-1.2-r21
-rw-r--r--dev-util/tla/files/tla-1.2-4.diff.gzbin0 -> 42048 bytes
-rw-r--r--dev-util/tla/tla-1.2-r2.ebuild61
5 files changed, 74 insertions, 2 deletions
diff --git a/dev-util/tla/ChangeLog b/dev-util/tla/ChangeLog
index d35820662abe..6661009d5900 100644
--- a/dev-util/tla/ChangeLog
+++ b/dev-util/tla/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/tla
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/tla/ChangeLog,v 1.11 2004/05/28 17:47:17 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/tla/ChangeLog,v 1.12 2004/06/02 06:22:03 rphillips Exp $
+
+*tla-1.2-r2 (01 Jun 2004)
+
+ 01 Jun 2004; <rphillips@gentoo.org> tla-1.2-r2.ebuild,
+ files/tla-1.2-4.diff.gz:
+ Added the debian patch from bob2 in #arch to use the external libneon library.
+ Added >=neon-0.24.6 dep
*tla-1.2.1_pre1 (28 May 2004)
diff --git a/dev-util/tla/Manifest b/dev-util/tla/Manifest
index 5760e3d25af5..e206196d1ea8 100644
--- a/dev-util/tla/Manifest
+++ b/dev-util/tla/Manifest
@@ -2,11 +2,14 @@ MD5 325e4f2b5cc665721caf05e7d3390c9a tla-1.2-r1.ebuild 1413
MD5 b66406be8d578da0eaccc851890de68e tla-1.0.6.ebuild 681
MD5 b6084d5aa2c0d621d81db4ff1365f23f tla-1.2.1_pre1.ebuild 1397
MD5 6331b3366acda102708b6a9f143553c9 tla-1.2.ebuild 1179
-MD5 be2bad69dfe34cb5681258315db8b8af ChangeLog 1670
+MD5 8c9c2b6f882c1c5e865828a5253156cc ChangeLog 1889
MD5 059733ad92a101895ce18a1120b6eb55 metadata.xml 225
+MD5 cd6224607f7c1f1a7cef429ba7eb764b tla-1.2-r2.ebuild 1564
MD5 8bf32a86442639f22f5e1adea9d4e0dd tla-1.1.ebuild 1143
MD5 3ec8ea660ee7876816a3ba908a8a58cc files/digest-tla-1.2.1_pre1 66
MD5 114be5c071f8499729d00621fa01bec4 files/digest-tla-1.2-r1 60
+MD5 114be5c071f8499729d00621fa01bec4 files/digest-tla-1.2-r2 60
MD5 4b643d505f794a0b0eca53e21efb3074 files/digest-tla-1.0.6 62
MD5 ed771c44099e7c67530910caaa54d279 files/digest-tla-1.1 60
MD5 114be5c071f8499729d00621fa01bec4 files/digest-tla-1.2 60
+MD5 7581a6d32e24bbcae4c8ad3f9521348b files/tla-1.2-4.diff.gz 42048
diff --git a/dev-util/tla/files/digest-tla-1.2-r2 b/dev-util/tla/files/digest-tla-1.2-r2
new file mode 100644
index 000000000000..f6c240d56ab1
--- /dev/null
+++ b/dev-util/tla/files/digest-tla-1.2-r2
@@ -0,0 +1 @@
+MD5 1fbc9cd83c37ad6e88e9e6a5f0b62871 tla-1.2.tar.gz 4421771
diff --git a/dev-util/tla/files/tla-1.2-4.diff.gz b/dev-util/tla/files/tla-1.2-4.diff.gz
new file mode 100644
index 000000000000..ac4bc3b1c00f
--- /dev/null
+++ b/dev-util/tla/files/tla-1.2-4.diff.gz
Binary files differ
diff --git a/dev-util/tla/tla-1.2-r2.ebuild b/dev-util/tla/tla-1.2-r2.ebuild
new file mode 100644
index 000000000000..8f4802bceb1e
--- /dev/null
+++ b/dev-util/tla/tla-1.2-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/tla/tla-1.2-r2.ebuild,v 1.1 2004/06/02 06:22:03 rphillips Exp $
+
+inherit eutils
+
+MY_P="${P/_/}"
+
+S="${WORKDIR}/${MY_P}/src/=build"
+DESCRIPTION="Revision control system ideal for widely distributed development"
+SRC_URI="http://arch.quackerhead.com/~lord/releases/tla/${MY_P}.tar.gz"
+HOMEPAGE="http://arch.quackerhead.com/~lord/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 alpha ppc mips hppa sparc ~amd64"
+
+DEPEND="sys-apps/coreutils
+ >=net-misc/neon-0.24.6
+ sys-apps/diffutils
+ sys-devel/patch
+ sys-apps/findutils
+ sys-apps/gawk
+ app-arch/tar
+ sys-apps/util-linux
+ sys-apps/debianutils
+ sys-devel/make"
+
+src_unpack() {
+ unpack "${A}"
+ mkdir "${MY_P}/src/=build"
+
+ # rphillips 2004-06-01
+ # patch to build tla with the external libneon
+ epatch ${FILESDIR}/tla-1.2-4.diff.gz
+}
+
+src_compile() {
+ sed -i 's:/home/lord/{install}:/usr:g' "${WORKDIR}/${MY_P}/src/tla/=gpg-check.awk"
+ ../configure \
+ --prefix="/usr" \
+ --with-posix-shell="/bin/bash" || die "configure failed"
+ # parallel make may cause problems with this package
+ make || die "make failed"
+}
+
+src_install () {
+ make install prefix="${D}/usr" \
+ || die "make install failed"
+ cd ${WORKDIR}/${MY_P}/src
+ dodoc COPYING
+ cd docs-tla
+ dodoc =README
+ docinto ps
+ dodoc ps/*.ps
+ docinto html
+ dohtml -r html/
+
+ chmod 755 "${WORKDIR}/${MY_P}/src/tla/=gpg-check.awk"
+ cp -a "${WORKDIR}/${MY_P}/src/tla/=gpg-check.awk" "${D}/usr/bin/tla-gpg-check.awk"
+}