summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-04-04 07:13:30 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-04-04 07:13:30 +0000
commit8e7861c1cb60ec0b226e570c4b993fe5aac849c7 (patch)
tree2ea1fdf8d93072949e585cd502b0a888ed97f934 /dev-util
parentstable x86, security bug 215694 (diff)
downloadgentoo-2-8e7861c1cb60ec0b226e570c4b993fe5aac849c7.tar.gz
gentoo-2-8e7861c1cb60ec0b226e570c4b993fe5aac849c7.tar.bz2
gentoo-2-8e7861c1cb60ec0b226e570c4b993fe5aac849c7.zip
Add a more upstream upstream version. The fork that powers git.overlays.gentoo.org is now moving to dev-util/gitosis-gentoo.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gitosis/ChangeLog11
-rw-r--r--dev-util/gitosis/gitosis-0.2_p20080319.ebuild41
2 files changed, 50 insertions, 2 deletions
diff --git a/dev-util/gitosis/ChangeLog b/dev-util/gitosis/ChangeLog
index b902dfdeadff..043ba1a2226d 100644
--- a/dev-util/gitosis/ChangeLog
+++ b/dev-util/gitosis/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/gitosis
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gitosis/ChangeLog,v 1.2 2007/12/25 12:24:56 robbat2 Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gitosis/ChangeLog,v 1.3 2008/04/04 07:13:30 robbat2 Exp $
+
+*gitosis-0.2_p20080319 (04 Apr 2008)
+
+ 04 Apr 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +gitosis-0.2_p20080319.ebuild:
+ Add a more upstream upstream version. The fork that powers
+ git.overlays.gentoo.org is now moving to dev-util/gitosis-gentoo.
25 Dec 2007; Robin H. Johnson <robbat2@gentoo.org>
gitosis-0.2_p20071217.ebuild:
diff --git a/dev-util/gitosis/gitosis-0.2_p20080319.ebuild b/dev-util/gitosis/gitosis-0.2_p20080319.ebuild
new file mode 100644
index 000000000000..1b874eee0c69
--- /dev/null
+++ b/dev-util/gitosis/gitosis-0.2_p20080319.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gitosis/gitosis-0.2_p20080319.ebuild,v 1.1 2008/04/04 07:13:30 robbat2 Exp $
+
+inherit distutils
+
+DESCRIPTION="gitosis -- software for hosting git repositories"
+HOMEPAGE="http://eagain.net/gitweb/?p=gitosis.git;a=summary"
+# This is a snapshot taken from the upstream gitweb.
+MY_PV="20080319-4d8ba7788d10e62928404b0272de241580e00e92"
+MY_PN="${PN}.git"
+MY_P="${MY_PN}-${MY_PV}"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE=""
+DEPEND=">=dev-util/git-1.5.3.6
+ >=dev-python/setuptools-0.6_rc5"
+RDEPEND="${DEPEND}
+ !dev-util/gitosis-gentoo"
+
+S=${WORKDIR}/gitosis
+
+DOCS="example.conf gitweb.conf lighttpd-gitweb.conf TODO.rst"
+
+pkg_setup() {
+ enewgroup git
+ enewuser git -1 /bin/sh /var/spool/gitosis git
+}
+
+src_install() {
+ distutils_src_install
+ keepdir /var/spool/gitosis
+ fowners git:git /var/spool/gitosis
+}
+
+# We should handle more of this, but it requires the input of an SSH public key
+# from the user, and they may want to set up more configuration first.
+#pkg_config() {
+#}