summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2013-06-14 17:17:22 +0000
committerMichael Palimaka <kensington@gentoo.org>2013-06-14 17:17:22 +0000
commit9f76a536fc4f35bf092ba105880051678dadc503 (patch)
treeebc1c90a6243ae48725a166a8c815be5482fc1a6 /dev-util
parentadd wavpack useflag (diff)
downloadgentoo-2-9f76a536fc4f35bf092ba105880051678dadc503.tar.gz
gentoo-2-9f76a536fc4f35bf092ba105880051678dadc503.tar.bz2
gentoo-2-9f76a536fc4f35bf092ba105880051678dadc503.zip
Fix tests by David Leverton <levertond@googlemail.com> wrt bug #467720.
(Portage version: 2.1.12.4/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cmake/ChangeLog5
-rw-r--r--dev-util/cmake/cmake-2.8.11.1.ebuild10
2 files changed, 10 insertions, 5 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index 95428f54a8fe..3c0245d15970 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/cmake
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.251 2013/06/11 20:21:28 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.252 2013/06/14 17:17:22 kensington Exp $
+
+ 14 Jun 2013; Michael Palimaka <kensington@gentoo.org> cmake-2.8.11.1.ebuild:
+ Fix tests by David Leverton <levertond@googlemail.com> wrt bug #467720.
11 Jun 2013; Fabian Groffen <grobian@gentoo.org> cmake-2.8.11.1.ebuild:
Add dropped darwin-isysroot patch to fix compilation, bug #472922
diff --git a/dev-util/cmake/cmake-2.8.11.1.ebuild b/dev-util/cmake/cmake-2.8.11.1.ebuild
index da40244f74eb..4ac7020ebecd 100644
--- a/dev-util/cmake/cmake-2.8.11.1.ebuild
+++ b/dev-util/cmake/cmake-2.8.11.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.11.1.ebuild,v 1.3 2013/06/11 20:21:28 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.11.1.ebuild,v 1.4 2013/06/14 17:17:22 kensington Exp $
EAPI=5
@@ -94,9 +94,11 @@ cmake_src_bootstrap() {
}
cmake_src_test() {
- # fix OutDir test
- # this is altered thanks to our eclass
- sed -i -e 's:#IGNORE ::g' "${S}"/Tests/OutDir/CMakeLists.txt || die
+ # fix OutDir and SelectLibraryConfigurations tests
+ # these are altered thanks to our eclass
+ sed -i -e 's:#IGNORE ::g' \
+ "${S}"/Tests/{OutDir,CMakeOnly/SelectLibraryConfigurations}/CMakeLists.txt \
+ || die
pushd "${CMAKE_BUILD_DIR}" > /dev/null