summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-01-14 11:18:58 +0000
committerMichael Weber <xmw@gentoo.org>2013-01-14 11:18:58 +0000
commita31102f48e160125f2373f7f094dbf0a6a3a64c6 (patch)
tree8962a14cdd70dccd168ed7a7b8157a763d7972b8 /dev-util
parentTweak elog message to mention newer TeX Live versions, bug #439916 by Keshav ... (diff)
downloadgentoo-2-a31102f48e160125f2373f7f094dbf0a6a3a64c6.tar.gz
gentoo-2-a31102f48e160125f2373f7f094dbf0a6a3a64c6.tar.bz2
gentoo-2-a31102f48e160125f2373f7f094dbf0a6a3a64c6.zip
Version bump (thanks euscan).
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cppcheck/ChangeLog9
-rw-r--r--dev-util/cppcheck/cppcheck-1.58.ebuild80
2 files changed, 87 insertions, 2 deletions
diff --git a/dev-util/cppcheck/ChangeLog b/dev-util/cppcheck/ChangeLog
index 510e8229f6f1..c503349609c6 100644
--- a/dev-util/cppcheck/ChangeLog
+++ b/dev-util/cppcheck/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/cppcheck
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.35 2012/11/05 17:53:47 xmw Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.36 2013/01/14 11:18:58 xmw Exp $
+
+*cppcheck-1.58 (14 Jan 2013)
+
+ 14 Jan 2013; Michael Weber <xmw@gentoo.org> +cppcheck-1.58.ebuild:
+ Version bump (thanks euscan).
*cppcheck-1.57 (05 Nov 2012)
diff --git a/dev-util/cppcheck/cppcheck-1.58.ebuild b/dev-util/cppcheck/cppcheck-1.58.ebuild
new file mode 100644
index 000000000000..bac0c2ac4151
--- /dev/null
+++ b/dev-util/cppcheck/cppcheck-1.58.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.58.ebuild,v 1.1 2013/01/14 11:18:58 xmw Exp $
+
+EAPI="3"
+PYTHON_DEPEND="htmlreport? 2"
+
+inherit distutils eutils qt4-r2 toolchain-funcs
+
+DESCRIPTION="static analyzer of C/C++ code"
+HOMEPAGE="http://apps.sourceforge.net/trac/cppcheck/"
+SRC_URI="mirror://sourceforge/cppcheck/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="htmlreport qt4"
+
+DEPEND="htmlreport? ( dev-python/pygments )
+ qt4? ( x11-libs/qt-gui:4 )"
+RDEPEND="${DEPEND}"
+
+DISTUTILS_SETUP_FILES=("htmlreport|setup.py")
+
+pkg_setup() {
+ if use htmlreport ; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ if use htmlreport ; then
+ pushd htmlreport
+ python_convert_shebangs -r 2 .
+ distutils_src_prepare
+ popd
+ fi
+}
+
+src_configure() {
+ tc-export CXX
+ if use qt4 ; then
+ pushd gui
+ qt4-r2_src_configure
+ popd
+ fi
+}
+
+src_compile() {
+ emake || die
+ if use qt4 ; then
+ pushd gui
+ qt4-r2_src_compile
+ popd
+ fi
+ use htmlreport && distutils_src_compile
+ #https://sourceforge.net/apps/trac/cppcheck/ticket/4149
+ #$(tc-getCXX) ${CFLAGS} ${LDFLAGS} -o ${PN}-democlient.cgi \
+ # democlient.cpp -I../lib democlient.cpp
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc readme.txt || die
+ if use qt4 ; then
+ dobin gui/${PN}-gui || die
+ dodoc readme_gui.txt gui/{projectfile.txt,gui.cppcheck} || die
+ fi
+ use htmlreport && distutils_src_install
+ #dobin ${PN}-democlient.cgi
+}
+
+pkg_postinst() {
+ use htmlreport && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use htmlreport && distutils_pkg_postrm
+}