summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2014-02-05 16:10:57 +0000
committerMichael Palimaka <kensington@gentoo.org>2014-02-05 16:10:57 +0000
commite89ed4d764dec487635d498a764a23c8b32f75ed (patch)
treed63d553a39979ed3523e12e06d2f733ecabf513c /dev-util
parentUpdate ChangeLog (diff)
downloadgentoo-2-e89ed4d764dec487635d498a764a23c8b32f75ed.tar.gz
gentoo-2-e89ed4d764dec487635d498a764a23c8b32f75ed.tar.bz2
gentoo-2-e89ed4d764dec487635d498a764a23c8b32f75ed.zip
Backport patch from upstream fixing linking during bootstrap on HPPA wrt bug #499922.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cmake/ChangeLog7
-rw-r--r--dev-util/cmake/cmake-2.8.12.2.ebuild3
-rw-r--r--dev-util/cmake/files/cmake-2.8.12.2-hppa-bootstrap.patch27
3 files changed, 35 insertions, 2 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index eb53ca3c73cf..8c1fe4ed53bc 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/cmake
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.271 2014/01/29 01:34:47 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.272 2014/02/05 16:10:57 kensington Exp $
+
+ 05 Feb 2014; Michael Palimaka <kensington@gentoo.org>
+ +files/cmake-2.8.12.2-hppa-bootstrap.patch, cmake-2.8.12.2.ebuild:
+ Backport patch from upstream fixing linking during bootstrap on HPPA wrt bug
+ #499922.
*cmake-2.8.12.2 (29 Jan 2014)
diff --git a/dev-util/cmake/cmake-2.8.12.2.ebuild b/dev-util/cmake/cmake-2.8.12.2.ebuild
index cd54ba9c6ab9..c2a5e445e3af 100644
--- a/dev-util/cmake/cmake-2.8.12.2.ebuild
+++ b/dev-util/cmake/cmake-2.8.12.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.12.2.ebuild,v 1.1 2014/01/29 01:34:47 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.12.2.ebuild,v 1.2 2014/02/05 16:10:57 kensington Exp $
EAPI=5
@@ -64,6 +64,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.8.11-more-no_host_paths.patch
"${FILESDIR}"/${PN}-2.8.12.1-FindImageMagick.patch
"${FILESDIR}"/${PN}-2.8.12.1-FindFreetype.patch
+ "${FILESDIR}"/${PN}-2.8.12.2-hppa-bootstrap.patch
)
cmake_src_bootstrap() {
diff --git a/dev-util/cmake/files/cmake-2.8.12.2-hppa-bootstrap.patch b/dev-util/cmake/files/cmake-2.8.12.2-hppa-bootstrap.patch
new file mode 100644
index 000000000000..99e39a2f5c8d
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.8.12.2-hppa-bootstrap.patch
@@ -0,0 +1,27 @@
+diff --git a/CompileFlags.cmake b/CompileFlags.cmake
+index 20f5dec..24ac58d 100644
+--- a/CompileFlags.cmake
++++ b/CompileFlags.cmake
+@@ -66,5 +66,5 @@ endif ()
+ # avoid binutils problem with large binaries, e.g. when building CMake in debug mode
+ # See http://gcc.gnu.org/bugzilla/show_bug.cgi?id=50230
+ if (CMAKE_SYSTEM_NAME STREQUAL Linux AND CMAKE_SYSTEM_PROCESSOR STREQUAL parisc)
+- set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--unique=.text.*")
++ set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--unique=.text._*")
+ endif ()
+diff --git a/bootstrap b/bootstrap
+index 9784d5d..51d067e 100755
+--- a/bootstrap
++++ b/bootstrap
+@@ -692,10 +692,7 @@ if ${cmake_system_linux}; then
+ # avoid binutils problem with large binaries, e.g. when building CMake in debug mode
+ # See http://gcc.gnu.org/bugzilla/show_bug.cgi?id=50230
+ if ${cmake_machine_parisc}; then
+- # if -O[s23] is given the effect is inverted, so do not use the flag then
+- if [ "`echo "${CXXFLAGS}" | sed -r '/^(.* )?(-O[s234])( .*)?$/s/.*/-Os/'`" != "-Os" ]; then
+- cmake_ld_flags="${LDFLAGS} -Wl,--unique=.text.*"
+- fi
++ cmake_ld_flags="${LDFLAGS} -Wl,--unique=.text._*"
+ fi
+ fi
+