summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2011-08-29 21:41:06 +0000
committerChristian Faulhammer <fauli@gentoo.org>2011-08-29 21:41:06 +0000
commit58240e1d628b69852d443af56a6ef4a002c466cd (patch)
tree58eb02f271ac8c037ae61e28adaca18135f3c02c /dev-vcs/bzr
parentclean up (diff)
downloadgentoo-2-58240e1d628b69852d443af56a6ef4a002c466cd.tar.gz
gentoo-2-58240e1d628b69852d443af56a6ef4a002c466cd.tar.bz2
gentoo-2-58240e1d628b69852d443af56a6ef4a002c466cd.zip
clean up
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'dev-vcs/bzr')
-rw-r--r--dev-vcs/bzr/ChangeLog6
-rw-r--r--dev-vcs/bzr/bzr-2.2.4.ebuild139
-rw-r--r--dev-vcs/bzr/bzr-2.3.4.ebuild133
3 files changed, 5 insertions, 273 deletions
diff --git a/dev-vcs/bzr/ChangeLog b/dev-vcs/bzr/ChangeLog
index 9ccd91c60ecd..d18713d249ea 100644
--- a/dev-vcs/bzr/ChangeLog
+++ b/dev-vcs/bzr/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/bzr
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr/ChangeLog,v 1.31 2011/08/19 19:17:32 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr/ChangeLog,v 1.32 2011/08/29 21:41:06 fauli Exp $
+
+ 29 Aug 2011; Christian Faulhammer <fauli@gentoo.org> -bzr-2.2.4.ebuild,
+ -bzr-2.3.4.ebuild:
+ clean up
19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> bzr-2.2.2-r1.ebuild,
bzr-2.2.4.ebuild, bzr-2.3.4.ebuild, bzr-2.4.0.ebuild:
diff --git a/dev-vcs/bzr/bzr-2.2.4.ebuild b/dev-vcs/bzr/bzr-2.2.4.ebuild
deleted file mode 100644
index a6b21e19197a..000000000000
--- a/dev-vcs/bzr/bzr-2.2.4.ebuild
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr/bzr-2.2.4.ebuild,v 1.3 2011/08/19 19:17:32 hwoarang Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit bash-completion distutils elisp-common eutils versionator
-
-MY_P=${PN}-${PV}
-SERIES=$(get_version_component_range 1-2)
-
-DESCRIPTION="Bazaar is a next generation distributed version control system."
-HOMEPAGE="http://bazaar-vcs.org/"
-#SRC_URI="http://bazaar-vcs.org/releases/src/${MY_P}.tar.gz"
-SRC_URI="http://launchpad.net/bzr/${SERIES}/${PV}/+download/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
-IUSE="curl doc emacs +sftp test"
-
-# Disable until https://bugs.launchpad.net/bzr/+bug/392127 is released.
-# It can be found in Bazaar 2.3
-RESTRICT="test"
-
-RDEPEND="|| ( dev-lang/python:2.7[xml] dev-lang/python:2.6[xml] dev-lang/python:2.5[xml] dev-python/celementtree )
- curl? ( dev-python/pycurl )
- sftp? ( dev-python/paramiko )"
-
-DEPEND="emacs? ( virtual/emacs )
- test? (
- ${RDEPEND}
- dev-python/medusa
- dev-python/subunit
- dev-python/testtools
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-DOCS="doc/*.txt"
-PYTHON_MODNAME="bzrlib"
-SITEFILE="71bzr-gentoo.el"
-
-src_prepare() {
- distutils_src_prepare
-
- # Fix for changed behaviour of Python 2.7, integrated into Bazaar
- # 2.3, might be a regression in Python, see
- # https://bugs.launchpad.net/bzr/+bug/612096
- # http://psf.upfronthosting.co.za/roundup/tracker/issue8194
- epatch "${FILESDIR}"/${PN}-2.2.2-python-2.7.patch
- # Don't regenerate .c files from .pyx when pyrex is found.
- epatch "${FILESDIR}/${PN}-2.2.0-no-pyrex-citon.patch"
- # Don't run lock permission tests when running as root
- # Has to be backported, tests are restricted anyway
-# epatch "${FILESDIR}/${PN}-0.90-tests-fix_root.patch"
- # Fix permission errors when run under directories with setgid set.
- epatch "${FILESDIR}/${PN}-0.90-tests-sgid.patch"
-}
-
-src_compile() {
- distutils_src_compile
-
- if use emacs; then
- elisp-compile contrib/emacs/bzr-mode.el || die
- fi
-}
-
-src_test() {
- # Some tests expect the usual pyc compiling behaviour.
- python_enable_pyc
-
- # Define tests which are known to fail below.
- local skip_tests="("
- # https://bugs.launchpad.net/bzr/+bug/456471
- skip_tests+="bzrlib.tests.blackbox.test_version.*|"
- # https://bugs.launchpad.net/bzr/+bug/392127
- skip_tests+="test_http.*"
- skip_tests+=")"
- if [[ -n ${skip_tests} ]]; then
- einfo "Skipping tests known to fail: ${skip_tests}"
- fi
-
- testing() {
- LC_ALL="C" "$(PYTHON)" bzr --no-plugins selftest ${skip_tests:+-x} ${skip_tests}
- }
- python_execute_function testing
-
- # Just to make sure we don't hit any errors on later stages.
- python_disable_pyc
-}
-
-src_install() {
- distutils_src_install --install-data "${EPREFIX}/usr/share"
-
- if use doc; then
- docinto developers
- dodoc doc/developers/* || die
- for doc in mini-tutorial tutorials user-{guide,reference}; do
- docinto $doc
- dodoc doc/en/$doc/* || die
- done
- fi
-
- if use emacs; then
- elisp-install ${PN} contrib/emacs/*.el* || die
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
-
- # don't add automatically to the load-path, so the sitefile
- # can do a conditional loading
- touch "${ED}${SITELISP}/${PN}/.nosearch"
- fi
-
- dobashcompletion contrib/bash/bzr
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
- bash-completion_pkg_postinst
-
- if use emacs; then
- elisp-site-regen
- elog "If you are using a GNU Emacs version greater than 22.1, bzr support"
- elog "is already included. This ebuild does not automatically activate bzr support"
- elog "in versions below, but prepares it in a way you can load it from your ~/.emacs"
- elog "file by adding"
- elog " (load \"bzr-mode\")"
- fi
-}
-
-pkg_postrm() {
- distutils_pkg_postrm
- use emacs && elisp-site-regen
-}
diff --git a/dev-vcs/bzr/bzr-2.3.4.ebuild b/dev-vcs/bzr/bzr-2.3.4.ebuild
deleted file mode 100644
index f8743b373225..000000000000
--- a/dev-vcs/bzr/bzr-2.3.4.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr/bzr-2.3.4.ebuild,v 1.2 2011/08/19 19:17:32 hwoarang Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit bash-completion distutils elisp-common eutils versionator
-
-MY_P=${PN}-${PV}
-SERIES=$(get_version_component_range 1-2)
-
-DESCRIPTION="Bazaar is a next generation distributed version control system."
-HOMEPAGE="http://bazaar-vcs.org/"
-#SRC_URI="http://bazaar-vcs.org/releases/src/${MY_P}.tar.gz"
-SRC_URI="http://launchpad.net/bzr/${SERIES}/${PV}/+download/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
-IUSE="curl doc emacs +sftp test"
-
-# Disable until https://bugs.launchpad.net/bzr/+bug/656170 is fixed.
-RESTRICT="test"
-
-RDEPEND="|| ( dev-lang/python:2.7[xml] dev-lang/python:2.6[xml] dev-lang/python:2.5[xml] dev-python/celementtree )
- curl? ( dev-python/pycurl )
- sftp? ( dev-python/paramiko )"
-
-DEPEND="emacs? ( virtual/emacs )
- test? (
- ${RDEPEND}
- dev-python/medusa
- dev-python/subunit
- dev-python/testtools
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-DOCS="doc/*.txt"
-PYTHON_MODNAME="bzrlib"
-SITEFILE="71bzr-gentoo.el"
-
-src_prepare() {
- distutils_src_prepare
-
- # Don't regenerate .c files from .pyx when pyrex is found.
- epatch "${FILESDIR}/${PN}-2.2.0-no-pyrex-citon.patch"
- # Don't run lock permission tests when running as root
- # Has to be backported, tests are restricted anyway
-# epatch "${FILESDIR}/${PN}-0.90-tests-fix_root.patch"
- # Fix permission errors when run under directories with setgid set.
- epatch "${FILESDIR}/${PN}-0.90-tests-sgid.patch"
-}
-
-src_compile() {
- distutils_src_compile
-
- if use emacs; then
- elisp-compile contrib/emacs/bzr-mode.el || die
- fi
-}
-
-src_test() {
- # Some tests expect the usual pyc compiling behaviour.
- python_enable_pyc
-
- # Define tests which are known to fail below.
- local skip_tests="("
- # https://bugs.launchpad.net/bzr/+bug/456471
- skip_tests+="bzrlib.tests.blackbox.test_version.*|"
- # https://bugs.launchpad.net/bzr/+bug/392127
- skip_tests+="test_http.*"
- skip_tests+=")"
- if [[ -n ${skip_tests} ]]; then
- einfo "Skipping tests known to fail: ${skip_tests}"
- fi
-
- testing() {
- LC_ALL="C" "$(PYTHON)" bzr --no-plugins selftest ${skip_tests:+-x} ${skip_tests}
- }
- python_execute_function testing
-
- # Just to make sure we don't hit any errors on later stages.
- python_disable_pyc
-}
-
-src_install() {
- distutils_src_install --install-data "${EPREFIX}/usr/share"
-
- if use doc; then
- docinto developers
- dodoc doc/developers/* || die
- for doc in mini-tutorial tutorials user-{guide,reference}; do
- docinto $doc
- dodoc doc/en/$doc/* || die
- done
- fi
-
- if use emacs; then
- elisp-install ${PN} contrib/emacs/*.el* || die
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
-
- # don't add automatically to the load-path, so the sitefile
- # can do a conditional loading
- touch "${ED}${SITELISP}/${PN}/.nosearch"
- fi
-
- dobashcompletion contrib/bash/bzr
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
- bash-completion_pkg_postinst
-
- if use emacs; then
- elisp-site-regen
- elog "If you are using a GNU Emacs version greater than 22.1, bzr support"
- elog "is already included. This ebuild does not automatically activate bzr support"
- elog "in versions below, but prepares it in a way you can load it from your ~/.emacs"
- elog "file by adding"
- elog " (load \"bzr-mode\")"
- fi
-}
-
-pkg_postrm() {
- distutils_pkg_postrm
- use emacs && elisp-site-regen
-}