summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2011-01-25 14:56:23 +0000
committerTiziano Müller <dev-zero@gentoo.org>2011-01-25 14:56:23 +0000
commit5f44fddc252c883015a7e843019e2a07179d7945 (patch)
tree6863e06b295da18dea3aec8cae5532ab302e700d /dev-vcs/cola
parentStable on amd64 wrt bug #342725 (diff)
downloadgentoo-2-5f44fddc252c883015a7e843019e2a07179d7945.tar.gz
gentoo-2-5f44fddc252c883015a7e843019e2a07179d7945.tar.bz2
gentoo-2-5f44fddc252c883015a7e843019e2a07179d7945.zip
Version bump (bug #351580). Also solved: the installation of localization files (bug #348130), adaption to python eclass changes (bug #329473).
(Portage version: 2.1.9.35/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/cola')
-rw-r--r--dev-vcs/cola/ChangeLog10
-rw-r--r--dev-vcs/cola/cola-1.4.3.ebuild96
2 files changed, 104 insertions, 2 deletions
diff --git a/dev-vcs/cola/ChangeLog b/dev-vcs/cola/ChangeLog
index ce068110f610..9a191cd23005 100644
--- a/dev-vcs/cola/ChangeLog
+++ b/dev-vcs/cola/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/cola
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cola/ChangeLog,v 1.4 2010/06/09 19:47:29 dev-zero Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cola/ChangeLog,v 1.5 2011/01/25 14:56:23 dev-zero Exp $
+
+*cola-1.4.3 (25 Jan 2011)
+
+ 25 Jan 2011; Tiziano Müller <dev-zero@gentoo.org> +cola-1.4.3.ebuild:
+ Version bump (bug #351580). Also solved: the installation of localization
+ files (bug #348130), adaption to python eclass changes (bug #329473).
09 Jun 2010; Tiziano Müller <dev-zero@gentoo.org> cola-1.4.2.1.ebuild:
Version bump.
diff --git a/dev-vcs/cola/cola-1.4.3.ebuild b/dev-vcs/cola/cola-1.4.3.ebuild
new file mode 100644
index 000000000000..088e2ff431c6
--- /dev/null
+++ b/dev-vcs/cola/cola-1.4.3.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cola/cola-1.4.3.ebuild,v 1.1 2011/01/25 14:56:23 dev-zero Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+
+inherit distutils eutils
+
+DESCRIPTION="A sweet, carbonated git gui known for its sugary flavour and caffeine-inspired features."
+HOMEPAGE="http://cola.tuxfamily.org/"
+SRC_URI="http://cola.tuxfamily.org/releases/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/PyQt4
+ >=dev-python/pyinotify-0.7.1
+ dev-python/jsonpickle
+ >=dev-vcs/git-1.6.3"
+DEPEND="${RDEPEND}
+ doc? ( app-text/asciidoc
+ dev-python/sphinx
+ app-text/xmlto )
+ sys-devel/gettext
+ test? ( dev-python/nose )"
+
+# tests currently broken due to unfinished translation framework
+RESTRICT="test"
+
+
+src_prepare() {
+ # don't install docs into wrong location
+ sed -i \
+ -e '/doc/d' \
+ setup.py || die "sed failed"
+
+ sed -i \
+ -e "s|'doc', 'git-cola'|'doc', '${PF}', 'html'|" \
+ cola/resources.py || die "sed failed"
+
+ # don't prefix install path with homedir
+ rm setup.cfg
+
+ epatch "${FILESDIR}/1.3.8-disable-tests.patch"
+
+ python_convert_shebangs 2 bin/git-cola share/git-cola/bin/ssh-askpass
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc ; then
+ cd share/doc/git-cola/
+ emake all || die "building docs failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ # remove bundled libraries
+ rm -rf "${D}"/usr/share/git-cola/lib/{jsonpickle,simplejson}
+
+ # remove wrong translation file
+ rm -rf "${D}/usr/share/locale/"
+
+ insinto /usr/share/locale
+ doins -r share/locale/*
+
+ cd share/doc/git-cola/
+ dodoc *.txt
+
+ if use doc ; then
+ dohtml -r _build/html/*
+ doman *.1
+ else
+ dohtml "${FILESDIR}/index.html"
+ fi
+}
+
+src_test() {
+ PYTHONPATH="${S}:${S}/build/lib:${PYTHONPATH}" LC_ALL="C" nosetests \
+ --verbose --with-doctest --with-id --exclude=jsonpickle --exclude=json \
+ || die "running nosetests failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/git-cola/lib/cola
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/git-cola/lib/cola
+}