summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-01-19 19:04:32 +0000
committerJustin Lecher <jlec@gentoo.org>2014-01-19 19:04:32 +0000
commit4216702be0858ea5345d5d0e8e07f0b6faba851f (patch)
tree0552739979673e72fe5871b3e44c4088ab680b19 /dev-vcs/git-cola
parentdev-vcs/git-cola: Block test if domain name is unset, #497876 (diff)
downloadgentoo-2-4216702be0858ea5345d5d0e8e07f0b6faba851f.tar.gz
gentoo-2-4216702be0858ea5345d5d0e8e07f0b6faba851f.tar.bz2
gentoo-2-4216702be0858ea5345d5d0e8e07f0b6faba851f.zip
dev-vcs/git-cola: Block test if domain name is unset, #497876
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-vcs/git-cola')
-rw-r--r--dev-vcs/git-cola/ChangeLog6
-rw-r--r--dev-vcs/git-cola/git-cola-1.9.1.ebuild16
-rw-r--r--dev-vcs/git-cola/git-cola-1.9.3.ebuild13
3 files changed, 28 insertions, 7 deletions
diff --git a/dev-vcs/git-cola/ChangeLog b/dev-vcs/git-cola/ChangeLog
index 20366110f08c..9cb3259aae17 100644
--- a/dev-vcs/git-cola/ChangeLog
+++ b/dev-vcs/git-cola/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/git-cola
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/ChangeLog,v 1.18 2014/01/15 12:00:19 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/ChangeLog,v 1.19 2014/01/19 19:04:32 jlec Exp $
+
+ 19 Jan 2014; Justin Lecher <jlec@gentoo.org> git-cola-1.9.1.ebuild,
+ git-cola-1.9.3.ebuild:
+ Block test if domain name is unset, #497876
*git-cola-1.9.3 (15 Jan 2014)
diff --git a/dev-vcs/git-cola/git-cola-1.9.1.ebuild b/dev-vcs/git-cola/git-cola-1.9.1.ebuild
index 3f36e758109b..b6a42c0f8436 100644
--- a/dev-vcs/git-cola/git-cola-1.9.1.ebuild
+++ b/dev-vcs/git-cola/git-cola-1.9.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/git-cola-1.9.1.ebuild,v 1.1 2013/11/07 16:56:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/git-cola-1.9.1.ebuild,v 1.2 2014/01/19 19:04:32 jlec Exp $
EAPI=5
@@ -26,15 +26,23 @@ RDEPEND="
DEPEND="${RDEPEND}
app-text/asciidoc
app-text/xmlto
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
sys-devel/gettext
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ sys-apps/net-tools
+ )"
PATCHES=(
"${FILESDIR}"/${PV}-disable-tests.patch
"${FILESDIR}"/${P}-system-ssh-askpass.patch
)
+pkg_pretend() {
+ if use test && [[ -z "$(hostname -d)" ]] ; then
+ die "Test will fail if no domain is set"
+ fi
+}
python_prepare_all() {
rm share/git-cola/bin/*askpass* || die
diff --git a/dev-vcs/git-cola/git-cola-1.9.3.ebuild b/dev-vcs/git-cola/git-cola-1.9.3.ebuild
index fca042ad2977..c707607c28b6 100644
--- a/dev-vcs/git-cola/git-cola-1.9.3.ebuild
+++ b/dev-vcs/git-cola/git-cola-1.9.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/git-cola-1.9.3.ebuild,v 1.1 2014/01/15 12:00:19 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/git-cola-1.9.3.ebuild,v 1.2 2014/01/19 19:04:32 jlec Exp $
EAPI=5
@@ -28,13 +28,22 @@ DEPEND="${RDEPEND}
app-text/xmlto
sys-devel/gettext
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ sys-apps/net-tools
+ )"
PATCHES=(
"${FILESDIR}"/${P}-disable-tests.patch
"${FILESDIR}"/${PN}-1.9.1-system-ssh-askpass.patch
)
+pkg_pretend() {
+ if use test && [[ -z "$(hostname -d)" ]] ; then
+ die "Test will fail if no domain is set"
+ fi
+}
+
python_prepare_all() {
rm share/git-cola/bin/*askpass* || die