summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2011-02-25 11:07:00 +0000
committerMike Auty <ikelos@gentoo.org>2011-02-25 11:07:00 +0000
commit18383b0662b133fdcc8be9315deab1b9323abb19 (patch)
tree32d32a92a2e57d61ba0e9b6dc757e6c7d707c9a2 /dev-vcs/gitg
parentAllow -fpermissive. (diff)
downloadgentoo-2-18383b0662b133fdcc8be9315deab1b9323abb19.tar.gz
gentoo-2-18383b0662b133fdcc8be9315deab1b9323abb19.tar.bz2
gentoo-2-18383b0662b133fdcc8be9315deab1b9323abb19.zip
Bump to 0.1.0, thanks to Alphat-PC (bug 354065).
(Portage version: 2.2.0_alpha25/cvs/Linux i686)
Diffstat (limited to 'dev-vcs/gitg')
-rw-r--r--dev-vcs/gitg/ChangeLog7
-rw-r--r--dev-vcs/gitg/gitg-0.1.0.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-vcs/gitg/ChangeLog b/dev-vcs/gitg/ChangeLog
index 4f9b9bd1c590..c8267e9e9590 100644
--- a/dev-vcs/gitg/ChangeLog
+++ b/dev-vcs/gitg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/gitg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitg/ChangeLog,v 1.7 2011/01/02 01:58:02 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitg/ChangeLog,v 1.8 2011/02/25 11:06:59 ikelos Exp $
+
+*gitg-0.1.0 (25 Feb 2011)
+
+ 25 Feb 2011; Mike Auty <ikelos@gentoo.org> +gitg-0.1.0.ebuild:
+ Bump to 0.1.0, thanks to Alphat-PC (bug 354065).
02 Jan 2011; Sebastian Pipping <sping@gentoo.org> gitg-0.0.8.ebuild:
Remove gone configure option --disable-bundle, integrate test suite from
diff --git a/dev-vcs/gitg/gitg-0.1.0.ebuild b/dev-vcs/gitg/gitg-0.1.0.ebuild
new file mode 100644
index 000000000000..587588da72d9
--- /dev/null
+++ b/dev-vcs/gitg/gitg-0.1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitg/gitg-0.1.0.ebuild,v 1.1 2011/02/25 11:07:00 ikelos Exp $
+
+EAPI="3"
+
+inherit gnome2
+
+DESCRIPTION="git repository viewer for GNOME"
+HOMEPAGE="http://trac.novowork.com/gitg/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.26:2
+ >=x11-libs/gtk+-2.18:2
+ >=x11-libs/gtksourceview-2.8:2.0
+ >=gnome-base/gconf-2.10
+ >=gnome-base/gsettings-desktop-schemas-0.1.1
+ dev-vcs/git"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.17
+ >=dev-util/pkgconfig-0.15
+ >=dev-util/intltool-0.40"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-dependency-tracking
+ --with-gtk=2.0"
+
+ DOCS="AUTHORS ChangeLog NEWS README"
+}
+
+src_prepare() {
+ # Fix intltoolize broken file, see <https://bugzilla.gnome.org/show_bug.cgi?id=577133>
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i "${S}/po/Makefile.in.in" || die "sed failed"
+}
+
+src_install() {
+ gnome2_src_install
+ find "${ED}" -name "*.la" -delete || die "Removal of .la files failed"
+}
+
+src_test() {
+ emake check || die
+}