summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-06 19:39:15 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-06 19:39:15 +0000
commit0bba0f6a15d409d7585e9e00e83b4f22222a7fe4 (patch)
treee67d80161272a0f1f415c5d7ec147abab1c7610f /dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20080203.ebuild
parentVersion bump (diff)
downloadgentoo-2-0bba0f6a15d409d7585e9e00e83b4f22222a7fe4.tar.gz
gentoo-2-0bba0f6a15d409d7585e9e00e83b4f22222a7fe4.tar.bz2
gentoo-2-0bba0f6a15d409d7585e9e00e83b4f22222a7fe4.zip
Use Python 2 (bug #329483).
(Portage version: 2.2.0_alpha29_p10/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20080203.ebuild')
-rw-r--r--dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20080203.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20080203.ebuild b/dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20080203.ebuild
index 6ef3ec8df9c5..8da70b851d29 100644
--- a/dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20080203.ebuild
+++ b/dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20080203.ebuild
@@ -1,6 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20080203.ebuild,v 1.1 2010/06/19 16:19:58 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20080203.ebuild,v 1.2 2011/04/06 19:39:15 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
inherit eutils distutils
@@ -23,8 +26,12 @@ RDEPEND="${DEPEND}
S=${WORKDIR}/gitosis-gentoo
DOCS="example.conf gitweb.conf lighttpd-gitweb.conf TODO.rst"
+PYTHON_MODNAME="gitosis"
pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+
enewgroup git
enewuser git -1 /bin/sh /var/spool/gitosis git
}