summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2011-11-15 03:12:00 +0000
committerMike Gilbert <floppym@gentoo.org>2011-11-15 03:12:00 +0000
commitaace7b5a703b3253cae6e709ef95b5a65c0aa2a1 (patch)
tree6d3f73bcac9c35cce6451f3f030d230432311531 /dev-vcs/hgsubversion
parentRevbump to 1.5.1-r1 to fix prestripped-binaries (diff)
downloadgentoo-2-aace7b5a703b3253cae6e709ef95b5a65c0aa2a1.tar.gz
gentoo-2-aace7b5a703b3253cae6e709ef95b5a65c0aa2a1.tar.bz2
gentoo-2-aace7b5a703b3253cae6e709ef95b5a65c0aa2a1.zip
Version bump.
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/hgsubversion')
-rw-r--r--dev-vcs/hgsubversion/ChangeLog7
-rw-r--r--dev-vcs/hgsubversion/hgsubversion-1.3.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-vcs/hgsubversion/ChangeLog b/dev-vcs/hgsubversion/ChangeLog
index 5314bb0aab90..acb2dd8e6fa6 100644
--- a/dev-vcs/hgsubversion/ChangeLog
+++ b/dev-vcs/hgsubversion/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/hgsubversion
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hgsubversion/ChangeLog,v 1.17 2011/06/23 14:44:33 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hgsubversion/ChangeLog,v 1.18 2011/11/15 03:12:00 floppym Exp $
+
+*hgsubversion-1.3 (15 Nov 2011)
+
+ 15 Nov 2011; Mike Gilbert <floppym@gentoo.org> +hgsubversion-1.3.ebuild:
+ Version bump.
23 Jun 2011; Markos Chandras <hwoarang@gentoo.org> -hgsubversion-1.2.ebuild:
Remove old ebuilds. Requested by Arfrever
diff --git a/dev-vcs/hgsubversion/hgsubversion-1.3.ebuild b/dev-vcs/hgsubversion/hgsubversion-1.3.ebuild
new file mode 100644
index 000000000000..bbf02df117d6
--- /dev/null
+++ b/dev-vcs/hgsubversion/hgsubversion-1.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hgsubversion/hgsubversion-1.3.ebuild,v 1.1 2011/11/15 03:12:00 floppym Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils
+
+DESCRIPTION="hgsubversion is a Mercurial extension for working with Subversion repositories."
+HOMEPAGE="https://bitbucket.org/durin42/hgsubversion/wiki/Home http://pypi.python.org/pypi/hgsubversion"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND=">=dev-vcs/mercurial-1.4
+ >=dev-vcs/subversion-1.5[python]"
+DEPEND="test? ( dev-python/nose )"
+
+DOCS="README"
+
+src_test() {
+ cd tests
+
+ testing() {
+ PYTHONPATH="../build-${PYTHON_ABI}/lib" "$(PYTHON)" run.py
+ }
+ python_execute_function testing
+}