summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-11-27 18:13:24 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-11-27 18:13:24 +0000
commit7ed4912243ee1a31a0635e45701e5d1f697ce271 (patch)
treeaa091acff70c24099f7121d7b124cd61f4fc2dd8 /dev-vcs/qbzr
parent*portage-2.2.0_alpha6 (27 Nov 2010) (diff)
downloadgentoo-2-7ed4912243ee1a31a0635e45701e5d1f697ce271.tar.gz
gentoo-2-7ed4912243ee1a31a0635e45701e5d1f697ce271.tar.bz2
gentoo-2-7ed4912243ee1a31a0635e45701e5d1f697ce271.zip
version bump
(Portage version: 2.1.9.24/cvs/Linux i686)
Diffstat (limited to 'dev-vcs/qbzr')
-rw-r--r--dev-vcs/qbzr/ChangeLog7
-rw-r--r--dev-vcs/qbzr/qbzr-0.19.3.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-vcs/qbzr/ChangeLog b/dev-vcs/qbzr/ChangeLog
index 96532935316f..e19cd6ee29f5 100644
--- a/dev-vcs/qbzr/ChangeLog
+++ b/dev-vcs/qbzr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/qbzr
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/qbzr/ChangeLog,v 1.12 2010/09/15 09:44:57 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/qbzr/ChangeLog,v 1.13 2010/11/27 18:13:24 fauli Exp $
+
+*qbzr-0.19.3 (27 Nov 2010)
+
+ 27 Nov 2010; Christian Faulhammer <fauli@gentoo.org> +qbzr-0.19.3.ebuild:
+ version bump
*qbzr-0.19.1 (15 Sep 2010)
diff --git a/dev-vcs/qbzr/qbzr-0.19.3.ebuild b/dev-vcs/qbzr/qbzr-0.19.3.ebuild
new file mode 100644
index 000000000000..dfe5955d3ffc
--- /dev/null
+++ b/dev-vcs/qbzr/qbzr-0.19.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/qbzr/qbzr-0.19.3.ebuild,v 1.1 2010/11/27 18:13:24 fauli Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils versionator
+
+DESCRIPTION="Qt frontend for Bazaar"
+HOMEPAGE="https://launchpad.net/qbzr"
+SRC_URI="https://edge.launchpad.net/qbzr/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+# bzr version comes from NEWS file. It's lowest version required for some
+# features to work.
+DEPEND=">=dev-vcs/bzr-1.14
+ >=dev-python/PyQt4-4.1[X]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+DOCS="AUTHORS.txt NEWS.txt README.txt TODO.txt"
+PYTHON_MODNAME="bzrlib/plugins/qbzr"
+
+src_test() {
+ elog "It's impossible to run tests at this point. If you wish to run tests"
+ elog "after installation of ${PN} execute:"
+ elog " $ bzr selftest -s bzrlib.plugins.qbzr"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog
+ elog "To enable spellchecking in qcommit, please, install >=dev-python/pyenchant-1.5.0"
+ elog " # emerge -a >=dev-python/pyenchant-1.5.0"
+ elog "To enable syntax highlighting, please, install dev-python/pygments"
+ elog " # emerge -a dev-python/pygments"
+}