summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2013-07-15 05:58:50 +0000
committerJonathan Callen <abcd@gentoo.org>2013-07-15 05:58:50 +0000
commit23b60eea2467fd768aef0c364180ffcd5f9091a1 (patch)
tree3c94a82e2db78a1906464bbb6e3514983cdbaa7c /dev-vcs
parentI always test before commiting, but clearly I don't always test properly. Fi... (diff)
downloadgentoo-2-23b60eea2467fd768aef0c364180ffcd5f9091a1.tar.gz
gentoo-2-23b60eea2467fd768aef0c364180ffcd5f9091a1.tar.bz2
gentoo-2-23b60eea2467fd768aef0c364180ffcd5f9091a1.zip
Non-maintainer update: make ${PYTHON_REQUIRED_USE} conditional on USE=python; fix pygtk and pygtksourceview deps to require that they be built with the same version of python as this package; replace built_with_use calls with has_version; remove python 2.5 support as none of the dependencies support it.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 229E5838)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git/ChangeLog8
-rw-r--r--dev-vcs/git/git-1.8.3.2.ebuild14
2 files changed, 14 insertions, 8 deletions
diff --git a/dev-vcs/git/ChangeLog b/dev-vcs/git/ChangeLog
index f5215aca3e7c..e400da837baa 100644
--- a/dev-vcs/git/ChangeLog
+++ b/dev-vcs/git/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/git
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.203 2013/07/11 07:25:56 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.204 2013/07/15 05:58:50 abcd Exp $
+
+ 15 Jul 2013; Jonathan Callen <abcd@gentoo.org> git-1.8.3.2.ebuild:
+ Non-maintainer update: make ${PYTHON_REQUIRED_USE} conditional on USE=python;
+ fix pygtk and pygtksourceview deps to require that they be built with the same
+ version of python as this package; replace built_with_use calls with
+ has_version; remove python 2.5 support as none of the dependencies support it.
11 Jul 2013; Lars Wendler <polynomial-c@gentoo.org> git-1.8.3.2.ebuild:
Non-maintainer commit: Fixed test failure when built with USE="-perl" (bug
diff --git a/dev-vcs/git/git-1.8.3.2.ebuild b/dev-vcs/git/git-1.8.3.2.ebuild
index 78864bee1e7a..9ccf7e5ddff8 100644
--- a/dev-vcs/git/git-1.8.3.2.ebuild
+++ b/dev-vcs/git/git-1.8.3.2.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.8.3.2.ebuild,v 1.2 2013/07/11 07:25:56 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.8.3.2.ebuild,v 1.3 2013/07/15 05:58:50 abcd Exp $
EAPI=5
GENTOO_DEPEND_ON_PERL=no
# bug #329479: git-remote-testgit is not multiple-version aware
-PYTHON_COMPAT=( python2_{5,6,7} )
+PYTHON_COMPAT=( python2_{6,7} )
[[ ${PV} == *9999 ]] && SCM="git-2"
EGIT_REPO_URI="git://git.kernel.org/pub/scm/git/git.git"
@@ -67,8 +67,8 @@ RDEPEND="${CDEPEND}
)
python? ( gtk?
(
- >=dev-python/pygtk-2.8
- dev-python/pygtksourceview:2
+ >=dev-python/pygtk-2.8[${PYTHON_USEDEP}]
+ dev-python/pygtksourceview:2[${PYTHON_USEDEP}]
)
${PYTHON_DEPS} )"
@@ -103,11 +103,11 @@ REQUIRED_USE="
subversion? ( perl )
webdav? ( curl )
gtk? ( python )
- ${PYTHON_REQUIRED_USE}
+ python? ( ${PYTHON_REQUIRED_USE} )
"
pkg_setup() {
- if use subversion && has_version dev-vcs/subversion && built_with_use --missing false dev-vcs/subversion dso ; then
+ if use subversion && has_version "dev-vcs/subversion[dso]"; then
ewarn "Per Gentoo bugs #223747, #238586, when subversion is built"
ewarn "with USE=dso, there may be weird crashes in git-svn. You"
ewarn "have been warned."
@@ -534,7 +534,7 @@ src_test() {
has_version dev-vcs/cvs && \
let cvs=$cvs+1
[[ $cvs -gt 1 ]] && \
- built_with_use dev-vcs/cvs server && \
+ has_version "dev-vcs/cvs[server]" && \
let cvs=$cvs+1
if [[ $cvs -lt 3 ]]; then
einfo "Disabling CVS tests (needs dev-vcs/cvs[USE=server])"