summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-24 14:36:29 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-24 14:36:29 +0000
commit39c1926697bc094efe70d8390bf664d43c45bfdf (patch)
tree63e65ca8e1ad31a3dbac9e8a4591338bdf37bfbc /dev-vcs
parentVersion bump. Add ree18 target as well. Don't run tests for jruby since they ... (diff)
downloadgentoo-2-39c1926697bc094efe70d8390bf664d43c45bfdf.tar.gz
gentoo-2-39c1926697bc094efe70d8390bf664d43c45bfdf.tar.bz2
gentoo-2-39c1926697bc094efe70d8390bf664d43c45bfdf.zip
Support installation for multiple Python ABIs (bug #329489).
(Portage version: 2.2_rc86_p7/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/mercurial/ChangeLog6
-rw-r--r--dev-vcs/mercurial/mercurial-1.6.3.ebuild33
-rw-r--r--dev-vcs/mercurial/mercurial-9999.ebuild33
3 files changed, 45 insertions, 27 deletions
diff --git a/dev-vcs/mercurial/ChangeLog b/dev-vcs/mercurial/ChangeLog
index 0fcbd26c0fa2..54a0a3894594 100644
--- a/dev-vcs/mercurial/ChangeLog
+++ b/dev-vcs/mercurial/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/mercurial
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/ChangeLog,v 1.21 2010/08/26 17:24:24 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/ChangeLog,v 1.22 2010/09/24 14:36:29 arfrever Exp $
+
+ 24 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ mercurial-1.6.3.ebuild, mercurial-9999.ebuild:
+ Support installation for multiple Python ABIs (bug #329489).
*mercurial-1.6.3 (26 Aug 2010)
diff --git a/dev-vcs/mercurial/mercurial-1.6.3.ebuild b/dev-vcs/mercurial/mercurial-1.6.3.ebuild
index e076c13b7867..08a864c9a205 100644
--- a/dev-vcs/mercurial/mercurial-1.6.3.ebuild
+++ b/dev-vcs/mercurial/mercurial-1.6.3.ebuild
@@ -1,10 +1,14 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-1.6.3.ebuild,v 1.1 2010/08/26 17:24:24 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-1.6.3.ebuild,v 1.2 2010/09/24 14:36:29 arfrever Exp $
EAPI=3
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="threads"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
-inherit bash-completion elisp-common flag-o-matic eutils distutils
+inherit bash-completion elisp-common eutils distutils
DESCRIPTION="Scalable distributed SCM"
HOMEPAGE="http://mercurial.selenic.com/"
@@ -15,23 +19,23 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="bugzilla emacs gpg test tk zsh-completion"
-CDEPEND=">=dev-lang/python-2.4[threads]"
-RDEPEND="${CDEPEND}
- bugzilla? ( dev-python/mysql-python )
+RDEPEND="bugzilla? ( dev-python/mysql-python )
gpg? ( app-crypt/gnupg )
tk? ( dev-lang/tk )
zsh-completion? ( app-shells/zsh )"
-DEPEND="${CDEPEND}
- emacs? ( virtual/emacs )
+DEPEND="emacs? ( virtual/emacs )
test? ( app-arch/unzip
dev-python/pygments )"
+PYTHON_CFLAGS=(
+ "2.* + -fno-strict-aliasing"
+ "* - -ftracer -ftree-vectorize"
+)
+
PYTHON_MODNAME="${PN} hgext"
SITEFILE="70${PN}-gentoo.el"
src_compile() {
- filter-flags -ftracer -ftree-vectorize
-
distutils_src_compile
if use emacs; then
@@ -99,10 +103,13 @@ src_test() {
rm -f test-journal-exists
rm -f test-repair-strip
fi
- local testdir="${T}/tests"
- rm -rf "${testdir}"
- einfo "Running Mercurial tests ..."
- python run-tests.py -j4 --tmpdir="${testdir}" || die "test failed"
+
+ testing() {
+ local testdir="${T}/tests-${PYTHON_ABI}"
+ rm -rf "${testdir}"
+ "$(PYTHON)" run-tests.py -j4 --tmpdir="${testdir}"
+ }
+ python_execute_function testing
}
pkg_postinst() {
diff --git a/dev-vcs/mercurial/mercurial-9999.ebuild b/dev-vcs/mercurial/mercurial-9999.ebuild
index b1fd5a46fa58..c0ee0ea2bc7b 100644
--- a/dev-vcs/mercurial/mercurial-9999.ebuild
+++ b/dev-vcs/mercurial/mercurial-9999.ebuild
@@ -1,10 +1,14 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-9999.ebuild,v 1.6 2010/06/22 18:49:45 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-9999.ebuild,v 1.7 2010/09/24 14:36:29 arfrever Exp $
EAPI=3
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="threads"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
-inherit bash-completion elisp-common flag-o-matic eutils distutils mercurial
+inherit bash-completion elisp-common eutils distutils mercurial
DESCRIPTION="Scalable distributed SCM"
HOMEPAGE="http://mercurial.selenic.com/"
@@ -15,26 +19,26 @@ SLOT="0"
KEYWORDS=""
IUSE="bugzilla emacs gpg test tk zsh-completion"
-CDEPEND=">=dev-lang/python-2.4[threads]"
-RDEPEND="${CDEPEND}
- bugzilla? ( dev-python/mysql-python )
+RDEPEND="bugzilla? ( dev-python/mysql-python )
gpg? ( app-crypt/gnupg )
tk? ( dev-lang/tk )
zsh-completion? ( app-shells/zsh )"
-DEPEND="${CDEPEND}
- emacs? ( virtual/emacs )
+DEPEND="emacs? ( virtual/emacs )
test? ( app-arch/unzip
dev-python/pygments )
app-text/asciidoc"
S="${WORKDIR}/hg"
+PYTHON_CFLAGS=(
+ "2.* + -fno-strict-aliasing"
+ "* - -ftracer -ftree-vectorize"
+)
+
PYTHON_MODNAME="${PN} hgext"
SITEFILE="70${PN}-gentoo.el"
src_compile() {
- filter-flags -ftracer -ftree-vectorize
-
distutils_src_compile
if use emacs; then
@@ -103,10 +107,13 @@ src_test() {
rm -f test-journal-exists
rm -f test-repair-strip
fi
- local testdir="${T}/tests"
- rm -rf "${testdir}"
- einfo "Running Mercurial tests ..."
- python run-tests.py --tmpdir="${testdir}" || die "test failed"
+
+ testing() {
+ local testdir="${T}/tests-${PYTHON_ABI}"
+ rm -rf "${testdir}"
+ "$(PYTHON)" run-tests.py -j4 --tmpdir="${testdir}"
+ }
+ python_execute_function testing
}
pkg_postinst() {