summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-03-22 15:49:16 +0000
committerJohannes Huber <johu@gentoo.org>2014-03-22 15:49:16 +0000
commit9a71dd7c0a04e71a6229de432f37f079cbcd6a9d (patch)
tree20671236eab9148f9527da6f89e4b2a544c45ecb /dev-vcs
parentSet DISTUTILS_OPTIONAL by Bruno (bug #505344). (diff)
downloadgentoo-2-9a71dd7c0a04e71a6229de432f37f079cbcd6a9d.tar.gz
gentoo-2-9a71dd7c0a04e71a6229de432f37f079cbcd6a9d.tar.bz2
gentoo-2-9a71dd7c0a04e71a6229de432f37f079cbcd6a9d.zip
New package wrt bug #419943. Import from johu overlay. Initial ebuild by Moritz Schlarb <moschlar@metalabs.de>.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-flow/ChangeLog11
-rw-r--r--dev-vcs/git-flow/files/git-flow-0.4.1-unbundle-shflags.patch32
-rw-r--r--dev-vcs/git-flow/git-flow-0.4.1.ebuild51
-rw-r--r--dev-vcs/git-flow/metadata.xml11
4 files changed, 105 insertions, 0 deletions
diff --git a/dev-vcs/git-flow/ChangeLog b/dev-vcs/git-flow/ChangeLog
new file mode 100644
index 000000000000..51baca69e3b3
--- /dev/null
+++ b/dev-vcs/git-flow/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-vcs/git-flow
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-flow/ChangeLog,v 1.1 2014/03/22 15:49:16 johu Exp $
+
+*git-flow-0.4.1 (22 Mar 2014)
+
+ 22 Mar 2014; Johannes Huber <johu@gentoo.org> +git-flow-0.4.1.ebuild,
+ +files/git-flow-0.4.1-unbundle-shflags.patch, +metadata.xml:
+ New package wrt bug #419943. Import from johu overlay. Initial ebuild by
+ Moritz Schlarb <moschlar@metalabs.de>.
+
diff --git a/dev-vcs/git-flow/files/git-flow-0.4.1-unbundle-shflags.patch b/dev-vcs/git-flow/files/git-flow-0.4.1-unbundle-shflags.patch
new file mode 100644
index 000000000000..93ecb7248c21
--- /dev/null
+++ b/dev-vcs/git-flow/files/git-flow-0.4.1-unbundle-shflags.patch
@@ -0,0 +1,32 @@
+diff --git a/Makefile b/Makefile
+index fbbfd2c..b0e2490 100644
+--- a/Makefile
++++ b/Makefile
+@@ -40,14 +40,12 @@ SCRIPT_FILES+=git-flow-release
+ SCRIPT_FILES+=git-flow-support
+ SCRIPT_FILES+=git-flow-version
+ SCRIPT_FILES+=gitflow-common
+-SCRIPT_FILES+=gitflow-shFlags
+
+ all:
+ @echo "usage: make install"
+ @echo " make uninstall"
+
+ install:
+- @test -f gitflow-shFlags || (echo "Run 'git submodule init && git submodule update' first." ; exit 1 )
+ install -d -m 0755 $(prefix)/bin
+ install -m 0755 $(EXEC_FILES) $(prefix)/bin
+ install -m 0644 $(SCRIPT_FILES) $(prefix)/bin
+diff --git a/git-flow b/git-flow
+index 93e9f0f..7b643d3 100755
+--- a/git-flow
++++ b/git-flow
+@@ -78,7 +78,7 @@ main() {
+ export POSIXLY_CORRECT=1
+
+ # use the shFlags project to parse the command line arguments
+- . "$GITFLOW_DIR/gitflow-shFlags"
++ . /usr/share/misc/shflags
+ FLAGS_PARENT="git flow"
+ FLAGS "$@" || exit $?
+ eval set -- "${FLAGS_ARGV}"
diff --git a/dev-vcs/git-flow/git-flow-0.4.1.ebuild b/dev-vcs/git-flow/git-flow-0.4.1.ebuild
new file mode 100644
index 000000000000..1d5aa70c3d2b
--- /dev/null
+++ b/dev-vcs/git-flow/git-flow-0.4.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-flow/git-flow-0.4.1.ebuild,v 1.1 2014/03/22 15:49:16 johu Exp $
+
+EAPI=5
+
+MY_PN="${PN/-/}"
+COMP_PN="${PN}-completion"
+COMP_PV="0.4.2.2"
+COMP_P="${COMP_PN}-${COMP_PV}"
+inherit eutils bash-completion-r1
+
+DESCRIPTION="Git extensions to provide high-level repository operations for Vincent Driessen's branching model"
+HOMEPAGE="https://github.com/nvie/gitflow"
+SRC_URI="https://github.com/nvie/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+https://github.com/bobthecow/${COMP_PN}/archive/${COMP_PV}.tar.gz -> ${COMP_P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-util/shflags
+ dev-vcs/git
+"
+
+DOCS=( AUTHORS Changes.mdown README.mdown )
+
+PATCHES=( "${FILESDIR}/${P}-unbundle-shflags.patch" )
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ [[ ${PATCHES[@]} ]] && epatch "${PATCHES[@]}"
+ debug-print "$FUNCNAME: applying user patches"
+ epatch_user
+}
+
+src_compile() {
+ true
+}
+
+src_install() {
+ emake prefix="${D}/usr" install
+
+ [[ ${DOCS[@]} ]] && dodoc "${DOCS[@]}"
+
+ newbashcomp "${WORKDIR}/${COMP_P}/${COMP_PN}.bash" ${PN}
+}
diff --git a/dev-vcs/git-flow/metadata.xml b/dev-vcs/git-flow/metadata.xml
new file mode 100644
index 000000000000..4f5a42ecea3d
--- /dev/null
+++ b/dev-vcs/git-flow/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>johu@gentoo.org</email>
+ <name>Johannes Huber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">nvie/gitflow</remote-id>
+ </upstream>
+</pkgmetadata>