summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2012-05-06 13:59:20 +0000
committerMike Auty <ikelos@gentoo.org>2012-05-06 13:59:20 +0000
commita82671adbe6a796f17d58f0f0f26df78b3db3905 (patch)
tree2d8a3f60483987f6827adfb995930e44e77b9975 /dev-vcs
parentImprove SYSCONFDIR patch. (diff)
downloadgentoo-2-a82671adbe6a796f17d58f0f0f26df78b3db3905.tar.gz
gentoo-2-a82671adbe6a796f17d58f0f0f26df78b3db3905.tar.bz2
gentoo-2-a82671adbe6a796f17d58f0f0f26df78b3db3905.zip
Fix bug 414835, no version bump since it's a compilation bug.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/giggle/ChangeLog6
-rw-r--r--dev-vcs/giggle/files/giggle-0.6.1-gmodule-explicit.patch23
-rw-r--r--dev-vcs/giggle/giggle-0.6.1.ebuild9
3 files changed, 35 insertions, 3 deletions
diff --git a/dev-vcs/giggle/ChangeLog b/dev-vcs/giggle/ChangeLog
index d423c55d1806..e708f9ec084f 100644
--- a/dev-vcs/giggle/ChangeLog
+++ b/dev-vcs/giggle/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/giggle
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/giggle/ChangeLog,v 1.13 2012/05/03 02:57:15 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/giggle/ChangeLog,v 1.14 2012/05/06 13:59:19 ikelos Exp $
+
+ 06 May 2012; Mike Auty <ikelos@gentoo.org> giggle-0.6.1.ebuild,
+ +files/giggle-0.6.1-gmodule-explicit.patch:
+ Fix bug 414835, no version bump since it's a compilation bug.
03 May 2012; Jeff Horelick <jdhore@gentoo.org> giggle-0.5.ebuild,
giggle-0.6.1.ebuild:
diff --git a/dev-vcs/giggle/files/giggle-0.6.1-gmodule-explicit.patch b/dev-vcs/giggle/files/giggle-0.6.1-gmodule-explicit.patch
new file mode 100644
index 000000000000..2716ea2cdeef
--- /dev/null
+++ b/dev-vcs/giggle/files/giggle-0.6.1-gmodule-explicit.patch
@@ -0,0 +1,23 @@
+From 6a4d71af9920df76a15e427671c90952fddbb411 Mon Sep 17 00:00:00 2001
+From: Vincent Untz <vuntz@gnome.org>
+Date: Thu, 19 Jan 2012 13:48:40 +0000
+Subject: build: Explicitly link to gmodule-2.0
+
+gmodule-2.0 is now gone from the pkg-config files for GTK+ 3 and others.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=667350
+---
+diff --git a/configure.ac b/configure.ac
+index 07f5b7b..aa11046 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -55,6 +55,7 @@ GTKSOURCE_REQUIRED_VERSION=3.0
+ PKG_CHECK_MODULES(GIGGLE, [
+ gio-2.0 >= $GLIB_REQUIRED_VERSION
+ glib-2.0 >= $GLIB_REQUIRED_VERSION
++ gmodule-2.0 >= $GLIB_REQUIRED_VERSION
+ gthread-2.0 >= $GLIB_REQUIRED_VERSION
+ gdk-pixbuf-2.0 >= $GDK_PIXBUF_REQUIRED_VERSION
+ gdk-3.0 >= $GTK_REQUIRED_VERSION
+--
+cgit v0.9.0.2
diff --git a/dev-vcs/giggle/giggle-0.6.1.ebuild b/dev-vcs/giggle/giggle-0.6.1.ebuild
index 0f429cdbc221..f9788ea79451 100644
--- a/dev-vcs/giggle/giggle-0.6.1.ebuild
+++ b/dev-vcs/giggle/giggle-0.6.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/giggle/giggle-0.6.1.ebuild,v 1.5 2012/05/03 02:57:15 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/giggle/giggle-0.6.1.ebuild,v 1.6 2012/05/06 13:59:19 ikelos Exp $
EAPI="3"
-inherit gnome2
+inherit gnome2 autotools eutils
DESCRIPTION="GTK+ Frontend for GIT"
HOMEPAGE="http://live.gnome.org/giggle"
@@ -32,3 +32,8 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog NEWS README"
G2CONF="$(use_enable eds evolution-data-server)"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gmodule-explicit.patch"
+ eautoreconf
+}