summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2011-04-15 08:19:45 +0000
committerFabian Groffen <grobian@gentoo.org>2011-04-15 08:19:45 +0000
commitb8f5ffbec6db01069dfc7d56556db56dba596745 (patch)
tree76633cc14cbbe40ff21e2d8d9bb63cfb5c148f7c /dev-vcs
parentVersion bump. (diff)
downloadgentoo-2-b8f5ffbec6db01069dfc7d56556db56dba596745.tar.gz
gentoo-2-b8f5ffbec6db01069dfc7d56556db56dba596745.tar.bz2
gentoo-2-b8f5ffbec6db01069dfc7d56556db56dba596745.zip
Fix build on Darwin 10 systems with Xcode 4.0, bug #362891
(Portage version: 2.2.01.18091-prefix/cvs/SunOS i386)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/mercurial/ChangeLog5
-rw-r--r--dev-vcs/mercurial/mercurial-1.8.2.ebuild10
2 files changed, 13 insertions, 2 deletions
diff --git a/dev-vcs/mercurial/ChangeLog b/dev-vcs/mercurial/ChangeLog
index 8670d5e1f599..8711e2763dbf 100644
--- a/dev-vcs/mercurial/ChangeLog
+++ b/dev-vcs/mercurial/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-vcs/mercurial
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/ChangeLog,v 1.42 2011/04/04 06:54:39 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/ChangeLog,v 1.43 2011/04/15 08:19:45 grobian Exp $
+
+ 15 Apr 2011; Fabian Groffen <grobian@gentoo.org> mercurial-1.8.2.ebuild:
+ Fix build on Darwin 10 systems with Xcode 4.0, bug #362891
*mercurial-1.8.2 (04 Apr 2011)
diff --git a/dev-vcs/mercurial/mercurial-1.8.2.ebuild b/dev-vcs/mercurial/mercurial-1.8.2.ebuild
index c4444c1c80cc..410be5fe3eab 100644
--- a/dev-vcs/mercurial/mercurial-1.8.2.ebuild
+++ b/dev-vcs/mercurial/mercurial-1.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-1.8.2.ebuild,v 1.1 2011/04/04 06:54:39 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-1.8.2.ebuild,v 1.2 2011/04/15 08:19:45 grobian Exp $
EAPI=3
PYTHON_DEPEND="2"
@@ -35,6 +35,14 @@ PYTHON_CFLAGS=(
PYTHON_MODNAME="${PN} hgext"
SITEFILE="70${PN}-gentoo.el"
+src_prepare() {
+ distutils_src_prepare
+
+ # fix up logic that won't work in Gentoo Prefix (also won't outside in
+ # certain cases), bug #362891
+ sed -i -e 's:xcodebuild:nocodebuild:' setup.py || die
+}
+
src_compile() {
distutils_src_compile