summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-01-14 07:39:44 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-01-14 07:39:44 +0000
commitc602c25061f6b166e343e68497609dd2438dc471 (patch)
tree23e07dc3e97f11bcf67246d10c77a8710974c631 /dev-vcs
parentFix broken USE=doc and install additional documentation files. Make build out... (diff)
downloadgentoo-2-c602c25061f6b166e343e68497609dd2438dc471.tar.gz
gentoo-2-c602c25061f6b166e343e68497609dd2438dc471.tar.bz2
gentoo-2-c602c25061f6b166e343e68497609dd2438dc471.zip
Bump
(Portage version: 2.2.8/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/cvsd/ChangeLog10
-rw-r--r--dev-vcs/cvsd/cvsd-1.0.17.ebuild44
2 files changed, 51 insertions, 3 deletions
diff --git a/dev-vcs/cvsd/ChangeLog b/dev-vcs/cvsd/ChangeLog
index acd7332ffcb2..047f6641197a 100644
--- a/dev-vcs/cvsd/ChangeLog
+++ b/dev-vcs/cvsd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/cvsd
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvsd/ChangeLog,v 1.2 2012/06/07 21:48:58 zmedico Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvsd/ChangeLog,v 1.3 2014/01/14 07:39:44 patrick Exp $
+
+*cvsd-1.0.17 (14 Jan 2014)
+
+ 14 Jan 2014; Patrick Lauer <patrick@gentoo.org> +cvsd-1.0.17.ebuild:
+ Bump
07 Jun 2012; Zac Medico <zmedico@gentoo.org> cvsd-1.0.16.ebuild,
cvsd-1.0.7.ebuild, cvsd-1.0.8.ebuild:
@@ -124,4 +129,3 @@
26 Jul 2003; Grant Goodyear <g2boojum@gentoo.org> cvsd-0.9.19.ebuild,
files/cvsd.confd, files/cvsd.init:
New package, long overdue, with many thanks to Enrico Morelli (Bug 18380).
-
diff --git a/dev-vcs/cvsd/cvsd-1.0.17.ebuild b/dev-vcs/cvsd/cvsd-1.0.17.ebuild
new file mode 100644
index 000000000000..d28b5f792e88
--- /dev/null
+++ b/dev-vcs/cvsd/cvsd-1.0.17.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvsd/cvsd-1.0.17.ebuild,v 1.1 2014/01/14 07:39:44 patrick Exp $
+
+inherit eutils user
+
+DESCRIPTION="CVS pserver daemon."
+HOMEPAGE="http://ch.tudelft.nl/~arthur/cvsd/"
+SRC_URI="http://ch.tudelft.nl/~arthur/cvsd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="tcpd"
+
+DEPEND=">=dev-vcs/cvs-1.11.6
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+RDEPEND="${DEPEND}
+ >=dev-lang/perl-5.8.0"
+
+pkg_setup() {
+ enewgroup cvsd
+ enewuser cvsd -1 -1 /var/lib/cvsd cvsd
+}
+
+src_compile() {
+ econf $(use_with tcpd libwrap) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dosed 's:^Repos:# Repos:g' /etc/cvsd/cvsd.conf
+ keepdir /var/lib/cvsd
+
+ dodoc AUTHORS ChangeLog FAQ INSTALL NEWS README TODO
+
+ newinitd "${FILESDIR}/cvsd.rc6" ${PN}
+}
+
+pkg_postinst() {
+ elog "To configure cvsd please read the README in "
+ elog "/usr/share/doc/${PF}/"
+}