summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-09 19:26:00 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-09 19:26:00 +0000
commit6910b2e0c5bab4c11d10c7ae18fdb10a45fba5f7 (patch)
treef6a74b4fd3a32dec61076a45b8f89ce1a1d603e5 /eclass/distutils.eclass
parentFix implicit wait() decl warning. (diff)
downloadgentoo-2-6910b2e0c5bab4c11d10c7ae18fdb10a45fba5f7.tar.gz
gentoo-2-6910b2e0c5bab4c11d10c7ae18fdb10a45fba5f7.tar.bz2
gentoo-2-6910b2e0c5bab4c11d10c7ae18fdb10a45fba5f7.zip
Add support for DISTUTILS_DISABLE_PYTHON_DEPENDENCY variable. Improve handling of documentation in distutils_src_install().
Diffstat (limited to 'eclass/distutils.eclass')
-rw-r--r--eclass/distutils.eclass20
1 files changed, 12 insertions, 8 deletions
diff --git a/eclass/distutils.eclass b/eclass/distutils.eclass
index c26813274992..a73ef059d461 100644
--- a/eclass/distutils.eclass
+++ b/eclass/distutils.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils.eclass,v 1.61 2009/09/07 02:34:10 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils.eclass,v 1.62 2009/09/09 19:26:00 arfrever Exp $
# @ECLASS: distutils.eclass
# @MAINTAINER:
@@ -24,8 +24,10 @@ case "${EAPI:-0}" in
;;
esac
-DEPEND="virtual/python"
-RDEPEND="${DEPEND}"
+if [[ -z "${DISTUTILS_DISABLE_PYTHON_DEPENDENCY}" ]]; then
+ DEPEND="virtual/python"
+ RDEPEND="${DEPEND}"
+fi
python="python"
# @ECLASS-VARIABLE: DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES
@@ -159,15 +161,17 @@ distutils_src_install() {
${python} setup.py "${DISTUTILS_GLOBAL_OPTIONS[@]}" install --root="${D}" --no-compile "$@" || die "Installation failed"
fi
- DDOCS="CHANGELOG KNOWN_BUGS MAINTAINERS PKG-INFO CONTRIBUTORS TODO NEWS"
- DDOCS="${DDOCS} Change* MANIFEST* README* AUTHORS"
+ local default_docs
+ default_docs="AUTHORS Change* CHANGELOG CONTRIBUTORS KNOWN_BUGS MAINTAINERS MANIFEST* NEWS PKG-INFO README* TODO"
local doc
- for doc in ${DDOCS}; do
- [[ -s "$doc" ]] && dodoc $doc
+ for doc in ${default_docs}; do
+ [[ -s "${doc}" ]] && dodoc "${doc}"
done
- [[ -n "${DOCS}" ]] && dodoc ${DOCS}
+ if [[ -n "${DOCS}" ]]; then
+ dodoc ${DOCS} || die "dodoc failed"
+ fi
}
# @FUNCTION: distutils_pkg_postrm