summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorPetre Rodan <kaiowas@gentoo.org>2007-07-07 16:21:07 +0000
committerPetre Rodan <kaiowas@gentoo.org>2007-07-07 16:21:07 +0000
commit47e278293d873cbe5f4d3ee3ce4b6140d4da8897 (patch)
tree777865b2ac80610739930ee7fe826076e853c4cf /eclass
parentmasked selinux-lpd and selinux-munin to keep repoman happy (diff)
downloadgentoo-2-47e278293d873cbe5f4d3ee3ce4b6140d4da8897.tar.gz
gentoo-2-47e278293d873cbe5f4d3ee3ce4b6140d4da8897.tar.bz2
gentoo-2-47e278293d873cbe5f4d3ee3ce4b6140d4da8897.zip
added support for POLICY_PATCH
Diffstat (limited to 'eclass')
-rw-r--r--eclass/selinux-policy-2.eclass8
1 files changed, 7 insertions, 1 deletions
diff --git a/eclass/selinux-policy-2.eclass b/eclass/selinux-policy-2.eclass
index 2275a0a8c4e9..ae4d411a8658 100644
--- a/eclass/selinux-policy-2.eclass
+++ b/eclass/selinux-policy-2.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/selinux-policy-2.eclass,v 1.2 2006/10/25 11:27:36 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/selinux-policy-2.eclass,v 1.3 2007/07/07 16:21:07 kaiowas Exp $
# Eclass for installing SELinux policy, and optionally
# reloading the reference-policy based modules
@@ -40,6 +40,12 @@ selinux-policy-2_src_unpack() {
cp ${S}/refpolicy/doc/Makefile.example ${S}/${i}/Makefile
cp ${modfiles} ${S}/${i}
+
+ if [ -n "${POLICY_PATCH}" ]; then
+ cd ${S}/${i}
+ epatch "${POLICY_PATCH}" || die "failed patch ${i}"
+ fi
+
done
}