summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-02-05 23:21:28 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-02-05 23:21:28 +0000
commit7c8107a4fe64a7fcce2c8f0a120ef332e98dcde7 (patch)
treeeb68139246159c715909bac79759228465e280ad /games-action/atanks/atanks-1.1.0.ebuild
parentversion bump (diff)
downloadgentoo-2-7c8107a4fe64a7fcce2c8f0a120ef332e98dcde7.tar.gz
gentoo-2-7c8107a4fe64a7fcce2c8f0a120ef332e98dcde7.tar.bz2
gentoo-2-7c8107a4fe64a7fcce2c8f0a120ef332e98dcde7.zip
version bump
Diffstat (limited to 'games-action/atanks/atanks-1.1.0.ebuild')
-rw-r--r--games-action/atanks/atanks-1.1.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-action/atanks/atanks-1.1.0.ebuild b/games-action/atanks/atanks-1.1.0.ebuild
new file mode 100644
index 000000000000..8d7bb5e81961
--- /dev/null
+++ b/games-action/atanks/atanks-1.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/atanks-1.1.0.ebuild,v 1.1 2004/02/05 23:21:16 mr_bones_ Exp $
+
+inherit games
+
+DATA_DIR="${GAMES_DATADIR}/${PN}"
+S="${WORKDIR}/${PN}"
+DESCRIPTION="Worms and Scorched Earth-like game"
+HOMEPAGE="http://atanks.sourceforge.net/"
+SRC_URI="mirror://sourceforge/atanks/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/x11
+ >=sys-apps/sed-4
+ >=media-libs/allegro-4.0.3
+ >=media-libs/allegttf-2.0"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "s:DATA_DIR=.*:DATA_DIR=\\\\\"${DATA_DIR}\\\\\":" src/Makefile || \
+ die "sed src/Makefile failed"
+}
+
+src_install() {
+ dogamesbin atanks || die "dogamesbin failed"
+ dodir "${DATA_DIR}"
+ cp {credits,gloat,instr,revenge}.txt *dat "${D}${DATA_DIR}" || \
+ die "cp failed"
+
+ dodoc BUGS Changelog Help.txt tanks.txt README TODO || die "dodoc failed"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ einfo "NOTE: If you had atanks version 0.9.8b or less installed"
+ einfo "remove ~/.atanks-config to take advantage of new features."
+ games_pkg_postinst
+}