summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-11-16 01:18:38 +0000
committerMike Frysinger <vapier@gentoo.org>2003-11-16 01:18:38 +0000
commite94a03bf6e71a82342a4c68cda8c31e5102e7506 (patch)
tree328152518008d7e573a521e2400968dd806ad8dd /games-action/chromium
parentAdded hppa to KEYWORDS. (diff)
downloadgentoo-2-e94a03bf6e71a82342a4c68cda8c31e5102e7506.tar.gz
gentoo-2-e94a03bf6e71a82342a4c68cda8c31e5102e7506.tar.bz2
gentoo-2-e94a03bf6e71a82342a4c68cda8c31e5102e7506.zip
environment warning
Diffstat (limited to 'games-action/chromium')
-rw-r--r--games-action/chromium/chromium-0.9.12-r4.ebuild17
1 files changed, 13 insertions, 4 deletions
diff --git a/games-action/chromium/chromium-0.9.12-r4.ebuild b/games-action/chromium/chromium-0.9.12-r4.ebuild
index bc1c336e1ec3..35abda1cf03c 100644
--- a/games-action/chromium/chromium-0.9.12-r4.ebuild
+++ b/games-action/chromium/chromium-0.9.12-r4.ebuild
@@ -1,18 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/chromium/chromium-0.9.12-r4.ebuild,v 1.3 2003/10/14 07:28:08 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/chromium/chromium-0.9.12-r4.ebuild,v 1.4 2003/11/16 01:18:38 vapier Exp $
inherit games eutils
-S=${WORKDIR}/Chromium-0.9
DESCRIPTION="Chromium B.S.U. - an arcade game"
HOMEPAGE="http://www.reptilelabour.com/software/chromium/"
SRC_URI="http://www.reptilelabour.com/software/files/chromium/chromium-src-${PV}.tar.gz
http://www.reptilelabour.com/software/files/chromium/chromium-data-${PV}.tar.gz"
+LICENSE="Artistic"
SLOT="0"
KEYWORDS="x86 ppc alpha amd64"
-LICENSE="Artistic"
IUSE="arts esd qt sdl svga oggvorbis alsa"
DEPEND="virtual/glibc
@@ -30,6 +29,8 @@ DEPEND="virtual/glibc
svga? ( media-libs/svgalib )
>=media-libs/smpeg-0.4.4-r1" # this last isn't strictly needed but is useful
+S=${WORKDIR}/Chromium-0.9
+
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${P}-gcc3-gentoo.patch
@@ -47,7 +48,7 @@ src_compile() {
}
src_install() {
- rm -rf `find -name CVS`
+ find ${D} -name CVS -type d -exec rm -rf '{}' \;
exeinto ${GAMES_BINDIR}
doexe bin/chromium*
@@ -60,3 +61,11 @@ src_install() {
prepgamesdirs
}
+
+pkg_postinst() {
+ games_pkg_postinst
+ ewarn "Before you play this game you must"
+ ewarn "update your environment."
+ ewarn "Either restart your shell or just run:"
+ ewarn "source /etc/profile"
+}