summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-07-02 05:48:27 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-07-02 05:48:27 +0000
commit32f9419bc35e6b6eb60faa97617f0d63612f782e (patch)
tree4b9fe1ba39d9ee9c7c63372f0a2db89cce30ca4b /games-action/d2x-rebirth
parent-0.6.0_p20140104;drop py2.6 -0.6.1; drop py2.6 add py3.4 pypy, removed IUSE t... (diff)
downloadgentoo-2-32f9419bc35e6b6eb60faa97617f0d63612f782e.tar.gz
gentoo-2-32f9419bc35e6b6eb60faa97617f0d63612f782e.tar.bz2
gentoo-2-32f9419bc35e6b6eb60faa97617f0d63612f782e.zip
version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-action/d2x-rebirth')
-rw-r--r--games-action/d2x-rebirth/ChangeLog9
-rw-r--r--games-action/d2x-rebirth/d2x-rebirth-0.58.1.ebuild94
-rw-r--r--games-action/d2x-rebirth/files/d2x-rebirth-0.58.1-flags.patch10
3 files changed, 111 insertions, 2 deletions
diff --git a/games-action/d2x-rebirth/ChangeLog b/games-action/d2x-rebirth/ChangeLog
index 7119a1685fbc..2c278cba6ef6 100644
--- a/games-action/d2x-rebirth/ChangeLog
+++ b/games-action/d2x-rebirth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/d2x-rebirth
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x-rebirth/ChangeLog,v 1.7 2014/05/15 16:22:00 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x-rebirth/ChangeLog,v 1.8 2014/07/02 05:48:27 mr_bones_ Exp $
+
+*d2x-rebirth-0.58.1 (02 Jul 2014)
+
+ 02 Jul 2014; Michael Sterrett <mr_bones_@gentoo.org>
+ +d2x-rebirth-0.58.1.ebuild, +files/d2x-rebirth-0.58.1-flags.patch:
+ version bump
15 May 2014; Ulrich Müller <ulm@gentoo.org> d2x-rebirth-0.57.3.ebuild:
Fix USE dependency on media-libs/libsdl, "audio" USE flag was renamed to
@@ -31,4 +37,3 @@
+d2x-rebirth-0.50.ebuild:
Initial import. Ebuild by Paul Bredbury <brebs@sent.com>. Closing bug
#137309.
-
diff --git a/games-action/d2x-rebirth/d2x-rebirth-0.58.1.ebuild b/games-action/d2x-rebirth/d2x-rebirth-0.58.1.ebuild
new file mode 100644
index 000000000000..a8b449aaf0c2
--- /dev/null
+++ b/games-action/d2x-rebirth/d2x-rebirth-0.58.1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x-rebirth/d2x-rebirth-0.58.1.ebuild,v 1.1 2014/07/02 05:48:27 mr_bones_ Exp $
+
+EAPI=5
+
+inherit eutils scons-utils games
+
+DV=2
+MY_P=dxx-rebirth-${PV}-d2x
+DESCRIPTION="Descent Rebirth - enhanced Descent ${DV} engine"
+HOMEPAGE="http://www.dxx-rebirth.com/"
+SRC_URI="https://github.com/dxx-rebirth/dxx-rebirth/archive/0.58.1-d2x.tar.gz -> ${P}.tar.gz
+ opl3-musicpack? ( http://www.dxx-rebirth.com/download/dxx/res/d${DV}xr-opl3-music.zip )
+ sc55-musicpack? ( http://www.dxx-rebirth.com/download/dxx/res/d${DV}xr-sc55-music.zip )
+ linguas_de? ( http://www.dxx-rebirth.com/download/dxx/res/d${DV}xr-briefings-ger.zip )"
+
+LICENSE="D1X GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cdinstall debug demo ipv6 linguas_de +music opengl opl3-musicpack sc55-musicpack"
+REQUIRED_USE="?? ( opl3-musicpack sc55-musicpack )
+ opl3-musicpack? ( music )
+ sc55-musicpack? ( music )"
+
+RDEPEND="dev-games/physfs[hog,mvl,zip]
+ media-libs/libsdl[X,sound,joystick,opengl?,video]
+ music? (
+ media-libs/sdl-mixer[timidity,vorbis]
+ )
+ opengl? (
+ virtual/opengl
+ virtual/glu
+ )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+PDEPEND="cdinstall? ( games-action/descent2-data )
+ demo? ( games-action/descent2-demodata )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${P}.tar.gz
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-flags.patch
+
+ DOCS=( {CHANGELOG,INSTALL,README,RELEASE-NOTES}.txt )
+ edos2unix ${DOCS[@]}
+}
+
+src_compile() {
+ escons \
+ verbosebuild=1 \
+ sharepath="${GAMES_DATADIR}/d${DV}x" \
+ $(use_scons ipv6) \
+ $(use_scons music sdlmixer) \
+ $(use_scons debug) \
+ $(use_scons opengl) \
+ || die
+}
+
+src_install() {
+ dodoc ${DOCS[@]}
+
+ insinto "${GAMES_DATADIR}/d${DV}x"
+
+ # None of the following zip files need to be extracted.
+ use linguas_de && newins "${DISTDIR}"/d${DV}xr-briefings-ger.zip d${DV}xr-briefings-ger.dxa
+ use opl3-musicpack && newins "${DISTDIR}"/d${DV}xr-opl3-music.zip d${DV}xr-opl3-music.dxa
+ use sc55-musicpack && newins "${DISTDIR}"/d${DV}xr-sc55-music.zip d${DV}xr-sc55-music.dxa
+
+ doicon ${PN}.xpm
+
+ dogamesbin ${PN}
+ make_desktop_entry ${PN} "Descent ${DV} Rebirth"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if ! use cdinstall ; then
+ echo
+ elog "To play the full game enable USE=\"cdinstall\" or manually "
+ elog "copy the files to ${GAMES_DATADIR}/d${DV}x."
+ elog "See /usr/share/doc/${PF}/INSTALL.txt for details."
+ echo
+ fi
+ elog 'AddOns now use filename extension ".dxa".'
+ elog 'Your old AddOns will not work anymore.'
+ elog 'You can either re-download them or simply'
+ elog 'rename them from *.zip to *.dxa.'
+}
diff --git a/games-action/d2x-rebirth/files/d2x-rebirth-0.58.1-flags.patch b/games-action/d2x-rebirth/files/d2x-rebirth-0.58.1-flags.patch
new file mode 100644
index 000000000000..6da154555b35
--- /dev/null
+++ b/games-action/d2x-rebirth/files/d2x-rebirth-0.58.1-flags.patch
@@ -0,0 +1,10 @@
+--- SConstruct.orig 2014-07-02 01:37:25.546536553 -0400
++++ SConstruct 2014-07-02 01:39:26.564324558 -0400
+@@ -220,7 +220,6 @@
+ env.Append(CPPFLAGS = ['-g'])
+ else:
+ env.Append(CPPDEFINES = ['NDEBUG', 'RELEASE'])
+- env.Append(CPPFLAGS = ['-O2'])
+
+ # profiler?
+ if (self.user_settings.profiler == 1):