summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2011-07-25 04:15:06 +0000
committerSebastian Pipping <sping@gentoo.org>2011-07-25 04:15:06 +0000
commitb6b78bc2bd5008a5b4065f9b96cda5fe105fc325 (patch)
tree1432f92a8e7a3b7db2dbe5b939f7e246c4a63dcb /games-action/openlierox
parentVersion bump. (diff)
downloadgentoo-2-b6b78bc2bd5008a5b4065f9b96cda5fe105fc325.tar.gz
gentoo-2-b6b78bc2bd5008a5b4065f9b96cda5fe105fc325.tar.bz2
gentoo-2-b6b78bc2bd5008a5b4065f9b96cda5fe105fc325.zip
games-action/openlierox: Patch for curl 7.21.7 (bug #376215)
(Portage version: 2.1.10.4/cvs/Linux x86_64)
Diffstat (limited to 'games-action/openlierox')
-rw-r--r--games-action/openlierox/ChangeLog6
-rw-r--r--games-action/openlierox/files/openlierox-0.58_rc1-curl.patch72
-rw-r--r--games-action/openlierox/openlierox-0.58_rc1-r1.ebuild5
3 files changed, 80 insertions, 3 deletions
diff --git a/games-action/openlierox/ChangeLog b/games-action/openlierox/ChangeLog
index b811bf1576e8..d48273118ac5 100644
--- a/games-action/openlierox/ChangeLog
+++ b/games-action/openlierox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/openlierox
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/openlierox/ChangeLog,v 1.6 2011/03/22 17:55:15 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/openlierox/ChangeLog,v 1.7 2011/07/25 04:15:06 sping Exp $
+
+ 25 Jul 2011; Sebastian Pipping <sping@gentoo.org>
+ openlierox-0.58_rc1-r1.ebuild, +files/openlierox-0.58_rc1-curl.patch:
+ Integrate patch for curl 7.21.7 (bug #376215)
*openlierox-0.58_rc1-r1 (22 Mar 2011)
diff --git a/games-action/openlierox/files/openlierox-0.58_rc1-curl.patch b/games-action/openlierox/files/openlierox-0.58_rc1-curl.patch
new file mode 100644
index 000000000000..d151036e7993
--- /dev/null
+++ b/games-action/openlierox/files/openlierox-0.58_rc1-curl.patch
@@ -0,0 +1,72 @@
+diff --git a/include/HTTP.h b/include/HTTP.h
+index 6be27f9..916193b 100644
+--- a/include/HTTP.h
++++ b/include/HTTP.h
+@@ -21,7 +21,12 @@
+
+ #include <string>
+ #include <curl/curl.h>
+-#include <curl/types.h>
++#if ! defined(LIBCURL_VERSION_PATCH) \
++ || (LIBCURL_VERSION_MAJOR < 7) \
++ || ((LIBCURL_VERSION_MAJOR == 7) && (LIBCURL_VERSION_MINOR < 21)) \
++ || ((LIBCURL_VERSION_MAJOR == 7) && (LIBCURL_VERSION_MINOR == 21) && (LIBCURL_VERSION_PATCH < 7))
++# include <curl/types.h>
++#endif
+ #include <curl/easy.h>
+
+ #include "Networking.h"
+diff --git a/src/breakpad/external/src/common/linux/http_upload.cc b/src/breakpad/external/src/common/linux/http_upload.cc
+index 8748d11..c079aef 100644
+--- a/src/breakpad/external/src/common/linux/http_upload.cc
++++ b/src/breakpad/external/src/common/linux/http_upload.cc
+@@ -31,7 +31,12 @@
+ #include <dlfcn.h>
+ #include <curl/curl.h>
+ #include <curl/easy.h>
+-#include <curl/types.h>
++#if ! defined(LIBCURL_VERSION_PATCH) \
++ || (LIBCURL_VERSION_MAJOR < 7) \
++ || ((LIBCURL_VERSION_MAJOR == 7) && (LIBCURL_VERSION_MINOR < 21)) \
++ || ((LIBCURL_VERSION_MAJOR == 7) && (LIBCURL_VERSION_MINOR == 21) && (LIBCURL_VERSION_PATCH < 7))
++# include <curl/types.h>
++#endif
+
+ #include "common/linux/http_upload.h"
+
+diff --git a/src/breakpad/external/src/common/linux/libcurl_wrapper.cc b/src/breakpad/external/src/common/linux/libcurl_wrapper.cc
+index 5bea3af..1fa6d24 100644
+--- a/src/breakpad/external/src/common/linux/libcurl_wrapper.cc
++++ b/src/breakpad/external/src/common/linux/libcurl_wrapper.cc
+@@ -29,7 +29,12 @@
+
+ #include <curl/curl.h>
+ #include <curl/easy.h>
+-#include <curl/types.h>
++#if ! defined(LIBCURL_VERSION_PATCH) \
++ || (LIBCURL_VERSION_MAJOR < 7) \
++ || ((LIBCURL_VERSION_MAJOR == 7) && (LIBCURL_VERSION_MINOR < 21)) \
++ || ((LIBCURL_VERSION_MAJOR == 7) && (LIBCURL_VERSION_MINOR == 21) && (LIBCURL_VERSION_PATCH < 7))
++# include <curl/types.h>
++#endif
+ #include <dlfcn.h>
+
+ #include <string>
+diff --git a/src/common/HTTP.cpp b/src/common/HTTP.cpp
+index 0782f9c..7f7a852 100644
+--- a/src/common/HTTP.cpp
++++ b/src/common/HTTP.cpp
+@@ -25,7 +25,12 @@
+ #include <stdlib.h>
+ #endif
+ #include <curl/curl.h>
+-#include <curl/types.h>
++#if ! defined(LIBCURL_VERSION_PATCH) \
++ || (LIBCURL_VERSION_MAJOR < 7) \
++ || ((LIBCURL_VERSION_MAJOR == 7) && (LIBCURL_VERSION_MINOR < 21)) \
++ || ((LIBCURL_VERSION_MAJOR == 7) && (LIBCURL_VERSION_MINOR == 21) && (LIBCURL_VERSION_PATCH < 7))
++# include <curl/types.h>
++#endif
+ #include <curl/easy.h>
+
+ #include "LieroX.h"
diff --git a/games-action/openlierox/openlierox-0.58_rc1-r1.ebuild b/games-action/openlierox/openlierox-0.58_rc1-r1.ebuild
index 17ba70143df8..ef2825b0b891 100644
--- a/games-action/openlierox/openlierox-0.58_rc1-r1.ebuild
+++ b/games-action/openlierox/openlierox-0.58_rc1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/openlierox/openlierox-0.58_rc1-r1.ebuild,v 1.1 2011/03/22 17:55:15 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/openlierox/openlierox-0.58_rc1-r1.ebuild,v 1.2 2011/07/25 04:15:06 sping Exp $
EAPI="2"
@@ -33,7 +33,8 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_PN}"
src_prepare() {
- epatch "${FILESDIR}"/${P}-icu.patch
+ epatch "${FILESDIR}"/${P}-icu.patch \
+ "${FILESDIR}"/${P}-curl.patch
}
src_configure() {