summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-04-16 22:30:25 +0000
committerMike Frysinger <vapier@gentoo.org>2011-04-16 22:30:25 +0000
commit960f9fb772b43ef5bb1cd0d58830760259f66462 (patch)
treeb45a5aa5ef335268f733d1ad4b5585e32f265fe7 /games-action/shadowgrounds-survivor-bin
parentNew package. (diff)
downloadgentoo-2-960f9fb772b43ef5bb1cd0d58830760259f66462.tar.gz
gentoo-2-960f9fb772b43ef5bb1cd0d58830760259f66462.tar.bz2
gentoo-2-960f9fb772b43ef5bb1cd0d58830760259f66462.zip
New package.
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'games-action/shadowgrounds-survivor-bin')
-rw-r--r--games-action/shadowgrounds-survivor-bin/ChangeLog10
-rw-r--r--games-action/shadowgrounds-survivor-bin/metadata.xml5
-rw-r--r--games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-0_beta11.ebuild57
3 files changed, 72 insertions, 0 deletions
diff --git a/games-action/shadowgrounds-survivor-bin/ChangeLog b/games-action/shadowgrounds-survivor-bin/ChangeLog
new file mode 100644
index 000000000000..e249bdc1abb0
--- /dev/null
+++ b/games-action/shadowgrounds-survivor-bin/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-action/shadowgrounds-survivor-bin
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/shadowgrounds-survivor-bin/ChangeLog,v 1.1 2011/04/16 22:30:25 vapier Exp $
+
+*shadowgrounds-survivor-bin-0_beta11 (16 Apr 2011)
+
+ 16 Apr 2011; Mike Frysinger <vapier@gentoo.org>
+ +shadowgrounds-survivor-bin-0_beta11.ebuild, +metadata.xml:
+ New package.
+
diff --git a/games-action/shadowgrounds-survivor-bin/metadata.xml b/games-action/shadowgrounds-survivor-bin/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-action/shadowgrounds-survivor-bin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-0_beta11.ebuild b/games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-0_beta11.ebuild
new file mode 100644
index 000000000000..5f55fb6b6f80
--- /dev/null
+++ b/games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-0_beta11.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-0_beta11.ebuild,v 1.1 2011/04/16 22:30:25 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="human survivors who battle against the ongoing alien onslaught"
+HOMEPAGE="http://shadowgroundsgame.com/survivor/"
+SRC_URI="Survivor${PV/*_b/B}.run"
+
+LICENSE="frozenbyte-eula"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="fetch strip"
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=sys-libs/glibc-2.4
+ >=sys-devel/gcc-4.3.0"
+
+S=${WORKDIR}
+
+d="${GAMES_PREFIX_OPT}/${PN}"
+QA_TEXTRELS_x86="`echo ${d#/}/lib32/lib{avcodec.so.51,avformat.so.52,avutil.so.49,FLAC.so.8}`"
+QA_TEXTRELS_amd64=${QA_TEXTRELS_x86}
+
+pkg_nofetch() {
+ einfo "Fetch ${SRC_URI} and put it into ${DISTDIR}"
+ einfo "See http://www.humblebundle.com/ for more info."
+}
+
+src_unpack() {
+ # manually run unzip as the initial seek causes it to exit(1)
+ unzip -q "${DISTDIR}/${A}"
+ rm lib*/lib{gcc_s,m,rt,selinux}.so.?
+}
+
+src_install() {
+ local b bb
+
+ doicon Survivor.xpm || die
+ for b in bin launcher ; do
+ bb="survivor-${b}"
+ exeinto ${d}
+ newexe ${bb} ${bb} || die
+ games_make_wrapper ${bb} "./${bb}" "${d}" || die
+ make_desktop_entry ${bb} "Shadowgrounds Survivor ${b}" "Shadowgrounds Survivor"
+ done
+
+ exeinto ${d}/lib32
+ doexe lib32/* || die
+
+ insinto ${d}
+ doins -r Config data Profiles *.fbz *.glade *-logo.png || die
+
+ prepgamesdirs
+}