summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-06-03 14:17:13 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-06-03 14:17:13 +0000
commit3a68ff2c1dae6373aed6b5826bc89584a4f8ffa8 (patch)
tree59278369c4543ed3dde1b8ac834738ead057c47a /games-action/shootingstar/shootingstar-1.2.0.ebuild
parentMarking quanta-3.5.10 ppc64 for bug 271889 (diff)
downloadgentoo-2-3a68ff2c1dae6373aed6b5826bc89584a4f8ffa8.tar.gz
gentoo-2-3a68ff2c1dae6373aed6b5826bc89584a4f8ffa8.tar.bz2
gentoo-2-3a68ff2c1dae6373aed6b5826bc89584a4f8ffa8.zip
Fix build with gcc-4.4.0 Bug #272374
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'games-action/shootingstar/shootingstar-1.2.0.ebuild')
-rw-r--r--games-action/shootingstar/shootingstar-1.2.0.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/games-action/shootingstar/shootingstar-1.2.0.ebuild b/games-action/shootingstar/shootingstar-1.2.0.ebuild
index d52c228828f1..b5ab1a9ac9cd 100644
--- a/games-action/shootingstar/shootingstar-1.2.0.ebuild
+++ b/games-action/shootingstar/shootingstar-1.2.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild,v 1.5 2007/03/14 20:53:28 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild,v 1.6 2009/06/03 14:17:13 tupone Exp $
+
+EAPI=2
inherit eutils games
@@ -18,12 +20,12 @@ DEPEND="virtual/opengl
media-libs/libsdl
media-libs/sdl-mixer
media-libs/sdl-image"
+RDEPEND="${DEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PV}-gcc34.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${PV}-gcc34.patch
+ "${FILESDIR}"/${P}-gcc44.patch
+)
src_install () {
emake DESTDIR="${D}" install || die "emake install failed"