summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-01-03 21:57:03 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-01-03 21:57:03 +0000
commitc45195dcce43fb764c9a90a9ab26e639cdce53fc (patch)
tree868b731855fb3e5cd22a5964f87d68d55eee5cb3 /games-action/supertuxkart
parentTransfer Prefix keywords (diff)
downloadgentoo-2-c45195dcce43fb764c9a90a9ab26e639cdce53fc.tar.gz
gentoo-2-c45195dcce43fb764c9a90a9ab26e639cdce53fc.tar.bz2
gentoo-2-c45195dcce43fb764c9a90a9ab26e639cdce53fc.zip
add USE=nls support (bug #299446)
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-action/supertuxkart')
-rw-r--r--games-action/supertuxkart/ChangeLog8
-rw-r--r--games-action/supertuxkart/supertuxkart-0.6.2.ebuild19
2 files changed, 20 insertions, 7 deletions
diff --git a/games-action/supertuxkart/ChangeLog b/games-action/supertuxkart/ChangeLog
index e1580c3d931d..a50c1bf6c84b 100644
--- a/games-action/supertuxkart/ChangeLog
+++ b/games-action/supertuxkart/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/supertuxkart
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/ChangeLog,v 1.16 2009/10/25 21:34:43 mr_bones_ Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/ChangeLog,v 1.17 2010/01/03 21:57:03 mr_bones_ Exp $
+
+ 03 Jan 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ supertuxkart-0.6.2.ebuild:
+ add USE=nls support (bug #299446)
25 Oct 2009; Michael Sterrett <mr_bones_@gentoo.org>
supertuxkart-0.6.2.ebuild:
diff --git a/games-action/supertuxkart/supertuxkart-0.6.2.ebuild b/games-action/supertuxkart/supertuxkart-0.6.2.ebuild
index 7d60f65e974c..e46e11f9d35d 100644
--- a/games-action/supertuxkart/supertuxkart-0.6.2.ebuild
+++ b/games-action/supertuxkart/supertuxkart-0.6.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/supertuxkart-0.6.2.ebuild,v 1.4 2009/10/25 21:34:43 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/supertuxkart-0.6.2.ebuild,v 1.5 2010/01/03 21:57:03 mr_bones_ Exp $
EAPI=2
inherit autotools eutils games
@@ -13,9 +13,9 @@ SRC_URI="mirror://sourceforge/supertuxkart/files/SuperTuxKart/${PV}/${P}-src.tar
LICENSE="GPL-3 CCPL-Attribution-ShareAlike-3.0 CCPL-Attribution-2.0 CCPL-Sampling-Plus-1.0 public-domain as-is"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
-IUSE=""
+IUSE="nls"
-DEPEND=">=media-libs/plib-1.8.4
+RDEPEND=">=media-libs/plib-1.8.4
virtual/opengl
virtual/glut
virtual/glu
@@ -23,7 +23,10 @@ DEPEND=">=media-libs/plib-1.8.4
media-libs/libmikmod
media-libs/libvorbis
media-libs/openal
- media-libs/libsdl[X,video,audio,joystick]"
+ media-libs/libsdl[X,video,audio,joystick]
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
src_prepare() {
esvn_clean
@@ -53,6 +56,12 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable nls)
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
doicon "${DISTDIR}"/${PN}.png