summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-01-20 01:12:09 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-01-20 01:12:09 +0000
commit1057593dffc7e4e9c92d01ee53cdd29b5fd5923a (patch)
treebbae77a43af4fa27a3cf6c0b36d04fca26d4aca9 /games-action
parentFix minor typo in test runner. (diff)
downloadgentoo-2-1057593dffc7e4e9c92d01ee53cdd29b5fd5923a.tar.gz
gentoo-2-1057593dffc7e4e9c92d01ee53cdd29b5fd5923a.tar.bz2
gentoo-2-1057593dffc7e4e9c92d01ee53cdd29b5fd5923a.zip
old
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/abuse/ChangeLog8
-rw-r--r--games-action/abuse/abuse-0.7.1.ebuild66
-rw-r--r--games-action/abuse/files/abuse-0.7.1-ovflfix.patch11
3 files changed, 6 insertions, 79 deletions
diff --git a/games-action/abuse/ChangeLog b/games-action/abuse/ChangeLog
index cd20f6386489..6159ff2d5a08 100644
--- a/games-action/abuse/ChangeLog
+++ b/games-action/abuse/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/abuse
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/abuse/ChangeLog,v 1.16 2011/10/04 22:27:47 josejx Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/abuse/ChangeLog,v 1.17 2013/01/20 01:12:09 mr_bones_ Exp $
+
+ 20 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org> -abuse-0.7.1.ebuild,
+ -files/abuse-0.7.1-ovflfix.patch:
+ old
04 Oct 2011; Joseph Jezak <josejx@gentoo.org> abuse-0.8.ebuild:
Marked ppc stable for bug #375327.
diff --git a/games-action/abuse/abuse-0.7.1.ebuild b/games-action/abuse/abuse-0.7.1.ebuild
deleted file mode 100644
index d11d64610c5f..000000000000
--- a/games-action/abuse/abuse-0.7.1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/abuse/abuse-0.7.1.ebuild,v 1.14 2011/08/07 14:27:37 armin76 Exp $
-
-EAPI=2
-inherit eutils games
-
-ZOY="http://abuse.zoy.org/raw/Downloads"
-
-DESCRIPTION="port of Abuse by Crack Dot Com"
-HOMEPAGE="http://abuse.zoy.org/"
-SRC_URI="${ZOY}/${P}.tar.gz
- !demo? ( ${ZOY}/abuse-data-2.00.tar.gz )
- demo? ( ${ZOY}/abuse-lib-2.00.tar.gz )
- sound? ( ${ZOY}/abuse-sfx-2.00.tar.gz )
- levels? ( ${ZOY}/abuse-frabs-2.11.tar.gz )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="demo levels sound"
-
-RDEPEND=">=media-libs/libsdl-1.1.6[audio,opengl,video]
- virtual/opengl"
-DEPEND="${RDEPEND}
- x11-libs/libXt"
-
-src_prepare() {
- # fix placing additional patches
- use levels && cp -rf "${WORKDIR}"/abuse-frabs-2.11/{addon,art,levels,lisp,music,netlevel,register} "${WORKDIR}" && rm -rf "${WORKDIR}"/abuse-frabs-2.11/
- use demo && cp -rf "${WORKDIR}"/abuse-lib-2.00.orig/unpacked/{addon,art,levels,lisp,abuse.lsp} "${WORKDIR}" && rm -rf "${WORKDIR}"/abuse-lib-2.00.orig/
- use sound && cp -rf "${WORKDIR}"/abuse-sfx-2.00.orig/sfx "${WORKDIR}" && rm -rf "${WORKDIR}"/abuse-sfx-2.00.orig/
- # fix bug #231822
- sed -i \
- -e "s:/var/games/abuse:${GAMES_DATADIR}/${PN}:" \
- src/sdlport/setup.cpp || or die
- epatch "${FILESDIR}"/${P}-ovflfix.patch
-}
-
-src_configure() {
- # Abuse auto-appends games, so point to the base
- egamesconf --datadir="${GAMES_DATADIR_BASE}"
-}
-
-src_install() {
- # Source-based install
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog README TODO
-
- # Data install
- insinto "${GAMES_DATADIR}"/${PN}
- doins -r "${WORKDIR}"/{addon,art,levels,lisp,music,netlevel,register,sfx} \
- "${WORKDIR}"/abuse.lsp \
- || die
-
- doicon ${PN}.png
- make_desktop_entry abuse "Abuse"
-
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
- elog "NOTE: If you had previous version of abuse installed"
- elog "you may need to remove ~/.abuse for the game to work correctly."
-}
diff --git a/games-action/abuse/files/abuse-0.7.1-ovflfix.patch b/games-action/abuse/files/abuse-0.7.1-ovflfix.patch
deleted file mode 100644
index a9ce1bc87e09..000000000000
--- a/games-action/abuse/files/abuse-0.7.1-ovflfix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/imlib/loader.cpp.old 2010-11-05 17:30:54.000000000 +0100
-+++ src/imlib/loader.cpp 2010-11-05 17:31:19.000000000 +0100
-@@ -114,7 +114,7 @@
- graphics_type tell_file_type(char *filename)
- {
- FILE *fp;
-- unsigned char header[10];
-+ unsigned char header[12];
- fp=fopen(filename,"rb");
- if (!fp)
- return LOADER_not_supported;