summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-06-09 17:11:20 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-06-09 17:11:20 +0000
commit3522ecaa26f797e07baf4f7eac72e2685ad2a296 (patch)
treef20c6a0bd08dc906c95dfffc4d9062406932e272 /games-action
parentdirdiff respects user CFLAGS, some clean up in ebuild, bug #66869 (diff)
downloadgentoo-2-3522ecaa26f797e07baf4f7eac72e2685ad2a296.tar.gz
gentoo-2-3522ecaa26f797e07baf4f7eac72e2685ad2a296.tar.bz2
gentoo-2-3522ecaa26f797e07baf4f7eac72e2685ad2a296.zip
Initial import. This ebuild is based off the ebuild submitted to bug #53123 by Donald R. Gray Jr <donaldgray@dslextreme.com>. Closing bug #65931.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/armagetronad/ChangeLog11
-rw-r--r--games-action/armagetronad/Manifest4
-rw-r--r--games-action/armagetronad/armagetronad-0.2.7.1.ebuild75
-rw-r--r--games-action/armagetronad/files/armagetronad39
-rw-r--r--games-action/armagetronad/files/armagetronad-ded50
-rw-r--r--games-action/armagetronad/files/digest-armagetronad-0.2.7.13
-rw-r--r--games-action/armagetronad/metadata.xml5
7 files changed, 187 insertions, 0 deletions
diff --git a/games-action/armagetronad/ChangeLog b/games-action/armagetronad/ChangeLog
new file mode 100644
index 000000000000..569e8e978019
--- /dev/null
+++ b/games-action/armagetronad/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for games-action/armagetronad
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/armagetronad/ChangeLog,v 1.1 2005/06/09 17:11:20 wolf31o2 Exp $
+
+*armagetronad-0.2.7.1 (09 Jun 2005)
+
+ 09 Jun 2005; Chris Gianelloni <wolf31o2@gentoo.org> +files/armagetronad,
+ +files/armagetronad-ded, +metadata.xml, +armagetronad-0.2.7.1.ebuild:
+ Initial import. This ebuild is based off the ebuild submitted to bug #53123
+ by Donald R. Gray Jr <donaldgray@dslextreme.com>. Closing bug #65931.
+
diff --git a/games-action/armagetronad/Manifest b/games-action/armagetronad/Manifest
new file mode 100644
index 000000000000..4248c6c3c209
--- /dev/null
+++ b/games-action/armagetronad/Manifest
@@ -0,0 +1,4 @@
+MD5 bd04be6d417144ce824f8301a3832ede armagetronad-0.2.7.1.ebuild 1949
+MD5 37312a765833708af1d1712bc4fad0ac files/armagetronad-ded 1340
+MD5 617e831d7f4c02cd72d67800bcf0144f files/armagetronad 1102
+MD5 6a1cb0c3d1b6316c534867da55cd7049 files/digest-armagetronad-0.2.7.1 196
diff --git a/games-action/armagetronad/armagetronad-0.2.7.1.ebuild b/games-action/armagetronad/armagetronad-0.2.7.1.ebuild
new file mode 100644
index 000000000000..41909ab978fa
--- /dev/null
+++ b/games-action/armagetronad/armagetronad-0.2.7.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/armagetronad/armagetronad-0.2.7.1.ebuild,v 1.1 2005/06/09 17:11:20 wolf31o2 Exp $
+
+
+inherit flag-o-matic eutils games
+
+DESCRIPTION="3d tron lightcycles, just like the movie"
+HOMEPAGE="http://armagetronad.sourceforge.net/"
+SRC_URI="mirror://sourceforge/armagetronad/${P}.tar.bz2
+ opengl? (
+ http://armagetron.sourceforge.net/addons/moviesounds_fq.zip
+ http://armagetron.sourceforge.net/addons/moviepack.zip )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="dedicated opengl"
+
+RDEPEND="sys-libs/zlib
+ opengl? (
+ virtual/x11
+ virtual/opengl
+ media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/libpng )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_compile() {
+ filter-flags -fno-exceptions
+ if use dedicated && ! use opengl; then
+ egamesconf --disable-glout || die "egamesconf failed"
+ else
+ egamesconf || die "egamesconf failed"
+ fi
+ emake || die "emake failed"
+ make documentation || "make doc failed"
+}
+
+src_install() {
+ dodoc COPYING.txt
+ dohtml doc/*.html
+ docinto html/net
+ dohtml doc/net/*.html
+ newicon tron.ico ${PN}.ico
+ insinto "${GAMES_LIBDIR}/${PN}"
+ if use dedicated && ! use opengl; then
+ doins src/tron/${PN}-dedicated || die "copying files"
+ else
+ doins src/tron/${PN} || die "copying files"
+ fi
+ doins src/network/armagetronad-* || die "copying files"
+ insinto "${GAMES_DATADIR}/${PN}"
+ if use dedicated && ! use opengl; then
+ doins -r log language || die "copying files"
+ else
+ doins -r arenas models sound textures language log music \
+ || die "copying files"
+ fi
+ insinto "${GAMES_SYSCONFDIR}/${PN}"
+ doins -r config/* || die "copying files"
+ if use dedicated; then
+ dogamesbin "${FILESDIR}/${PN}-ded"
+ fi
+ cd "${S}"
+ insinto "${GAMES_DATADIR}/${PN}"
+ if use opengl; then
+ dogamesbin "${FILESDIR}/${PN}"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r ../moviepack ../moviesounds || die "copying movies"
+ make_desktop_entry armagetronad "Armagetron Advanced" ${PN}.ico
+ fi
+ prepgamesdirs
+}
diff --git a/games-action/armagetronad/files/armagetronad b/games-action/armagetronad/files/armagetronad
new file mode 100644
index 000000000000..fe647e03a56b
--- /dev/null
+++ b/games-action/armagetronad/files/armagetronad
@@ -0,0 +1,39 @@
+#!/bin/bash
+#
+# starts Armagetron Advanced from the installation directory
+
+GAMES_LIBDIR=/usr/games/lib/armagetronad
+GAMES_DATADIR=/usr/share/games
+GAMES_SYSCONFDIR=/etc/games
+PN=armagetronad
+if test ! -r $HOME/.armagetronad ; then
+ mkdir $HOME/.armagetronad
+
+ if test -r $HOME/.ArmageTronrc ; then
+ #migrage very old configuration
+ echo "Porting very old configuration..."
+ mkdir $HOME/.armagetronad/var
+ mv $HOME/.ArmageTronrc $HOME/.armagetronad/var/user.cfg
+ fi
+fi
+
+if test ! -r $HOME/.armagetronad/var ; then
+ #migrate old configuration
+ files=$( find $HOME/.armagetronad -type f -maxdepth 1 )
+
+ mkdir $HOME/.armagetronad/var
+
+ test "$files" != "" && echo "Porting old configuration..." && mv $files $HOME/.armagetronad/var
+fi
+
+if test "x$1" = "x-h" ; then
+ echo -e "\n\nTo uninstall Armagetron Advanced, type armagetronad --uninstall."
+fi
+
+if test "x$1" = "x--uninstall" ; then
+ emerge unmerge armagetronad
+else
+ $GAMES_LIBDIR/$PN --datadir $GAMES_DATADIR/$PN --configdir $GAMES_SYSCONFDIR/$PN \
+ --userdatadir $HOME/.armagetronad $*
+fi
+
diff --git a/games-action/armagetronad/files/armagetronad-ded b/games-action/armagetronad/files/armagetronad-ded
new file mode 100644
index 000000000000..2f3c44763a6c
--- /dev/null
+++ b/games-action/armagetronad/files/armagetronad-ded
@@ -0,0 +1,50 @@
+#!/bin/bash
+#
+# starts Armagetron Advanced Dedicated Server from the installation directory
+
+ GAME_CONFDIR=/etc/games/armagetronad-ded
+ GAME_LIBDIR=/usr/games/lib/armagetronad-ded
+ GAME_DATADIR=/usr/share/games/armagetronad-ded
+ USER_DATADIR=/etc/games/armagetronad-ded
+ CONFIGDIR=/etc/games/armagetronad-ded
+
+ NO=$'\x1b[0;0m'
+ RD=$'\x1b[31;01m'
+ GR=$'\x1b[32;01m'
+ YL=$'\x1b[33;01m'
+
+ echo "${GR} *${NO} Checking Configuration."
+ if test ! -r $HOME/.armagetronad-ded ; then
+ mkdir $HOME/.armagetronad-ded
+
+ if test -r $HOME/.ArmageTronrc ; then
+ echo "${YL} *${NO} Migrating very old configuration."
+ cp $HOME/.ArmageTronrc $HOME/.armagetronad-ded/user.cfg
+ fi
+fi
+ if test ! -r $HOME/.armagetronad-ded/var ; then
+ files=$( ls $HOME/.armagetronad-ded )
+ mkdir $HOME/.armagetronad-ded/var
+ echo "${GR} *${NO} Testing configuration."
+ test "$files" != "" && mv $files $HOME/.armagetronad-ded/var
+ fi
+
+ echo "${GR} *${NO} Done."
+
+
+ if test "x$1" = "x-h" ; then
+ echo "${RD} *${NO} Please uninstall Armagetron Advanced via Portage."
+fi
+
+ if test "x$1" = "x--uninstall" ; then
+ echo "${RD} *${NO} Please uninstall Armagetron Advanced via Portage."
+ else
+
+ while true; do
+
+ $GAME_LIBDIR/armagetronad-dedicated \
+ --datadir $GAME_DATADIR \
+ --configdir $GAME_CONFDIR \
+ --userdatadir $HOME/.armagetronad-ded
+done
+fi \ No newline at end of file
diff --git a/games-action/armagetronad/files/digest-armagetronad-0.2.7.1 b/games-action/armagetronad/files/digest-armagetronad-0.2.7.1
new file mode 100644
index 000000000000..d641470e6ff0
--- /dev/null
+++ b/games-action/armagetronad/files/digest-armagetronad-0.2.7.1
@@ -0,0 +1,3 @@
+MD5 cc29c2fd7de5699173de84d7cde57b97 armagetronad-0.2.7.1.tar.bz2 1243746
+MD5 3c5d04af52eb296cdeb2fba5ecbd8899 moviesounds_fq.zip 2182021
+MD5 e2d40309dde7e1339ca6aff7599cdfa3 moviepack.zip 352253
diff --git a/games-action/armagetronad/metadata.xml b/games-action/armagetronad/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-action/armagetronad/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>