summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-10-14 03:52:04 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-10-14 03:52:04 +0000
commitc305ed9f4cfa3792aa69d939cee06ef3576e6d89 (patch)
tree2d3a58687820aa2cfa2b4d27937ed82f768d91d2 /games-action
parentold (diff)
downloadgentoo-2-c305ed9f4cfa3792aa69d939cee06ef3576e6d89.tar.gz
gentoo-2-c305ed9f4cfa3792aa69d939cee06ef3576e6d89.tar.bz2
gentoo-2-c305ed9f4cfa3792aa69d939cee06ef3576e6d89.zip
use scons-utils
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/btanks/ChangeLog6
-rw-r--r--games-action/btanks/btanks-0.9.8083.ebuild14
2 files changed, 10 insertions, 10 deletions
diff --git a/games-action/btanks/ChangeLog b/games-action/btanks/ChangeLog
index dbbe7080512b..0b4f7bfb690c 100644
--- a/games-action/btanks/ChangeLog
+++ b/games-action/btanks/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/btanks
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/ChangeLog,v 1.22 2010/02/27 18:10:00 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/ChangeLog,v 1.23 2010/10/14 03:52:04 mr_bones_ Exp $
+
+ 14 Oct 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ btanks-0.9.8083.ebuild:
+ use scons-utils
27 Feb 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
btanks-0.9.8083.ebuild:
diff --git a/games-action/btanks/btanks-0.9.8083.ebuild b/games-action/btanks/btanks-0.9.8083.ebuild
index 2ece742c6cdb..d87b56d6c1cd 100644
--- a/games-action/btanks/btanks-0.9.8083.ebuild
+++ b/games-action/btanks/btanks-0.9.8083.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/btanks-0.9.8083.ebuild,v 1.2 2010/02/27 18:10:00 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/btanks-0.9.8083.ebuild,v 1.3 2010/10/14 03:52:04 mr_bones_ Exp $
EAPI=2
-inherit eutils games
+inherit eutils scons-utils games
DESCRIPTION="Fast 2D tank arcade game with multiplayer and split-screen modes"
HOMEPAGE="http://btanks.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+SRC_URI="mirror://sourceforge/btanks/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
@@ -23,7 +23,6 @@ RDEPEND=">=dev-lang/lua-5.1
media-libs/sdl-image[jpeg,png]
media-libs/sdl-gfx"
DEPEND="${RDEPEND}
- dev-util/scons
dev-util/pkgconfig"
src_prepare() {
@@ -32,15 +31,12 @@ src_prepare() {
}
src_compile() {
- local sconsopts=$(echo "${MAKEOPTS}" | sed -ne "/-j/ { s/.*\(-j[[:space:]]*[0-9]\+\).*/\1/; p }")
-
- scons \
- ${sconsopts} \
+ escons \
prefix="${GAMES_PREFIX}" \
lib_dir="$(games_get_libdir)"/${PN} \
plugins_dir="$(games_get_libdir)"/${PN} \
resources_dir="${GAMES_DATADIR}"/${PN} \
- || die "scons failed"
+ || die
}
src_install() {