summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-01-14 06:08:19 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-01-14 06:08:19 +0000
commitc3e63c7824720fa1379beb455f7f5e422991a336 (patch)
tree9c107061c1e745f741b8a414d589d72d10e7c230 /games-action
parentRestrict SLOT in dev-python/pygobject dependency (diff)
downloadgentoo-2-c3e63c7824720fa1379beb455f7f5e422991a336.tar.gz
gentoo-2-c3e63c7824720fa1379beb455f7f5e422991a336.tar.bz2
gentoo-2-c3e63c7824720fa1379beb455f7f5e422991a336.zip
version bump
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/atanks/ChangeLog9
-rw-r--r--games-action/atanks/atanks-6.1.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/games-action/atanks/ChangeLog b/games-action/atanks/ChangeLog
index 098e522521f3..3839ef1f41b4 100644
--- a/games-action/atanks/ChangeLog
+++ b/games-action/atanks/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/atanks
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/ChangeLog,v 1.86 2014/04/23 21:11:10 mr_bones_ Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/ChangeLog,v 1.87 2015/01/14 06:08:19 mr_bones_ Exp $
+
+*atanks-6.1 (14 Jan 2015)
+
+ 14 Jan 2015; Michael Sterrett <mr_bones_@gentoo.org> +atanks-6.1.ebuild:
+ version bump
*atanks-5.9 (23 Apr 2014)
diff --git a/games-action/atanks/atanks-6.1.ebuild b/games-action/atanks/atanks-6.1.ebuild
new file mode 100644
index 000000000000..aef3691aadda
--- /dev/null
+++ b/games-action/atanks/atanks-6.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/atanks-6.1.ebuild,v 1.1 2015/01/14 06:08:19 mr_bones_ Exp $
+
+EAPI=5
+inherit eutils gnome2-utils games
+
+DESCRIPTION="Worms and Scorched Earth-like game"
+HOMEPAGE="http://atanks.sourceforge.net/"
+SRC_URI="mirror://sourceforge/atanks/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/allegro:0[X]"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ find . -type f -name ".directory" -exec rm -vf '{}' +
+}
+
+src_compile() {
+ emake \
+ BINDIR="${GAMES_BINDIR}" \
+ INSTALLDIR="${GAMES_DATADIR}/${PN}"
+}
+
+src_install() {
+ dogamesbin ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r button misc missile sound stock tank tankgun text title unicode.dat *.txt
+ doicon -s 48 ${PN}.png
+ make_desktop_entry atanks "Atomic Tanks"
+ dodoc Changelog README TODO
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}