summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-04-20 09:19:43 +0000
committerMike Frysinger <vapier@gentoo.org>2008-04-20 09:19:43 +0000
commitefde2f7afb03971e0f832abb644909afdb56986f (patch)
tree472fd8ea8ace92532aa225c112cc14a680b0951b /games-action
parentVersion bump. (diff)
downloadgentoo-2-efde2f7afb03971e0f832abb644909afdb56986f.tar.gz
gentoo-2-efde2f7afb03971e0f832abb644909afdb56986f.tar.bz2
gentoo-2-efde2f7afb03971e0f832abb644909afdb56986f.zip
Fix from Debian for building with gcc-4.3 #217944 by Peter Alfredsen.
(Portage version: 2.2_pre5)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/btanks/ChangeLog6
-rw-r--r--games-action/btanks/btanks-0.7.5800.ebuild3
-rw-r--r--games-action/btanks/files/btanks-0.7.5800-gcc43.patch91
3 files changed, 98 insertions, 2 deletions
diff --git a/games-action/btanks/ChangeLog b/games-action/btanks/ChangeLog
index 22ed360e6c6b..0a6426529cf8 100644
--- a/games-action/btanks/ChangeLog
+++ b/games-action/btanks/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/btanks
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/ChangeLog,v 1.11 2008/03/28 22:46:26 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/ChangeLog,v 1.12 2008/04/20 09:19:43 vapier Exp $
+
+ 20 Apr 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/btanks-0.7.5800-gcc43.patch, btanks-0.7.5800.ebuild:
+ Fix from Debian for building with gcc-4.3 #217944 by Peter Alfredsen.
28 Mar 2008; Markus Meier <maekke@gentoo.org> btanks-0.7.5800.ebuild:
x86 stable, bug #214429
diff --git a/games-action/btanks/btanks-0.7.5800.ebuild b/games-action/btanks/btanks-0.7.5800.ebuild
index f1789fc74bd4..cbe027e93005 100644
--- a/games-action/btanks/btanks-0.7.5800.ebuild
+++ b/games-action/btanks/btanks-0.7.5800.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/btanks-0.7.5800.ebuild,v 1.5 2008/03/28 22:46:26 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/btanks-0.7.5800.ebuild,v 1.6 2008/04/20 09:19:43 vapier Exp $
inherit eutils games
@@ -29,6 +29,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-scons-blows.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch #217944
}
src_compile() {
diff --git a/games-action/btanks/files/btanks-0.7.5800-gcc43.patch b/games-action/btanks/files/btanks-0.7.5800-gcc43.patch
new file mode 100644
index 000000000000..c6515b62d940
--- /dev/null
+++ b/games-action/btanks/files/btanks-0.7.5800-gcc43.patch
@@ -0,0 +1,91 @@
+sniped from Debian to fix building with gcc-4.3
+
+http://bugs.gentoo.org/217944
+
+--- btanks-0.7.5800/mrt/udp_socket.cpp
++++ btanks-0.7.5800/mrt/udp_socket.cpp
+@@ -22,6 +22,7 @@
+ # endif
+ #endif
+
++#include <cstring>
+
+ using namespace mrt;
+
+--- btanks-0.7.5800/mrt/sys_socket.cpp
++++ btanks-0.7.5800/mrt/sys_socket.cpp
+@@ -27,6 +27,7 @@
+ # include <unistd.h>
+ #endif
+
++#include <cstring>
+
+ using namespace mrt;
+
+--- btanks-0.7.5800/mrt/lang.cpp
++++ btanks-0.7.5800/mrt/lang.cpp
+@@ -8,6 +8,9 @@
+ #include "lang.h"
+ #include "logger.h"
+
++#include <cstdlib>
++#include <cstring>
++
+ const std::string mrt::getLanguageCode() {
+ #ifdef WIN32
+ LANGID lang_id = GetUserDefaultLangID();
+--- btanks-0.7.5800/mrt/serializator.cpp
++++ btanks-0.7.5800/mrt/serializator.cpp
+@@ -31,6 +31,8 @@
+ #include <limits.h>
+ #include "exception.h"
+
++#include <cstring>
++
+ #ifdef WIN32
+ # ifndef uint32_t
+ # define uint32_t unsigned __int32
+--- btanks-0.7.5800/menu/menu_config.cpp
++++ btanks-0.7.5800/menu/menu_config.cpp
+@@ -24,6 +24,8 @@
+ #include "mrt/b64.h"
+ #include "config.h"
+
++#include <cstring>
++
+ IMPLEMENT_SINGLETON(MenuConfig, IMenuConfig);
+
+ void SlotConfig::serialize(mrt::Serializator &s) const {
+--- btanks-0.7.5800/src/i18n.cpp
++++ btanks-0.7.5800/src/i18n.cpp
+@@ -20,6 +20,8 @@
+ #include "mrt/exception.h"
+ #include <assert.h>
+
++#include <cstring>
++
+ IMPLEMENT_SINGLETON(I18n, II18n);
+
+ bool lessnocase::operator()(const std::string& s1, const std::string& s2) const {
+--- btanks-0.7.5800/src/var.cpp
++++ btanks-0.7.5800/src/var.cpp
+@@ -21,6 +21,8 @@
+ #include "mrt/serializator.h"
+ #include <assert.h>
+
++#include <cstdlib>
++
+ void Var::serialize(mrt::Serializator &s) const {
+ if (type.empty())
+ throw_ex(("cannot serialize empty variable"));
+--- btanks-0.7.5800/objects/trooper.cpp
++++ btanks-0.7.5800/objects/trooper.cpp
+@@ -24,6 +24,8 @@
+ #include "config.h"
+ #include "trooper.h"
+
++#include <cstring>
++
+ void Trooper::getImpassabilityPenalty(const float impassability, float &base, float &base_value, float &penalty) const {
+ if (impassability > 0.2f) {
+ base_value = 0.2f;