summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:22 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:22 +0000
commitf0759f77429dfcff11fdeb040d0553dd1e8e0bd8 (patch)
treebc451cfc4f19d245b0c6a7f10e547fdc2006db52 /games-arcade/bub-n-bros/bub-n-bros-1.1.ebuild
parentaction games ! (diff)
downloadgentoo-2-f0759f77429dfcff11fdeb040d0553dd1e8e0bd8.tar.gz
gentoo-2-f0759f77429dfcff11fdeb040d0553dd1e8e0bd8.tar.bz2
gentoo-2-f0759f77429dfcff11fdeb040d0553dd1e8e0bd8.zip
arcade games !
Diffstat (limited to 'games-arcade/bub-n-bros/bub-n-bros-1.1.ebuild')
-rw-r--r--games-arcade/bub-n-bros/bub-n-bros-1.1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/games-arcade/bub-n-bros/bub-n-bros-1.1.ebuild b/games-arcade/bub-n-bros/bub-n-bros-1.1.ebuild
new file mode 100644
index 000000000000..640e3ea31060
--- /dev/null
+++ b/games-arcade/bub-n-bros/bub-n-bros-1.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/bub-n-bros/bub-n-bros-1.1.ebuild,v 1.1 2003/09/10 19:29:21 vapier Exp $
+
+inherit games
+
+DESCRIPTION="A multiplayer clone of the famous Bubble Bobble game"
+HOMEPAGE="http://bub-n-bros.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=">=dev-lang/python-2.2*"
+RDEPEND=">=dev-python/pygame-1.5.5"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ # Compile the "statesaver" extension module to enable the Clock bonus
+ cd ${S}/bubbob
+ python setup.py build_ext -i || die
+
+ # Compile the extension module required for the X Window client
+ cd ${S}/display
+ python setup.py build_ext -i || die
+}
+
+src_install() {
+ local dir=${GAMES_LIBDIR}/${PN}
+
+ exeinto ${dir}
+ doexe *.py
+
+ insinto ${dir}
+ cp -r bubbob common display java ${D}/${dir}/
+
+ dodir ${GAMES_BINDIR}
+ dosym ${dir}/pclient-pygame.py ${GAMES_BINDIR}/bubnbros
+ dosym ${dir}/pclient-xshm.py ${GAMES_BINDIR}/bubnbros-x
+ dosym ${dir}/pclient-slow-X.py ${GAMES_BINDIR}/bubnbros-slowx
+
+ dogamesbin ${FILESDIR}/bubnbros-server
+ dosed "s:GENTOO_DIR:${dir}/bubbob/:" ${GAMES_BINDIR}/bubnbros-server
+
+ dodoc INSTALL.txt
+ dohtml *.html
+
+ find ${D}/${dir} -name CVS -type d -exec rm -rf '{}' \; 2> /dev/null
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ echo
+ einfo "First you must start a server by running \`bubnbros-server\`."
+ einfo "Afterwards you can start the client by running \`bubnbros\`"
+ einfo "or \`bubnbros-x\`. Note that the X version of the game"
+ einfo "doesn't support sound and music."
+
+ games_pkg_postinst
+}