summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-03-15 21:31:23 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-03-15 21:31:23 +0000
commite5c6b66ac9aa4afa3094dd6a7a8eef1143168e8e (patch)
treee42457940752f6789b41398e601972d541dc0e9c /games-arcade/defendguin
parentInstall menu entry, bug #159771 (diff)
downloadgentoo-2-e5c6b66ac9aa4afa3094dd6a7a8eef1143168e8e.tar.gz
gentoo-2-e5c6b66ac9aa4afa3094dd6a7a8eef1143168e8e.tar.bz2
gentoo-2-e5c6b66ac9aa4afa3094dd6a7a8eef1143168e8e.zip
Install menu entry, bug #160204
(Portage version: 2.1.2.2)
Diffstat (limited to 'games-arcade/defendguin')
-rw-r--r--games-arcade/defendguin/ChangeLog7
-rw-r--r--games-arcade/defendguin/defendguin-0.0.11.ebuild26
-rw-r--r--games-arcade/defendguin/files/0.0.11-makefile.patch29
3 files changed, 23 insertions, 39 deletions
diff --git a/games-arcade/defendguin/ChangeLog b/games-arcade/defendguin/ChangeLog
index 595dac3477da..a28591be6137 100644
--- a/games-arcade/defendguin/ChangeLog
+++ b/games-arcade/defendguin/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/defendguin
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/defendguin/ChangeLog,v 1.10 2006/10/02 02:59:32 dang Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/defendguin/ChangeLog,v 1.11 2007/03/15 21:31:23 nyhm Exp $
+
+ 15 Mar 2007; Tristan Heaven <nyhm@gentoo.org> defendguin-0.0.11.ebuild:
+ Install menu entry, bug #160204
02 Oct 2006; Daniel Gryniewicz <dang@gentoo.org> defendguin-0.0.11.ebuild:
Marked stable on amd64 For bug #149769
diff --git a/games-arcade/defendguin/defendguin-0.0.11.ebuild b/games-arcade/defendguin/defendguin-0.0.11.ebuild
index 3a41a998a9f5..a9e1581d84c6 100644
--- a/games-arcade/defendguin/defendguin-0.0.11.ebuild
+++ b/games-arcade/defendguin/defendguin-0.0.11.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/defendguin/defendguin-0.0.11.ebuild,v 1.4 2006/10/02 02:59:32 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/defendguin/defendguin-0.0.11.ebuild,v 1.5 2007/03/15 21:31:23 nyhm Exp $
+
+inherit eutils toolchain-funcs games
-inherit eutils games
DESCRIPTION="A clone of the arcade game Defender, but with a Linux theme"
HOMEPAGE="http://www.newbreedsoftware.com/defendguin/"
-SRC_URI="ftp://ftp.billsgames.com/unix/x/defendguin/src/${P}.tar.gz"
+SRC_URI="ftp://ftp.billsgames.com/unix/x/${PN}/src/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -17,7 +18,7 @@ DEPEND="media-libs/sdl-mixer
pkg_setup() {
if ! built_with_use media-libs/sdl-mixer mikmod; then
- die "You need to build media-libs/sdl-mixer with mikmod USE flag enabled!"
+ die "Please build media-libs/sdl-mixer with USE=mikmod"
fi
games_pkg_setup
}
@@ -25,13 +26,22 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${PV}-makefile.patch"
+ sed -i \
+ -e "1i CC=$(tc-getCC)" \
+ -e "s:\$(DATA_PREFIX):${GAMES_DATADIR}/${PN}/:" \
+ -e "s:-Wall:-Wall ${CFLAGS}:" \
+ Makefile \
+ || die "sed failed"
rm -f data/images/*.sh
}
src_install() {
- dogamesbin defendguin || die "dogamesbin failed"
- insinto "${GAMES_DATADIR}/${PN}"
+ dogamesbin ${PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
doins -r ./data/* || die "doins failed"
+ newicon data/images/ufo/ufo0.bmp ${PN}.bmp
+ make_desktop_entry ${PN} Defendguin /usr/share/pixmaps/${PN}.bmp
+ doman src/${PN}.6
+ dodoc docs/{AUTHORS,CHANGES,README,TODO}.txt
prepgamesdirs
}
diff --git a/games-arcade/defendguin/files/0.0.11-makefile.patch b/games-arcade/defendguin/files/0.0.11-makefile.patch
deleted file mode 100644
index bb61b8c437ba..000000000000
--- a/games-arcade/defendguin/files/0.0.11-makefile.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- Makefile.orig 2002-01-06 02:09:37.000000000 +0100
-+++ Makefile 2004-09-14 22:03:45.525993936 +0200
-@@ -9,12 +9,12 @@
-
- # User-definable stuff:
-
--CFLAGS=-Wall -O2
-+#CFLAGS=-Wall -O2
- #DATA_PREFIX=$(PWD)/data/
--PREFIX=/usr/local
--MAN_PREFIX=$(PREFIX)
--BIN_PREFIX=$(PREFIX)/bin
--DATA_PREFIX=$(PREFIX)/share/defendguin/
-+PREFIX=/usr/share
-+MAN_PREFIX=$(PREFIX)/man
-+BIN_PREFIX=/usr/games/bin
-+DATA_PREFIX=$(PREFIX)/games/defendguin/
- JOY=YES
-
-
-@@ -24,7 +24,7 @@
- SDL_LDFLAGS := $(shell sdl-config --libs) -L/usr/X11R6/lib
- MIXER=-lSDL_mixer
- NOSOUNDFLAG=__SOUND
--CFLAGS=-Wall $(SDL_CFLAGS) -DDATA_PREFIX=\"$(DATA_PREFIX)\" -D$(NOSOUNDFLAG) \
-+CFLAGS+=-Wall $(SDL_CFLAGS) -DDATA_PREFIX=\"$(DATA_PREFIX)\" -D$(NOSOUNDFLAG) \
- -DJOY_$(JOY)
- SDL_LIB=$(SDL_LDFLAGS) $(MIXER)
-