summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-11-16 17:43:00 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-11-16 17:43:00 +0000
commitba85b09c510165d5734beefaf32b60c248fe4cf4 (patch)
treef867173fa5a94e07606ff1cc386d58f877649165 /games-arcade/holotz-castle/files
parentCleanup and added media-sound/specimen, gnome-extra/hal-device-manager (diff)
downloadgentoo-2-ba85b09c510165d5734beefaf32b60c248fe4cf4.tar.gz
gentoo-2-ba85b09c510165d5734beefaf32b60c248fe4cf4.tar.bz2
gentoo-2-ba85b09c510165d5734beefaf32b60c248fe4cf4.zip
version bump - patch supplied by Robert Lundmark via bug #112621
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'games-arcade/holotz-castle/files')
-rw-r--r--games-arcade/holotz-castle/files/digest-holotz-castle-1.3.71
-rw-r--r--games-arcade/holotz-castle/files/holotz-castle-1.3.7-build.patch54
2 files changed, 55 insertions, 0 deletions
diff --git a/games-arcade/holotz-castle/files/digest-holotz-castle-1.3.7 b/games-arcade/holotz-castle/files/digest-holotz-castle-1.3.7
new file mode 100644
index 000000000000..c3f8f516cbe1
--- /dev/null
+++ b/games-arcade/holotz-castle/files/digest-holotz-castle-1.3.7
@@ -0,0 +1 @@
+MD5 571be7f4dadf81f0eb5df7bee65d215b holotz-castle-1.3.7-src.tar.gz 3612543
diff --git a/games-arcade/holotz-castle/files/holotz-castle-1.3.7-build.patch b/games-arcade/holotz-castle/files/holotz-castle-1.3.7-build.patch
new file mode 100644
index 000000000000..4c5f06b0cc30
--- /dev/null
+++ b/games-arcade/holotz-castle/files/holotz-castle-1.3.7-build.patch
@@ -0,0 +1,54 @@
+--- JLib/Makefile
++++ JLib/Makefile
+@@ -15,22 +15,21 @@
+ $(UTIL)/JApp.o $(UTIL)/JFS.o $(UTIL)/JThread.o $(UTIL)/JRW.o $(MATH)/J2DPolygon.o
+
+ # Definir -D_JLIB_DEBUG para hacer debug de JLib. Compilar el programa a debugear también con este flag
+-CFLAGS=-I. -O3 -ffast-math -fPIC -Wall -Wshadow -Winline
+-LDFLAGS=-L. -ffast-math -lSDL -lSDL_image -lSDL_ttf -lSDL_mixer
++ CXXFLAGS=-I. $(CPU_OPTS)
++ LDFLAGS=-L. -lSDL -lSDL_image -lSDL_ttf -lSDL_mixer
+
+ all: libJLib
+
+ # JLib
+ libJLib: $(JLIB_OBJS)
+- g++ -shared -fPIC -o $@.so $? \
+- && ar rvus $@.a $? \
++ ar rvus $@.a $?
+
+ $(GRAPHICS)/%.o: $(GRAPHICS)/%.cpp
+- g++ $(CFLAGS) -c -o $@ $<
++ $(CXX) $(CXXFLAGS) -c -o $@ $<
+ $(UTIL)/%.o: $(UTIL)/%.cpp
+- g++ $(CFLAGS) -c -o $@ $<
++ $(CXX) $(CXXFLAGS) -c -o $@ $<
+ $(MATH)/%.o: $(MATH)/%.cpp
+- g++ $(CFLAGS) -c -o $@ $<
++ $(CXX) $(CXXFLAGS) -c -o $@ $<
+
+ .PHONY: install
+ install:
+
+--- src/Makefile
++++ src/Makefile
+@@ -26,7 +26,7 @@
+
+ DEFINES = -DHC_DATA_DIR=\"$(HC_DATA)\" -DHCED_DATA_DIR=\"$(HCED_DATA)\"
+
+-all: JLib HC HCed
++all: HC HCed
+
+ HC_OBJ_MAIN=HolotzCastle.o
+ HC_OBJS=HCUtil.o HCTimer.o HCLoadSaveSlot.o HCPlaylist.o HCPreferences.o HCTheme.o HCText.o \
+@@ -38,8 +38,8 @@
+
+ # Definir -D_JLIB_DEBUG para debug con JLib. Ponerlo también en el Makefile de JLib.
+ # Define -D_JLIB_DEBUG for JLib debug mode. Put it also in JLib's Makefile.
+-CFLAGS=-I. -I../JLib -O3 -Wall -Werror -Wshadow $(CPU_OPTS) -ffast-math -c $(shell sdl-config --cflags)
+-LDFLAGS=-L/usr/X11R6/lib -ffast-math -lSDL -lSDL_image -lSDL_mixer -lSDL_ttf
++CFLAGS=-Wshadow $(CPU_OPTS) -c -I. -I../JLib $(shell sdl-config --cflags)
++LDFLAGS=-lSDL -lSDL_image -lSDL_mixer -lSDL_ttf -lGL -lGLU
+
+ JLib:
+ make -C ../JLib;