summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-02-19 04:38:18 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-02-19 04:38:18 +0000
commitae48ad86c718ab673d577a13570adf675f74fe28 (patch)
treebef5fc32146a97332a66d75d5c821f3102cbe3ae /games-arcade/xgalaga
parentRemoved old ebuilds (diff)
downloadgentoo-2-ae48ad86c718ab673d577a13570adf675f74fe28.tar.gz
gentoo-2-ae48ad86c718ab673d577a13570adf675f74fe28.tar.bz2
gentoo-2-ae48ad86c718ab673d577a13570adf675f74fe28.zip
version bump - ebuild submitted by Victor Ostorga via bug #259549
(Portage version: 2.1.6.4/cvs/Linux 2.6.28.1 i686)
Diffstat (limited to 'games-arcade/xgalaga')
-rw-r--r--games-arcade/xgalaga/ChangeLog8
-rw-r--r--games-arcade/xgalaga/xgalaga-2.1.1.0.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/games-arcade/xgalaga/ChangeLog b/games-arcade/xgalaga/ChangeLog
index 5ee763add74e..a9d28ebd9fd7 100644
--- a/games-arcade/xgalaga/ChangeLog
+++ b/games-arcade/xgalaga/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-arcade/xgalaga
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/xgalaga/ChangeLog,v 1.13 2009/02/02 13:26:38 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xgalaga/ChangeLog,v 1.14 2009/02/19 04:38:18 mr_bones_ Exp $
+
+*xgalaga-2.1.1.0 (19 Feb 2009)
+
+ 19 Feb 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +xgalaga-2.1.1.0.ebuild:
+ version bump - ebuild submitted by Victor Ostorga via bug #259549
02 Feb 2009; Alfredo Tupone <tupone@gentoo.org>
+files/xgalaga-2.0.34-as-needed.patch, xgalaga-2.0.34-r6.ebuild:
diff --git a/games-arcade/xgalaga/xgalaga-2.1.1.0.ebuild b/games-arcade/xgalaga/xgalaga-2.1.1.0.ebuild
new file mode 100644
index 000000000000..55b17afa36c2
--- /dev/null
+++ b/games-arcade/xgalaga/xgalaga-2.1.1.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xgalaga/xgalaga-2.1.1.0.ebuild,v 1.1 2009/02/19 04:38:18 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="A clone of the classic game Galaga for the X Window System"
+HOMEPAGE="http://sourceforge.net/projects/xgalaga"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXext
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_prepare() {
+ sed -i \
+ -e "/LEVELDIR\|SOUNDDIR/ s:prefix:datadir/${PN}:" \
+ -e "/\/scores/ s:prefix:localstatedir/${PN}:" \
+ configure \
+ || die "sed configure failed"
+ sed -i \
+ -e "/SOUNDDEFS/ s:(SOUNDSRVDIR):(SOUNDSRVDIR)/bin:" \
+ -e 's:make ;:$(MAKE) ;:' \
+ Makefile.in \
+ || die "sed Makefile.in failed"
+}
+
+src_install() {
+ dogamesbin xgalaga xgal.sndsrv.oss xgalaga-hyperspace || die "dogamesbin failed"
+ dodoc README README.SOUND CHANGES
+ newman xgalaga.6x xgalaga.6
+
+ insinto "${GAMES_DATADIR}/${PN}/sounds"
+ doins sounds/*.raw || die "doins failed"
+
+ insinto "${GAMES_DATADIR}/${PN}/levels"
+ doins levels/*.xgl || die "doins failed"
+
+ make_desktop_entry ${PN} XGalaga
+
+ dodir "${GAMES_STATEDIR}/${PN}"
+ touch "${D}${GAMES_STATEDIR}/${PN}/scores"
+ fperms 660 "${GAMES_STATEDIR}/${PN}/scores"
+ prepgamesdirs
+}