summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-03-25 03:04:05 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-03-25 03:04:05 +0000
commit165e30ea92063605f664819c8f31b8432dd26974 (patch)
tree4518d8b5d39fd70ab264c526a9ffde84100c9cff /games-arcade
parentTake an orphaned package (diff)
downloadgentoo-2-165e30ea92063605f664819c8f31b8432dd26974.tar.gz
gentoo-2-165e30ea92063605f664819c8f31b8432dd26974.tar.bz2
gentoo-2-165e30ea92063605f664819c8f31b8432dd26974.zip
EAPI=5
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/gunocide2ex/ChangeLog7
-rw-r--r--games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild37
2 files changed, 22 insertions, 22 deletions
diff --git a/games-arcade/gunocide2ex/ChangeLog b/games-arcade/gunocide2ex/ChangeLog
index 121eedd28385..74a38ed90c6d 100644
--- a/games-arcade/gunocide2ex/ChangeLog
+++ b/games-arcade/gunocide2ex/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/gunocide2ex
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/gunocide2ex/ChangeLog,v 1.13 2012/02/05 06:20:50 vapier Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/gunocide2ex/ChangeLog,v 1.14 2015/03/25 03:04:05 mr_bones_ Exp $
+
+ 25 Mar 2015; Michael Sterrett <mr_bones_@gentoo.org> gunocide2ex-1.0.ebuild:
+ EAPI=5
05 Feb 2012; Mike Frysinger <vapier@gentoo.org> gunocide2ex-1.0.ebuild:
Move to new unpacker eclass for unpack_makeself.
diff --git a/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild b/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild
index e5cc8cc8af22..90c82ffb1d15 100644
--- a/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild
+++ b/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild,v 1.15 2012/02/05 06:20:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild,v 1.16 2015/03/25 03:04:05 mr_bones_ Exp $
-EAPI=2
+EAPI=5
inherit eutils unpacker toolchain-funcs games
DESCRIPTION="fast-paced 2D shoot'em'up"
-HOMEPAGE="http://www.polyfrag.com/content/product_gunocide.html"
+HOMEPAGE="http://g2ex.sourceforge.net/"
SRC_URI="mirror://sourceforge/g2ex/g2ex-setup.run"
LICENSE="GPL-2"
@@ -17,12 +17,13 @@ IUSE=""
DEPEND="media-libs/libsdl[video]
media-libs/sdl-ttf
media-libs/sdl-mixer[vorbis]"
+RDEPEND=${DEPEND}
S=${WORKDIR}
src_unpack() {
unpack_makeself
- mkdir binary
+ mkdir binary || die
}
src_prepare() {
@@ -34,33 +35,29 @@ src_prepare() {
-e "s:/usr/local/games/gunocide2ex/config\.cfg:${GAMES_SYSCONFDIR}/${PN}.cfg:" \
-e "s:/usr/local/games/gunocide2ex/hscore\.dat:${GAMES_STATEDIR}/${PN}-hscore.dat:" \
-e "s:memleaks.log:/dev/null:" \
- src/*.{h,cpp} \
- || die "sed failed"
+ src/*.{h,cpp} || die
sed -i \
-e "s:/usr/local/games:${GAMES_DATADIR}:" \
- src/*.{h,cpp} $(find gfx -name '*.txt') \
- || die "sed failed"
+ src/*.{h,cpp} $(find gfx -name '*.txt') || die
}
src_compile() {
cd src
- emake CXXFLAGS="$CXXFLAGS $(sdl-config --cflags)" $(echo *.cpp | sed 's/\.cpp/.o/g') \
- || die "emake failed"
- $(tc-getCXX) ${CXXFLAGS} ${LDFLAGS} -o ${PN} *.o -lpthread -lSDL -lSDL_ttf -lSDL_mixer \
- || die "cxx failed"
+ emake CXXFLAGS="$CXXFLAGS $(sdl-config --cflags)" $(echo *.cpp | sed 's/\.cpp/.o/g')
+ $(tc-getCXX) ${CXXFLAGS} ${LDFLAGS} -o ${PN} *.o -lpthread -lSDL -lSDL_ttf -lSDL_mixer || die
}
src_install() {
- dogamesbin src/${PN} || die "dogamesbin failed"
- dosym ${PN} "${GAMES_BINDIR}/g2ex" || die "dosym failed"
+ dogamesbin src/${PN}
+ dosym ${PN} "${GAMES_BINDIR}/g2ex"
insinto "${GAMES_DATADIR}/${PN}"
- doins -r gfx sfx lvl credits arial.ttf || die "doins failed"
+ doins -r gfx sfx lvl credits arial.ttf
insinto "${GAMES_SYSCONFDIR}"
- newins config.cfg ${PN}.cfg || die "newins failed (cfg)"
+ newins config.cfg ${PN}.cfg
insinto "${GAMES_STATEDIR}"
- newins hscore.dat ${PN}-hscore.dat || die "newins failed (hscore)"
- dodoc history doc/MANUAL_DE || die "dodoc failed"
- dohtml doc/manual_de.html || die "dohtml failed"
+ newins hscore.dat ${PN}-hscore.dat
+ dodoc history doc/MANUAL_DE
+ dohtml doc/manual_de.html
newicon g2icon.xpm ${PN}.xpm
make_desktop_entry ${PN} "Gunocide II EX"
prepgamesdirs