summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-02-03 08:27:24 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-02-03 08:27:24 +0000
commit5d28eb47ed9c9bf72b229111aec18d338bcc4172 (patch)
treeffabe91211738278db0a758933fdec2b8e65d3a1 /games-board/ace
parentVersion bump (diff)
downloadgentoo-2-5d28eb47ed9c9bf72b229111aec18d338bcc4172.tar.gz
gentoo-2-5d28eb47ed9c9bf72b229111aec18d338bcc4172.tar.bz2
gentoo-2-5d28eb47ed9c9bf72b229111aec18d338bcc4172.zip
Fix --as-needed bug #247334
(Portage version: 2.1.6.4/cvs/Linux 2.6.27-gentoo-r8 x86_64)
Diffstat (limited to 'games-board/ace')
-rw-r--r--games-board/ace/ChangeLog8
-rw-r--r--games-board/ace/ace-1.2-r2.ebuild10
-rw-r--r--games-board/ace/files/ace-1.2-as-needed.patch39
3 files changed, 50 insertions, 7 deletions
diff --git a/games-board/ace/ChangeLog b/games-board/ace/ChangeLog
index ee7a020a75e0..45d0409fca24 100644
--- a/games-board/ace/ChangeLog
+++ b/games-board/ace/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/ace
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/ace/ChangeLog,v 1.17 2008/11/17 21:01:07 flameeyes Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/ace/ChangeLog,v 1.18 2009/02/03 08:27:18 tupone Exp $
+
+ 03 Feb 2009; Alfredo Tupone <tupone@gentoo.org>
+ +files/ace-1.2-as-needed.patch, ace-1.2-r2.ebuild:
+ Fix --as-needed bug #247334 by flameeyes@gentoo.org
17 Nov 2008; Diego E. Pettenò <flameeyes@gentoo.org>
files/ace-1.2-mastermind-keys.patch:
diff --git a/games-board/ace/ace-1.2-r2.ebuild b/games-board/ace/ace-1.2-r2.ebuild
index 8adacadddec3..fe74f6f8dcbb 100644
--- a/games-board/ace/ace-1.2-r2.ebuild
+++ b/games-board/ace/ace-1.2-r2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/ace/ace-1.2-r2.ebuild,v 1.1 2007/07/22 12:23:59 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/ace/ace-1.2-r2.ebuild,v 1.2 2009/02/03 08:27:18 tupone Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="DJ Delorie's Ace of Penguins solitaire games"
@@ -17,10 +18,9 @@ DEPEND="x11-libs/libXpm
media-libs/libpng
!games-misc/bsd-games"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch \
+ "${FILESDIR}"/${P}-as-needed.patch \
"${FILESDIR}"/${P}-check_for_end_of_game.patch \
"${FILESDIR}"/${P}-gcc41.patch \
"${FILESDIR}"/${P}-mastermind-keys.patch
diff --git a/games-board/ace/files/ace-1.2-as-needed.patch b/games-board/ace/files/ace-1.2-as-needed.patch
new file mode 100644
index 000000000000..0ec796eea6b3
--- /dev/null
+++ b/games-board/ace/files/ace-1.2-as-needed.patch
@@ -0,0 +1,39 @@
+--- lib/Makefile.in.old 2009-02-03 09:04:55.000000000 +0100
++++ lib/Makefile.in 2009-02-03 09:08:37.000000000 +0100
+@@ -85,7 +85,6 @@
+ CLEANFILES = images.c images.d
+
+ INCLUDES = $(X_CFLAGS) @PDA@
+-LDFLAGS = $(X_LIBS)
+
+ BUILD_CC = @BUILD_CC@
+ AR = @AR@
+@@ -107,7 +106,7 @@
+ X_LIBS = @X_LIBS@
+ X_EXTRA_LIBS = @X_EXTRA_LIBS@
+ X_PRE_LIBS = @X_PRE_LIBS@
+-libcards_la_LIBADD =
++libcards_la_LIBADD = -lpng -lX11
+ libcards_la_OBJECTS = table.lo help.lo stack.lo imagelib.lo xwin.lo \
+ images.lo table_ai.lo table_ck.lo table_dc.lo table_dg.lo table_dp.lo \
+ table_in.lo table_ky.lo table_rd.lo table_rn.lo table_rs.lo
+--- games/Makefile.in.old 2009-02-03 09:07:26.000000000 +0100
++++ games/Makefile.in 2009-02-03 09:07:35.000000000 +0100
+@@ -90,7 +90,6 @@
+ STRIP = @STRIP@
+
+ INCLUDES = -I$(srcdir)/../lib $(X_CFLAGS) @PDA@
+-LDFLAGS = $(X_LIBS)
+
+ canfield_SOURCES = canfield.c canfield-img.c
+ freecell_SOURCES = freecell.c freecell-help.c freecell-img.c
+--- tests/Makefile.in.old 2009-02-03 09:10:36.000000000 +0100
++++ tests/Makefile.in 2009-02-03 09:10:47.000000000 +0100
+@@ -85,7 +85,6 @@
+ test6_SOURCES = test6.c test6c.c
+
+ INCLUDES = -I$(srcdir)/../lib $(X_CFLAGS) @PDA@
+-LDFLAGS = $(X_LIBS)
+ LDADD = ../lib/libcards.la -lpng -lz -lX11 -lm
+
+ EXTRA_DIST = test6.png