summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-12-09 10:25:17 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-12-09 10:25:17 +0000
commitc42f37c91658fde8d9bee5be854b1886af3710dd (patch)
tree2fc6d75dce48ed020e63913c46fe4bb1c58ed0c5 /games-board/crafty
parentfix DirectFB depend to 1.0.0 only (diff)
downloadgentoo-2-c42f37c91658fde8d9bee5be854b1886af3710dd.tar.gz
gentoo-2-c42f37c91658fde8d9bee5be854b1886af3710dd.tar.bz2
gentoo-2-c42f37c91658fde8d9bee5be854b1886af3710dd.zip
Fix problem on x86_64 platform. Bug #195918 & Bug #201630
(Portage version: 2.1.3.19)
Diffstat (limited to 'games-board/crafty')
-rw-r--r--games-board/crafty/ChangeLog7
-rw-r--r--games-board/crafty/crafty-21.6.ebuild10
2 files changed, 14 insertions, 3 deletions
diff --git a/games-board/crafty/ChangeLog b/games-board/crafty/ChangeLog
index a9a75aabb864..b86a1b08dcd2 100644
--- a/games-board/crafty/ChangeLog
+++ b/games-board/crafty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/crafty
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/ChangeLog,v 1.22 2007/12/07 22:33:56 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/ChangeLog,v 1.23 2007/12/09 10:25:17 tupone Exp $
+
+ 09 Dec 2007; <atupone@gentoo.org> crafty-21.6.ebuild:
+ Fix problem on x86_64 platform.
+ Bug #195918 by HTS.
+ Bug #201630 by Chris Smith
*crafty-21.6 (07 Dec 2007)
diff --git a/games-board/crafty/crafty-21.6.ebuild b/games-board/crafty/crafty-21.6.ebuild
index f2dc99276ac6..779780ae428a 100644
--- a/games-board/crafty/crafty-21.6.ebuild
+++ b/games-board/crafty/crafty-21.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-21.6.ebuild,v 1.1 2007/12/07 22:33:56 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-21.6.ebuild,v 1.2 2007/12/09 10:25:17 tupone Exp $
inherit flag-o-matic games
@@ -52,7 +52,13 @@ src_compile() {
-DFAST -DSMP -DCPUS=4 -DCLONE -DDGT
append-flags -fno-gcse \
-fomit-frame-pointer -mpreferred-stack-boundary=2
- makeopts="${makeopts} CC=gcc CXX=g++ asm=X86.o"
+ makeopts="${makeopts} CC=gcc CXX=g++"
+ elif [[ "${CHOST}" == "x86_64-pc-linux-gnu" ]] ; then
+ append-flags -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
+ -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B \
+ -DFAST -DSMP -DCPUS=4 -DCLONE -DDGT
+ append-flags -fomit-frame-pointer
+ makeopts="${makeopts} CC=gcc CXX=g++"
else
: # everything else :)
fi