summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-09-24 20:46:30 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-09-24 20:46:30 +0000
commit2f59381a8ead9c979b831d20d8d12697989bf597 (patch)
treef09cf6916d70dcebdb8a29653e5837fcb999cfc0 /games-board/xgammon
parentBump (diff)
downloadgentoo-2-2f59381a8ead9c979b831d20d8d12697989bf597.tar.gz
gentoo-2-2f59381a8ead9c979b831d20d8d12697989bf597.tar.bz2
gentoo-2-2f59381a8ead9c979b831d20d8d12697989bf597.zip
EAPI=2; get rid of X11R6 in the config for the database location (bug #286206)
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-board/xgammon')
-rw-r--r--games-board/xgammon/ChangeLog9
-rw-r--r--games-board/xgammon/files/xgammon-0.98-config.patch2
-rw-r--r--games-board/xgammon/xgammon-0.98.ebuild15
3 files changed, 16 insertions, 10 deletions
diff --git a/games-board/xgammon/ChangeLog b/games-board/xgammon/ChangeLog
index 0c57f3993642..67ad7eb380f2 100644
--- a/games-board/xgammon/ChangeLog
+++ b/games-board/xgammon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/xgammon
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/xgammon/ChangeLog,v 1.12 2009/01/30 05:38:12 mr_bones_ Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/xgammon/ChangeLog,v 1.13 2009/09/24 20:46:30 mr_bones_ Exp $
+
+ 24 Sep 2009; Michael Sterrett <mr_bones_@gentoo.org> xgammon-0.98.ebuild,
+ files/xgammon-0.98-config.patch:
+ EAPI=2; get rid of X11R6 in the config for the database location (bug
+ #286206)
30 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org> xgammon-0.98.ebuild:
look in . first to find db
diff --git a/games-board/xgammon/files/xgammon-0.98-config.patch b/games-board/xgammon/files/xgammon-0.98-config.patch
index d2e11bacfd81..363d1730933c 100644
--- a/games-board/xgammon/files/xgammon-0.98-config.patch
+++ b/games-board/xgammon/files/xgammon-0.98-config.patch
@@ -5,7 +5,7 @@
xgammon.stonesteps: 5
xgammon.delaytime: 5
-xgammon.database: lib/xgammon.db
-+xgammon.database: /usr/X11R6/lib/X11/xgammon/xgammon.db
++xgammon.database: /usr/lib/X11/xgammon/xgammon.db
--- xgammon-0.98/Imakefile.rhconfig Wed Aug 23 15:26:39 1995
+++ xgammon-0.98/Imakefile Wed Aug 12 18:42:55 1998
@@ -12,9 +12,9 @@
diff --git a/games-board/xgammon/xgammon-0.98.ebuild b/games-board/xgammon/xgammon-0.98.ebuild
index dc5d810f8b17..f7a6b7e8fbe5 100644
--- a/games-board/xgammon/xgammon-0.98.ebuild
+++ b/games-board/xgammon/xgammon-0.98.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/xgammon/xgammon-0.98.ebuild,v 1.12 2009/01/30 05:38:12 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/xgammon/xgammon-0.98.ebuild,v 1.13 2009/09/24 20:46:30 mr_bones_ Exp $
+EAPI=2
inherit eutils
DESCRIPTION="very nice backgammon game for X"
@@ -20,21 +21,21 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${P}a
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
epatch \
"${FILESDIR}/${P}-broken.patch" \
"${FILESDIR}/${P}-config.patch" \
"${FILESDIR}/gcc33.patch"
}
-src_compile() {
+src_configure() {
xmkmf || die "xmkmf died"
+}
+
+src_compile() {
env PATH=".:${PATH}" emake || die "emake failed"
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
}